Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

New tab "+" missing from tab bar with with 20 tabs or more

  • 11 respostas
  • 1 tem este problema
  • 211 visualizações
  • Última resposta por trgz

more options

After the latest update (117.0 64-bit) I now do not see the '+' sign in the tab bar. I have 40 tabs open (please, no negativity - it's always worked for me), but if I close all of the tabs it reappears. Re-open the original 42 tabs and it's gone again. Close them and it reappears, etc. Now for the fun bit: starting from scratch with a new window - the '+' is there, but open 20 more tabs and it goes.

After the latest update (117.0 64-bit) I now do not see the '+' sign in the tab bar. I have 40 tabs open (please, no negativity - it's always worked for me), but if I close all of the tabs it reappears. Re-open the original 42 tabs and it's gone again. Close them and it reappears, etc. Now for the fun bit: starting from scratch with a new window - the '+' is there, but open 20 more tabs and it goes.
Capturas de ecrã anexadas

Solução escolhida

You may have a userChrome.css file with CSS code that needs an update.

If you have this rule then remove it as it is no longer needed.

#tabbrowser-tabs { width: 100vw !important;}

Ler esta resposta no contexto 👍 6

Todas as respostas (11)

more options

Small bit of extra info: the Ctrl+ 'T' still works fine, to open a new tab, so it's not actually a limit

more options

Modificado por jonzn4SUSE a

more options

jonzn4SUSE said

Have a look at this. https://support.mozilla.org/en-US/questions/1372930

I'd seen that article already, thanks, but sadly that doesn't resolve my issue as the New Tab icon isn't available either (has it been removed since that article?)

more options

I assume you already tried the Restore Defaults option? Where did you get Firefox from? How about Firefox Refresh? Same issue under another user account?

more options

What security software are your running?

more options

It looks like your userChrome.css modifications are causing issues with the latest version. You can disable them by going to about:config in the address bar and changing toolkit.legacyUserProfileCustomizations.stylesheets to false then restarting the browser.

more options

zeroknight said

It looks like your userChrome.css modifications are causing issues with the latest version. You can disable them by going to about:config in the address bar and changing toolkit.legacyUserProfileCustomizations.stylesheets to false then restarting the browser.

But I like my customizations, and the problem only appears when I open 20 or more tabs, and that it has only just started happening (and Ctrl+'T' still works). In my mind a better solution would be to roll back to the previous version. But thanks for the reply - that's a useful bit of knowledge/detail :-)

more options

jonzn4SUSE said

What security software are your running?

Tons - doesn't explain why it only starts to happen with 20 or more tabs though...

jonzn4SUSE said

I assume you already tried the Restore Defaults option? Where did you get Firefox from? How about Firefox Refresh? Same issue under another user account?

Got my copy of Firefox from a dodgy looking guy in a pub! nah, just joshing, I installed last year fresh (IIRC) from the Mozzie site. To do both of those I'd have to go through the very painful process of getting Firefox back to the condition that I like it, with the necessary extensions, and their settings, and fiddle around with getting the Tabs where they really ought to be, ie in the correct place and not at the top of the page like some awful attempt at modernity/hipness. Happier, and easier, to roll it back...

more options

I've got the new tab icon back in my Toolbar (though not as a '+' in the Tabs bar) - I used that tip about setting toolkit.legacyUserProfileCustomizations.stylesheets to false, restarted FF, dragged the '+' off the Tabs bar into the pick list, turned toolkit.legacyUserProfileCustomizations.stylesheets to true, restarted FF and then dragged the 'New Tab' icon from the customization picklist into the Toolbar where it is now cluttering up my nice layout (its days are numbered!). TBH, being a bit old-school, I'm getting used to using Ctrl+'t' already and so I'll probably stick with that. It still seems crazy that once I pass 20+ tabs the '+' dissappears, but yet I can still continue to add new tabs using the icon, or Ctrl+'t', or right-clinking on any tab and selecting 'New Tab'. IMO this is another, albeit small, disappointing moment in the development of the only viable browser for the PC.

more options

Solução escolhida

You may have a userChrome.css file with CSS code that needs an update.

If you have this rule then remove it as it is no longer needed.

#tabbrowser-tabs { width: 100vw !important;}

Modificado por cor-el a

more options

cor-el said

You may have a userChrome.css file with CSS code that needs an update. If you have this rule then remove ot as it is no longer needed.
#tabbrowser-tabs { width: 100vw !important;}

Bingo! That was it. Many thanks!