Compatibilidade com tecnologias assistivas

Este artigo não é mais mantido, portanto o seu conteúdo pode estar desatualizado.

Neste documento pode encontrar uma lista de produtos de tecnologias assistivas e a sua compatibilidade com o Firefox.


Firefox 2.0.x

Windows

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Dragon Naturally Speaking 1-8|Comandos de voz e ditados|não compatível Dragon Naturally Speaking 9 or later|Comandos de voz e ditados|Compatível, com alguns problemas
Para mais dicas e detalhes, visite http://www.speechcomputing.com/node/942
Mouseless Browsing (Navegação sem rato) recomendado
Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Compatível Hal, Lunar, Supernova etc. (versões de demonstração disponíveis)|Leitor ecrã, ampliador de ecrã|Não compatível JAWS 1.x-6.x|Leitor ecrã|Não compatível JAWS 7.0|Leitor ecrã|Os mesmos problemas que o JAWS 7.1. Pensamos que para Suporte Técnico é necessário o JAWS 7.1. JAWS 7.1|Leitor ecrã|Compatível, com alguns problemas. Os problemas incluem:
A notificação de alterações ao formato de texto não está completa
Falhas ocasionais ou texto duplicado quando a ler o conteúdo de um documento
Falhas ocasionais quando a ler o título da página actual na lista de separadores de navegação.
Não funciona bem com páginas com molduras
Ocasionalmente perde a posição anterior quando se retrocede a uma página visitada, repondo a posição de leitura para o inicio do documento
Combinação de teclas em conflito com a navegação por separadores
Problemas de performance JAWS 8.0 (versão de demonstração disponível)|Leitor ecrã|Compatível, com alguns problemas. Os problemas incluem:
A notificação de alterações ao formato de texto não está completa
Falhas ocasionais ou texto duplicado quando a ler o conteúdo de um documento
Ocasionalmente perde a posição anterior quando se retrocede a uma página visitada, repondo a posição de leitura para o inicio do documento
Por favor visite a página dedicada à Compatibilidade JAWS-Firefox. MAGic (versão de demonstração disponível)|Ampliador de ecrã|desconhecido NVDA|Leitor de ecrã gratuito (código aberto)|Compatível. O autor refere que funciona bem, com a excepção da edição de campos de texto. Necessita de confirmação dos utilizadores. Window-Eyes 1.0-5.0|Leitor de ecrã|Não compatível Window-Eyes 5.5, Window-Eyes 6.0 (versão de demonstração disponível)|Leitor de ecrã|Compatível ZoomText 1-7|Ampliador de ecrã|Não compatível ZoomText 8.0x-8.11|Ampliador de ecrã|Sem AppReader/DocReader. Contornar o problema:
Inicie o ZoomText.
Inicie o FireFox.
Pressione CTRL+SHIFT+U para mostrar o ZoomText.
Clique no menu Ajuda.
Clique em Suporte técnico.
No campo de comando Fix-It, digite:
CLASSTOOL
Clique Fix-It
Irá visualizar uma ferramenta anexada ao cursor do seu rato, clique na janela do Firefox.
Irá aparecer uma janela, para Window Class Definition, escolha "ChildWindow" na lista de selecção.
Clique Ok.
Clique no botão fechar na janela "Acerca de".
Termine e reinicie o ZoomText e o FireFox.
Agora deverá conseguir utilizar o AppReader/DocReader no FireFox.
Nota: Pode não ter suporte para leitura de colunas no DocReader/AppReader. O mouse echo não lê por linhas. ZoomText 8.12 e ZoomText 9.0x (versão de demonstração disponível)|Ampliador de ecrã|Parcialmente compatível: pode não ter suporte para leitura de colunas no DocReader/AppReader. O mouse echo não lê por linhas. ZoomText 9.x|Ampliador de ecrã|Compatível||

Linux e UNIX

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Dasher|Introdução alternativa utilizando o cursor|Parcialmente compatível Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Deve ser compatível, mas pode necessitar de alguns procedimentos de instalação especiais. Detalhes desconhecidos. Gnome Magnifier|Ampliador de ecrã|Parcialmente compatível Gnopernicus|Leitor de ecrã|Não compatível GOK|Teclado no ecrã|Parcialmente compatível LSR|Leitor de ecrã|Não compatível ORCA|Leitor de ecrã|Não compatível||

MacOS X

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Deve ser compatível, mas são necessárias mais informações VoiceOver|Leitor de ecrã|Não compatível||

Firefox 3.0

Windows

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Dragon Naturally Speaking 1-8|Comandos de voz e ditados|não compatível Dragon Naturally Speaking 9 or later|Comandos de voz e ditados|Compatível, com alguns problemas
Para mais dicas e detalhes, visite http://www.speechcomputing.com/node/942
Mouseless Browsing (Navegação sem rato) recomendado
Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Compatível Hal, Lunar, Supernova etc. (versões de demonstração disponíveis)|Leitor ecrã, ampliador de ecrã|Não compatível JAWS 1.x-6.x|Leitor ecrã|Não compatível JAWS 7.0|Leitor ecrã|Os mesmos problemas que o JAWS 7.1. Pensamos que para Suporte Técnico é necessário o JAWS 7.1. JAWS 7.1|Leitor ecrã|Compatível, com alguns problemas. Os problemas incluem:
A notificação de alterações ao formato de texto não está completa
Falhas ocasionais ou texto duplicado quando a ler o conteúdo de um documento
Falhas ocasionais quando a ler o título da página actual na lista de separadores de navegação.
Não funciona bem com páginas com molduras
Ocasionalmente perde a posição anterior quando se retrocede a uma página visitada, repondo a posição de leitura para o inicio do documento
Combinação de teclas em conflito com a navegação por separadores
Problemas de performance JAWS 8.0 (versão de demonstração disponível)|Leitor ecrã|Compatível, com alguns problemas. Os problemas incluem:
A notificação de alterações ao formato de texto não está completa
Falhas ocasionais ou texto duplicado quando a ler o conteúdo de um documento
Ocasionalmente perde a posição anterior quando se retrocede a uma página visitada, repondo a posição de leitura para o inicio do documento
Por favor visite a página dedicada à Compatibilidade JAWS-Firefox. MAGic (versão de demonstração disponível)|Ampliador de ecrã|desconhecido NVDA|Leitor de ecrã gratuito (código aberto)|Compatível. O autor refere que funciona bem, com a excepção da edição de campos de texto. Necessita de confirmação dos utilizadores. Window-Eyes 1.0-5.0|Leitor de ecrã|Não compatível Window-Eyes 5.5, Window-Eyes 6.0 (versão de demonstração disponível)|Leitor de ecrã|Compatível ZoomText 1-7|Ampliador de ecrã|Não compatível ZoomText 8.0x-8.11|Ampliador de ecrã|Sem AppReader/DocReader. Contornar o problema:
Inicie o ZoomText.
Inicie o FireFox.
Pressione CTRL+SHIFT+U para mostrar o ZoomText.
Clique no menu Ajuda.
Clique em Suporte técnico.
No campo de comando Fix-It, digite:
CLASSTOOL
Clique Fix-It
Irá visualizar uma ferramenta anexada ao cursor do seu rato, clique na janela do Firefox.
Irá aparecer uma janela, para Window Class Definition, escolha "ChildWindow" na lista de selecção.
Clique Ok.
Clique no botão fechar na janela "Acerca de".
Termine e reinicie o ZoomText e o FireFox.
Agora deverá conseguir utilizar o AppReader/DocReader no FireFox.
Nota: Pode não ter suporte para leitura de colunas no DocReader/AppReader. O mouse echo não lê por linhas. ZoomText 8.12 e ZoomText 9.0x (versão de demonstração disponível)|Ampliador de ecrã|Parcialmente compatível: pode não ter suporte para leitura de colunas no DocReader/AppReader. O mouse echo não lê por linhas. ZoomText 9.x|Ampliador de ecrã|Compatível||

Linux e UNIX

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Dasher|Introdução alternativa utilizando o cursor|Parcialmente compatível Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Deve ser compatível, mas pode necessitar de alguns procedimentos de instalação especiais. Detalhes desconhecidos. Gnome Magnifier|Ampliador de ecrã|Parcialmente compatível Gnopernicus|Leitor de ecrã|Não compatível GOK|Teclado no ecrã|Parcialmente compatível Jambu|Acessibilidade Web melhorada para utilizadores de interfaces de acessibilidade alternativos|Compatível LSR|Leitor de ecrã|Não compatível ORCA|Leitor de ecrã|Compatível||


MacOS X

||Tecnologia Assistiva|Tipo|Notas de compatibilidade Fire Vox|Extensão para leitura de páginas gratuita e de código aberto|Deve ser compatível, mas são necessárias mais informações VoiceOver|Leitor de ecrã|Não compatível||




Este artigo baseou-se no artigo de Compatibilidade com tecnologias assistivas (mozillaZine KB)

These fine people helped write this article: cesperanc@. You can help too - find out how.