X
Toque aqui para ver a versão para dispositivos móveis desse site.

Fórum de suporte

plugin java e flash não funcionam

Postado

Os plugins do java e do flash não são reconhecidos e não funcionam. Na versão anterior estavam funcionando. Por recomendação, na versão anterior, foi solicitado atualização da versão do java e do flash. Isso foi feito, porém não funcionou.

Segue diretórios de instalação dos referidos plugins e programas: .sistema operacional Linux machine 3.10.17 #2 SMP Wed Oct 23 16:34:38 CDT 2013 x86_64 AMD Slackware 14.1 64bits

.java /usr/local/programas/jdk1.8.0_05/jre/

.firefox /usr/lib64/firefox_29.0/

.atalho em /usr/bin lrwxrwxrwx 1 root root 31 May 4 09:27 /usr/bin/firefox -> /usr/lib64/firefox_29.0/firefox

.plugins (java e flash) /usr/lib64/mozilla/plugins/

drwxr-xr-x 2 user1 users 4096 May 4 10:47 . drwxr-xr-x 3 user1 users 4096 Mar 8 13:20 .. -rw-r--r-- 1 user1 users 19234224 Apr 18 20:15 libflashplayer.so lrwxrwxrwx 1 root root 52 Mar 8 13:22 libnpgoogletalk.so -> ../../../../opt/google/talkplugin/libnpgoogletalk.so lrwxrwxrwx 1 root root 58 Mar 8 13:22 libnpgtpo3dautoplugin.so -> ../../../../opt/google/talkplugin/libnpgtpo3dautoplugin.so lrwxrwxrwx 1 root root 58 May 4 09:09 libnpjp2.so -> /usr/local/programas/jdk1.8.0_05/jre/lib/amd64/libnpjp2.so lrwxrwxrwx 1 root root 45 Mar 8 13:22 libnpo1d.so -> ../../../../opt/google/talkplugin/libnpo1d.so -rwxr-xr-x 1 root root 75424 Jul 5 2013 skypebuttons.so

Os plugins do java e do flash não são reconhecidos e não funcionam. Na versão anterior estavam funcionando. Por recomendação, na versão anterior, foi solicitado atualização da versão do java e do flash. Isso foi feito, porém não funcionou. Segue diretórios de instalação dos referidos plugins e programas: .sistema operacional Linux machine 3.10.17 #2 SMP Wed Oct 23 16:34:38 CDT 2013 x86_64 AMD Slackware 14.1 64bits .java /usr/local/programas/jdk1.8.0_05/jre/ .firefox /usr/lib64/firefox_29.0/ .atalho em /usr/bin lrwxrwxrwx 1 root root 31 May 4 09:27 /usr/bin/firefox -> /usr/lib64/firefox_29.0/firefox .plugins (java e flash) /usr/lib64/mozilla/plugins/ drwxr-xr-x 2 user1 users 4096 May 4 10:47 . drwxr-xr-x 3 user1 users 4096 Mar 8 13:20 .. -rw-r--r-- 1 user1 users 19234224 Apr 18 20:15 libflashplayer.so lrwxrwxrwx 1 root root 52 Mar 8 13:22 libnpgoogletalk.so -> ../../../../opt/google/talkplugin/libnpgoogletalk.so lrwxrwxrwx 1 root root 58 Mar 8 13:22 libnpgtpo3dautoplugin.so -> ../../../../opt/google/talkplugin/libnpgtpo3dautoplugin.so lrwxrwxrwx 1 root root 58 May 4 09:09 libnpjp2.so -> /usr/local/programas/jdk1.8.0_05/jre/lib/amd64/libnpjp2.so lrwxrwxrwx 1 root root 45 Mar 8 13:22 libnpo1d.so -> ../../../../opt/google/talkplugin/libnpo1d.so -rwxr-xr-x 1 root root 75424 Jul 5 2013 skypebuttons.so

Solução escolhida

Rapaz, uso Fedora e tive o mesmo problema e resolvi dessa forma. Baixei o firefox 29 64bits e coloquei ele em /opt/firefox, mas ele não reconhecia os plugins que estavam em /usr/lib64/mozilla/plugins, fiz links dos plugins para /usr/lib/mozilla/plugins e funcionou. Lembrando que uso a versão 64bis do firefox e plugins

Ler esta resposta 2
Diego Victor 658 soluções 4175 respostas

Isto é estranho, sugiro desinstalar os plugins, depois instalar as versões recentes compatíveis:

Depois verifique se foram reconhecidos, tente também verificar através da pagina de atualização:

Isto é estranho, sugiro desinstalar os plugins, depois instalar as versões recentes compatíveis: *get.adobe.com/flashplayer/‎ *www.java.com/ Depois verifique se foram reconhecidos, tente também verificar através da pagina de atualização: *[https://www.mozilla.org/en-US/plugincheck/ Plugins]

Alterado por Diego Victor em

Autor da pergunta

Não rolou.

Fiz os preocedimentos rodando o firefox 29, e os plugins não apareceram. Quando rodei em uma versão antiga, funcionou.

O estranho é que na verificação dos plugins (feito na versão antiga), o firefox sempre indica que deve ser feito atualização do plugin do flash, mesmo baixando o arquivo indicado pelo site da adobe.

Já o java, se baixar a vesão 7u55, que é a versão sugerida pelo site indicado na sua mensagem, o firefox também indica que precisa fazer atualização. Quando vou pelo site da oracle e baixo a versão mais nova disponível, 8u05, aí o firefox informa que está ok.

Mas tudo isso feito pela versão antiga, na versão 29 nada fucniona.

Não rolou. Fiz os preocedimentos rodando o firefox 29, e os plugins não apareceram. Quando rodei em uma versão antiga, funcionou. O estranho é que na verificação dos plugins (feito na versão antiga), o firefox sempre indica que deve ser feito atualização do plugin do flash, mesmo baixando o arquivo indicado pelo site da adobe. Já o java, se baixar a vesão 7u55, que é a versão sugerida pelo site indicado na sua mensagem, o firefox também indica que precisa fazer atualização. Quando vou pelo site da oracle e baixo a versão mais nova disponível, 8u05, aí o firefox informa que está ok. Mas tudo isso feito pela versão antiga, na versão 29 nada fucniona.

Autor da pergunta

Mais alguma sugestão?

O estanho é que funciona perfeitamente na versão antiga. O problema é quando rodo no novo.

Mais alguma sugestão? O estanho é que funciona perfeitamente na versão antiga. O problema é quando rodo no novo.
Diego Victor 658 soluções 4175 respostas

Tente criar um novo perfil ou resetar:

Delete qualquer outro perfil que você tiver, se possível, claro. Você esta com duas instâncias do Firefox instalado? Verifique se já existe alguma atualização para o seu Firefox:

Na versão 29 se você digitar about:plugins na sua barra de endereços e apertar enter, você consegue ver algum plugin?

Se possivel tente reinstalar a versão 29:

Tente criar um novo perfil ou resetar: *[https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles Criando um novo perfil] *[https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems Resetando Firefox] Delete qualquer outro perfil que você tiver, se possível, claro. Você esta com duas instâncias do Firefox instalado? Verifique se já existe alguma atualização para o seu Firefox: *[https://www.mozilla.org/firefox/new/ Versão do Firefox] Na versão 29 se você digitar '''about:plugins''' na sua barra de endereços e apertar enter, você consegue ver algum plugin? Se possivel tente reinstalar a versão 29: *[https://www.mozilla.org/en-US/firefox/all/ Todas as versões]

Alterado por Diego Victor em

Autor da pergunta

Renomiei o diretório .mozilla, e abri o firefox. Acredito que isso seja equivalente a remover o perfil, e fazer reset. Os plugins não foram reconhecidos.

Quando coloco about:plugin, é informado que nenhum plugin foi encontrado.

No diretório /usr/lib64 existem o firefox-24.1.0 e o firefox_29.0. Inicialmente quando fiz a atualização, ocorreu em cima da versão 28.0. Mas como ocorreu esse problema dos plugins, resolvi apagá-la, baixar a versão 29 e colocar lá, como está agora.

Existe um link no diretório /usr/bin que aponta para o firefox_29.0. Toda vez que clico no ícone do firefox a versão 29 é aberta.

Para abrir a versão antiga, digito o seguinte comando no console: /usr/lib64/firefox-24.1.0/firefox

Mais alguma sugestão?

Renomiei o diretório .mozilla, e abri o firefox. Acredito que isso seja equivalente a remover o perfil, e fazer reset. Os plugins não foram reconhecidos. Quando coloco '''about:plugin''', é informado que nenhum plugin foi encontrado. No diretório /usr/lib64 existem o firefox-24.1.0 e o firefox_29.0. Inicialmente quando fiz a atualização, ocorreu em cima da versão 28.0. Mas como ocorreu esse problema dos plugins, resolvi apagá-la, baixar a versão 29 e colocar lá, como está agora. Existe um link no diretório /usr/bin que aponta para o firefox_29.0. Toda vez que clico no ícone do firefox a versão 29 é aberta. Para abrir a versão antiga, digito o seguinte comando no console: /usr/lib64/firefox-24.1.0/firefox Mais alguma sugestão?
Diego Victor 658 soluções 4175 respostas

Na verdade os plugins ficam na pasta da Mozilla, se você renomear ela ai ele não vai achar nenhum mesmo.

Na verdade os plugins ficam na pasta da Mozilla, se você renomear ela ai ele não vai achar nenhum mesmo.

Autor da pergunta

Erro meu não ter colocado o caminho completo. O diretório que renomiei foi o /home/usuario/.mozilla . É nesse diretório que ficam os perfis.

Mas de qualquer forma, apaguei os perfis e fiz o reset.

Os plugins ficam em /usr/lib64/mozilla. Nesse eu não mexi.

Erro meu não ter colocado o caminho completo. O diretório que renomiei foi o /home/usuario/.mozilla . É nesse diretório que ficam os perfis. Mas de qualquer forma, apaguei os perfis e fiz o reset. Os plugins ficam em /usr/lib64/mozilla. Nesse eu não mexi.
user917725 402 soluções 2382 respostas

Só para esclarecer uma dúvida, qual versão do Firefox 29 está sendo usada, 32 bits ou 64 bits?

Só para esclarecer uma dúvida, qual versão do Firefox 29 está sendo usada, 32 bits ou 64 bits?

Votos como útil

Eu baixei a 64. Onde eu posso ver efetivamente?

Acho que se fosse a 32, ele não rodaria se estivesse dentro do diretório /usr/lib64, onde ele está.

Eu baixei a 64. Onde eu posso ver efetivamente? Acho que se fosse a 32, ele não rodaria se estivesse dentro do diretório /usr/lib64, onde ele está.
user917725 402 soluções 2382 respostas

A versão que é mostrado nos detalhes do sistema é a 64 bits e o firefox 28 que você usava anteriormente é 64 bits também. Experimenta testar a versão 32 bits.

A versão que é mostrado nos [/pt-BR/questions/998634#more-system-details detalhes do sistema] é a 64 bits e o firefox 28 que você usava anteriormente é 64 bits também. Experimenta testar a versão 32 bits.
Ronilson 1 soluções 1 respostas

Solução escolhida

Rapaz, uso Fedora e tive o mesmo problema e resolvi dessa forma. Baixei o firefox 29 64bits e coloquei ele em /opt/firefox, mas ele não reconhecia os plugins que estavam em /usr/lib64/mozilla/plugins, fiz links dos plugins para /usr/lib/mozilla/plugins e funcionou. Lembrando que uso a versão 64bis do firefox e plugins

Rapaz, uso Fedora e tive o mesmo problema e resolvi dessa forma. Baixei o firefox 29 64bits e coloquei ele em /opt/firefox, mas ele não reconhecia os plugins que estavam em /usr/lib64/mozilla/plugins, fiz links dos plugins para /usr/lib/mozilla/plugins e funcionou. Lembrando que uso a versão 64bis do firefox e plugins

Autor da pergunta

Muito obrigado cara!!! Resolveu perfeitamente! Tudo funcionando agora.

Muito obrigado cara!!! Resolveu perfeitamente! Tudo funcionando agora.