Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Ao fazer download de TXT a opção de memorizar fica desabilitada

  • 4 respostas
  • 1 tem este problema
  • 1495 visualizações
  • Última resposta de samuelfac

more options

Ao fazer download de qualquer arquivo (pdf, jpg, ppt, etc) a janela de download aparece e a opção "memorizar a decisão para este tipo de arquivo" fica habilitada. Mas quando o tipo de arquivo é TXT ou XML esta opção fica desabilitada.

Tentativa: No about:config, alterei a opção "browser.helperApps.neverAsk.saveToDisk" para "text/plain" mas mesmo assim a janela aparece e com a opção desabilitada.

Como faço para memorizar o download automático para arquivos TXT ou XML?

Solução escolhida

Bom encontrei uma alternativa, que pode ajuda-lo.

  1. Na barra de endereços, escreva about:config e pressione Enter. É possível que o aviso 'Isso pode anular a garantia!' apareça.
  2. Clique no botão Serei cuidadoso, prometo!, para acessar a página about:config.
  3. Procure por browser.altClickSave mude o valor desta opção para true, para isso clique duas vezes sobre a opção ou clique com o botão direito e escolha Inverter valor
  4. Quando for clicar no link para download segure Alt depois clique no link.

Reparei que aquele ação Documento de texto esta presente somente no Windows XP, porem no W7 e 8 parece não existir. Caso encontre uma outra forma postarei aqui.

Ler esta resposta 👍 0

Todas as respostas (4)

more options

Olá

Vá na barra de menus (aperte F10 ou Alt para mostra-la caso necessário) depois clique em Ferramentas » Opções » Aplicativos e procure por Documento de texto altere a ação para Download, provavelmente arquivos XML você entrara um plugin que o abra, basta dar uma olhada e mudar para download também

more options

Diego, grato pela resposta. Não há a opção "Documento de texto". Quando ao XML, já selecionei o notepad++ para abrir como padrão, mas continua desabilitado a opção de memorizar para XML.

pode testar aqui: http://the-internet.herokuapp.com/download

more options

Solução escolhida

Bom encontrei uma alternativa, que pode ajuda-lo.

  1. Na barra de endereços, escreva about:config e pressione Enter. É possível que o aviso 'Isso pode anular a garantia!' apareça.
  2. Clique no botão Serei cuidadoso, prometo!, para acessar a página about:config.
  3. Procure por browser.altClickSave mude o valor desta opção para true, para isso clique duas vezes sobre a opção ou clique com o botão direito e escolha Inverter valor
  4. Quando for clicar no link para download segure Alt depois clique no link.

Reparei que aquele ação Documento de texto esta presente somente no Windows XP, porem no W7 e 8 parece não existir. Caso encontre uma outra forma postarei aqui.

more options

resolvido com: "browser.helperApps.neverAsk.saveToDisk" para "application/octet-stream"

Obrigado a todos.

Alterado por samuelfac em