Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Javascript isn't working after I turned it on

  • 11 antwoorden
  • 1 heeft dit probleem
  • 190 weergaven
  • Laatste antwoord van DianaRosaline

more options

Javascript isn't working. I turned off all my plugins, and I enabled/disabled/enabled it in about:config.

The reason I'm trying to figure this out is because the website I need to get on comes up with: JavaScript required

JavaScript is required. This web browser does not support JavaScript or JavaScript in this web browser is not enabled.

To find out if your web browser supports JavaScript or to enable JavaScript, see web browser help.

Gekozen oplossing

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Dit antwoord in context lezen 👍 0

Alle antwoorden (11)

more options

Hello DianaRosaline,

In Firefox JavaScript is enabled by default - and apparantly you made sure that the pref's value is indeed set to "true".

Just to make sure : could it be that the site in question is talking about "Java" (which is not supported in any browser, except Internet Explorer) ?

Would it be possible for you to provide a link to that site  ?

more options
more options

Also, I posted a copied and pasted the exact message it gave me.

more options

McCoy said

Hello DianaRosaline, In Firefox JavaScript is enabled by default - and apparantly you made sure that the pref's value is indeed set to "true". Just to make sure : could it be that the site in question is talking about "Java" (which is not supported in any browser, except Internet Explorer) ? Would it be possible for you to provide a link to that site  ?

It works on my other computer on Firefox (Also, I'm new but does it only notify you if I quote you?)

more options

No, you don't have to quote me ......  :)

I tried the link you posted and went to other sso.egcc.edu pages, and never got a message saying JavaScript needs to be enabled (or something to that effect).

Everything worked as it should, and you just now say that it works on your other computer.

I don't know what it is that doesn't work, but this might be something you could try :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

more options

DianaRosaline said

Also, I posted a copied and pasted the exact message it gave me.

That failed to upload ......  :(

more options

It says "JavaScript required JavaScript is required. This web browser does not support JavaScript or JavaScript in this web browser is not enabled. To find out if your web browser supports JavaScript or to enable JavaScript see web browser help."

And I'm sorry to say that that didn't work. :(

My other computer works fine with the same browser and OS, but it's Lenovo and this one is Dell, does that have any bearing on whether JavaScript works?

more options

The only thing I can think of now, is to either email or call them :

https://egcc.edu/gateway/

(scroll down all the way to the bottom of the page to see their email address and phone number)

more options

Thank you McCoy.

more options

Gekozen oplossing

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Afterward Note: I was able to simply reset the browser and now it works! Thank you!