Wrong Scaling with HiDPI Screen on Linux

Dear Technical Support, I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor. I'm having issues with the text and graphi… (read more)

Dear Technical Support,

I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor.

I'm having issues with the text and graphics of web pages, that are often mismatched or misaligned, with text being too large compared to graphical elements. See the enclosed pictures for an example; as you can see, this happens also on your website. Also, I've noted that pages (and plugins) appear to be "shrinked" as opposed to when viewed on Chrome, where they are shown to their true size.

Setting ui.textScaleFactor=100 and tweaking with layout.css.devPixelsPerPx did not change much. I must admit that I find this behavior quite strange, since HiDPI monitors have been around for more than a decade, and especially considering that this did not impact my experience with Firefox on Windows, using the same monitor and machine.

I hope to find an effective solution to this problem and look forward to your reply. Please let me know if I can be of any help in this matter.

Best regards, Federico

Asked by Federico 2 hours ago

Last reply by jonzn4SUSE 2 seconds ago

HTTPS Configuration Assistance Needed for Topcareemergency.com

Dear Mozilla Community, I'm seeking technical help with HTTPS configuration for my website, TopCareEmergency, which provides emergency room services information. Despite… (read more)

Dear Mozilla Community,

I'm seeking technical help with HTTPS configuration for my website, TopCareEmergency, which provides emergency room services information. Despite installing SSL and adjusting Apache, I'm encountering mixed content errors. Any guidance on resolving this issue would be greatly appreciated.

Thank you, Huma Jackson

Asked by HumaJackson 1 hour ago

Last reply by cor-el 1 minute ago

Read Aloud

Suddenly, your Read Aloud feature no longer works properly: pitch and speed are distorted and can't be normalized. Don't know whether it's the fault of either Mozilla's o… (read more)

Suddenly, your Read Aloud feature no longer works properly: pitch and speed are distorted and can't be normalized. Don't know whether it's the fault of either Mozilla's or OSX's update. Both builds are up to date. Is there an alternative?

Asked by Tatiner 3 minutes ago

Number is not getting recognised

After switching to Firefox version 123, I encountered an error on our website: '1,000,000.00 is not a valid number.' It seems to be a form validation error, but it worked… (read more)

After switching to Firefox version 123, I encountered an error on our website: '1,000,000.00 is not a valid number.' It seems to be a form validation error, but it worked fine with previous versions of Firefox. The application is built using GWT (Google Web Toolkit). Any help would be appreciated. Thanks.

Asked by Bikram Singh 17 hours ago

Last reply by Bikram Singh 4 minutes ago

Email access problem

Just within the past few days, Firefox no longer allows me desktop computer access to my email account with wowway.com. However, both Chrome and Edge do. WOW's customer s… (read more)

Just within the past few days, Firefox no longer allows me desktop computer access to my email account with wowway.com. However, both Chrome and Edge do. WOW's customer support person said that Firefox is causing the problem. I really like Firefox and hope that this issue can be resolved. Thank you. Clare Abt

Asked by cabt 13 minutes ago

website shows a Mozilla error

Hello, I'm alinexubrex . Every time a webpage opens in the Mozilla browser, a "not supported" message appears. Upon examining the settings, I found that Mozilla has to be… (read more)

Hello, I'm alinexubrex . Every time a webpage opens in the Mozilla browser, a "not supported" message appears. Upon examining the settings, I found that Mozilla has to be updated. Can someone assist me with updating Mozilla? For example, an error notice shows when I open (https://iesco.org/).

Asked by Alinex Ubrex 19 minutes ago

How can i change the Microphone?

I have multiple Microphones on my PC. I don't want to Plug them in and out Everytime, and some can't be unpluggt. Also i want the freedom to choose easily. I would love t… (read more)

I have multiple Microphones on my PC. I don't want to Plug them in and out Everytime, and some can't be unpluggt. Also i want the freedom to choose easily. I would love to change it in the "Permission for web.whatsapp.com" Menue thats drops down when i klick on it in the Adressbar. See picture attached.

Asked by b.schmitt38 7 hours ago

Last reply by cor-el 25 minutes ago

iMac Firefox Won't Open

After wipe of drive and reinstallation of Ventura by the Apple Store, and migration from Time Machine, Firefox won't launch. It's there, but it won't open. Click the ic… (read more)

After wipe of drive and reinstallation of Ventura by the Apple Store, and migration from Time Machine, Firefox won't launch. It's there, but it won't open. Click the icon and the icon moves as if it were going to launch, but the app doesn't open. If I were to reinstall Firefox, would it sync with my settings and Bookmarks?

Asked by John 1 day ago

Last reply by jonzn4SUSE 30 minutes ago

  • Solved

Inquiry on Password Security for website in Firefox

Dear Firefox Support Team, I hope this message finds you well. I'm Dr. Sobya owner of the sobya's skincare website. I'm seeking clarification on Firefox's password manag… (read more)

Dear Firefox Support Team,

I hope this message finds you well. I'm Dr. Sobya owner of the sobya's skincare website. I'm seeking clarification on Firefox's password management security, considering the prevalent practice of users saving passwords for convenience. I'm keen to know if Firefox has robust measures in place to safeguard sensitive information, addressing potential risks similar to those raised about other browsers like Chrome. Given our skincare focus and the trust our users place in us, assuring the safety of their credentials is paramount. A detailed response on Firefox's security protocols would not only alleviate user concerns but also enhance trust and credibility for our platform. I appreciate your prompt attention to this matter and look forward to your insights.

Best regards, Dr. Sobya

Asked by Umar alyani 2 days ago

Answered by Umar alyani 35 minutes ago

  • Solved

Can't copy text - It works in any other browser

Hello! I often log in to a service ticketing website to help my customers. Before emailing them I must reference the service ticket number somewhere in the email, but t… (read more)

Hello!

I often log in to a service ticketing website to help my customers. Before emailing them I must reference the service ticket number somewhere in the email, but this is very difficult to do in Firefox. If I inspect the element this is what I see:

<em unselectable="on" style="width: 2161px;">Service Ticket #55474079</em>

I understand the unselectable attribute is on but even if I try setting it to off or deleting it all together the problem remains. Moreover, I've tried it in several browsers (Chrome, Edge, DuckDuckGo) and it works fine without any extensions or tricks.

In other words: only Firefox keeps me from selecting this very important piece of info.

Any help would be very much appreciated! I looked up help articles but nothing similar to my case. I did find an extension for the browser but I am afraid to try it due to security reasons.

Thank you!

BMET1.

Asked by BMET1 3 months ago

Answered by cor-el 3 months ago

Why Yandex has been added as "default" (and unchangeable) engine with Russian language as default (unchangeable) setting?

Hi all, In the past I was using Chrome and I have decided to move back to Firefox because I didn't like certain trends of that browser...now...the thing is...I like to us… (read more)

Hi all, In the past I was using Chrome and I have decided to move back to Firefox because I didn't like certain trends of that browser...now...the thing is...I like to use Yandex, but in Chrome -until a certain point- I was able to alter its settings to force default English language for it.

Firefox seems to have Yandex set as default...you cannot alter it and you cannot delete any of the default engines (i.e., because if it is loaded, you seem unable to try add it as custom search engine with your chosen parameters), but seems that the Mozilla developers had the brilliant idea to add it with the default settings...which is in Russian...

...and you look into Extensions and all the people writing extensions seemed to have the same idea...

Now...fine that Yandex is mostly for Russian people, but why English-speaking users to be forced with the default search in Russian and being completely denied any possibility to force the English language on Yandex (as it is fully possible if you were able to tweak the search parameters...but Firefox isn't allowing to do, because the only thing we have is a dumbed down interface with a list of search engines!)...

...alternatively...why not allow to force our favored language parameters to ALL search engines by default?

( That would mean that one could have Google, Bing or Yandex in a different language of our choice....but that change would need to be implemented on developer side...)

Asked by Skarm Ghelmaad 2 hours ago

Last reply by cor-el 37 minutes ago

Firefox Clears All Settings

Firefox clears all of my settings every time I close and reopen it. My homepage, settings for various extensions, custom toolbar settings, application settings, etc., are… (read more)

Firefox clears all of my settings every time I close and reopen it. My homepage, settings for various extensions, custom toolbar settings, application settings, etc., are all gone and I have to start all over. Additionally, Firefox usually takes 20 to 30 minutes or more to fully load upon opening. Any solution for the problem of losing all of my settings everyday?

Asked by ignatz13 3 hours ago

Last reply by cor-el 41 minutes ago

Mouseover link tooltip url persistent through click and page load.

So on most sites there has been an issue for me for quite some time. I hover over a link, the tooltip appears on the bottom left of the window showing the URL of the lin… (read more)

So on most sites there has been an issue for me for quite some time.

I hover over a link, the tooltip appears on the bottom left of the window showing the URL of the link. I click on link and page reloads but the tooltip is still on bottom left of the new window. The tooltip will disappear if I hover over any other link on the newly loaded page.

I expect the tooltip to go away when clicking the link and going to that page/site.

Firefox on win10 & 11 This problem does not occur in Edge.

Asked by MFS 2 weeks ago

Last reply by cor-el 49 minutes ago

I keep getting the following message when trying to use kaspersky safe money '

I keep getting the following message when trying to use kaspersky safe money 'Firefox is already running, but is not responding. The old Firefox process must be closed to… (read more)

I keep getting the following message when trying to use kaspersky safe money 'Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window'

Asked by barrie.robin 5 hours ago

Last reply by cor-el 50 minutes ago

"Your browser is being managed by your organisation" (Der Browser wird durch Ihre Organisation verwaltet)

On my Laptop I always get the Message "Der Browser wird durch Ihre Organisation verwaltet" (No. 1). To change this I should go to HKEY_LOCAL_MACHINE via REGEDIT. Then to … (read more)

On my Laptop I always get the Message "Der Browser wird durch Ihre Organisation verwaltet" (No. 1). To change this I should go to HKEY_LOCAL_MACHINE via REGEDIT. Then to SOFTWARE / POLICIES / ???. There should be an entry MOZILLA or FIREFOX. I dont have this (No. 2). So I should go to FIREFOX "about:config" and there I should change "security.enterprise_roots.enabled" from "true" to "false". But it is (the ONLY) setting, which is locked (No. 3).

So I do not know, how I can remove this "Your browser is being managed by your organisation".

Can you help me?? I am my own organisation....

Asked by dieter_wiese 6 hours ago

Last reply by cor-el 1 hour ago

RELAY Premium

When I try to access my premium relay dashboard, I am taken to the free option and asked if I want to upgrade to premium..... I have been a premium customer for 2 yeras?… (read more)

When I try to access my premium relay dashboard, I am taken to the free option and asked if I want to upgrade to premium..... I have been a premium customer for 2 yeras? Can you help/advise please? Tim

Asked by timawmack1 1 hour ago

I am no longer able to download my email from the WOWWAY home web site since your last update!!!!

Find out and correct the problem I typed in the question block : I am no longer able to download my email from the WOWWAY home page since I accepted our latest updat… (read more)

Find out and correct the problem I typed in the question block : I am no longer able to download my email from the WOWWAY home page since I accepted our latest update. The only way I can get my email now is by using Microsoft Edge as my browser!!!!

Asked by wjroberts1 1 hour ago

Pages taking ages to load

Hi all, I feel like this is a problem that must have been experienced and solved a thousand times... however I've tried all the suggested fixes I can find and the proble… (read more)

Hi all,

I feel like this is a problem that must have been experienced and solved a thousand times... however I've tried all the suggested fixes I can find and the problem still persists.

When I load Firefox the pages take ages to load. It doesn't matter what the page is, it takes ages, except that about: pages load fine, no problem. When I say pages take ages to load, I mean that everything about the page takes ages, not only the next, not on the images and other content etc, everything. This only started happening today and I only created a new profile a month or so ago. I don't have many tabs open (maybe 20) of which 9 are pinned. I do have lots of extensions installed.

I've tried troubleshooting/safe mode, that makes no difference.

Private browsing and loading another profile are fine, they don't have this problem.

I've cleared all cache and data, cookies, etc, including startup cache.

I've deleted the content-prefs file, and removed places files.

I've tried disabling and enabling hardware acceleration.

I've tried disabling TRR.

Probably some other things too, but so far nothing has worked.

Suggestions please! :)

Asked by madbilly 1 month ago

Last reply by cor-el 1 hour ago