Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On Firefox 13 the new tab page boxes are blank no matter how many times I visit a website

  • 11 replies
  • 14 have this problem
  • 2135 views
  • Last reply by dumdidadida

more options

I downloaded firefox 13 about a week ago and when I open a new tab the boxes that are supposed to display your most visited webpages don't work, if you go to your bookmark that says "Most Visited" that displays my most visited webpages fine but none of the pages show up on my new tab page. Also if I click and drag one of the websites into the boxes the website name appears but it never loads any picture for the website. If I don't click and drag the website to one of the boxes then the box is empty....there is no website, nothing. But I've gone to plenty of sites plenty amount of times and it is not showing up http://i.imgur.com/TWmAU.png --- Here's a image of what I see (to clear up any confusion)

Modified by wam19

All Replies (11)

more options

Hi,

Please see this.

more options

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.

  • Do not use Clear Recent History to clear data like the cache and the history when you close Firefox

If there is no history then you get an about:newtab page with empty boxes.

Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose:

  • Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"
more options

I am/was not in private browsing I can look through all of my history yet no sites appear on the new tab boxes. Also edited main post to clear up confusion that I guess some people where having with what my issue was.

Modified by wam19

more options

Do you at least see the URL under some of the nine boxes on the about:newtab page?

Can you drag a bookmark or history item onto one of the boxes.

Is the cache enabled and working?

You can check that on the about:cache page, via the location bar.
You can check the browser.cache.disk.enable pref on the about:config page.

Modified by cor-el

more options

I see no URL there are no webpages assigned to any of the boxes even though I have visited multiple sites numerous amount of times.

I can drag a bookmark into a box, but I want it to show my most visited webpages not my bookmarks :\

The browser.cache.disk.enable is true

more options

So the page works if you drag a bookmark or history item to one of the boxes, but doesn't work directly for visited websites?

That would imply that the history isn't working properly.

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

You can also try to repair the places database with this extension:

more options

I tried starting it in safe mode and it still wasn't working so I reset firefox back to default everything and the new tab page seems to work now.

more options

I have the same problem with Firefox 14.0 - the boxes showed a URL name but no picture. I reset Firefox but it didn't correct the problem.

more options

Due to privacy concerns, there are minor changes in the way thumbnails are stored/displayed as of Firefox 14.0.1 . Please see this (comment 41).

more options

I'm also having problems with my blog - same problems I had with IE - I'm logged in but don't see menu choices to make a new post, or edit current ones. Looks like Firefox 14.0 is causing a lot of problems. Can I go back to the previous version - it worked perfectly!

more options

Hi stitchlady,

You can consider the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information.

(To revert to the previous profile you were using, close the new profile, start Firefox and choose the Default User profile. While the Profile Manager is open, you can also delete the newly reset profile (the one containing random numbers), or the former profile, as the case may be).

Managing profiles

Profiles Howto

You can also start a new thread as it would help to provide more specific details.