Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have all tabs set to open with Google search, but when I open a new tab and start typing, the letters appear in the address bar and not the Google search bar. It didn't used to be like this!

  • 2 replies
  • 4 have this problem
  • 11 views
  • Last reply by cor-el

more options

Firefox 9.01; Windows 7 64 bit;

One of my set of home pages is the basic Google search page. When I open this, I can immediately start typing and the words appear in the Google search box. If however I open a new tab (white cross far right of tab bar) and start typing, the words appear in the address bar, not in the Google search box. Of course once I click in the search box I can carry on: but I'd like to make it start there as it does with the homepage.

All Replies (2)

more options

If you want a specific webpage (like the Google page) to always open when you open a New Tab, you can use the following add-on to Open New Tabs with your Favorite Pages:

-> NewTabURL 2.2.3

Check and tell if its working.


Not related to your problem but do the following:

-> Update Firefox to the latest version 10

-> Update All your Firefox Plugins -> https://www.mozilla.org/en-US/plugincheck/

  • When Downloading Plugins Update setup files, Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.)

Modified by Hasan

more options

That issue can be caused by an extension that isn't working properly.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).