Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Repeating "Welcome back" popup when starting Firefox

  • 7 replies
  • 4 have this problem
  • 155 views
  • Last reply by pepak

more options

I have just upgraded to Firefox version 123. Now whenever I start Firefox on any of my profiles, it will immediately or almost immediately display a "Welcome back" popup stating that "Here’s a quick reminder that you can keep your favorite indie browser just one click away." and provides a button to make the browser the default one. That's exceedingly annoying - I can understand that Firefox wants to notify my once in a while, but this happens at least once a day, probably more often than that. I looked over the source code and got that it is a "spotlight" feature, but I failed to find any settings that would turn it off. Any idea how can I disable this forever?

I have just upgraded to Firefox version 123. Now whenever I start Firefox on any of my profiles, it will immediately or almost immediately display a "Welcome back" popup stating that "Here’s a quick reminder that you can keep your favorite indie browser just one click away." and provides a button to make the browser the default one. That's exceedingly annoying - I can understand that Firefox wants to notify my once in a while, but this happens at least once a day, probably more often than that. I looked over the source code and got that it is a "spotlight" feature, but I failed to find any settings that would turn it off. Any idea how can I disable this forever?

Chosen solution

Found it.

The information that I refused the change of the default browser is stored in `<profile>\storage\permanent\chrome\idb\3870112724rsegmnoittet-es.sqlite`. If I don't delete the file (which I normally do), the question will not be repeated.

Read this answer in context 👍 0

All Replies (7)

more options

Untick "Always check if Firefox is your default browser" and "Recommend features as you browse" in settings.

Helpful?

more options

Unfortunately, both of the checkboxes are unchecked and the problem persists.

Helpful?

more options

Note that this is about the Firefox Doodle. See line 1123.

# “indie” is short for the term “independent”.
# In this instance, free from outside influence or control.
fox-doodle-pin-body = Here’s a quick reminder that you can keep your favorite indie browser just one click away.

Firefox would normally only show such a message once or twice (frequency:{lifetime:2}). Do you otherwise have problems with preferences?

Helpful?

more options

Make sure that browser.shell.checkDefaultBrowser and browser.newtabpage.activity-stream.asrouter.userprefs.cfr.features are always false in about:config on startup.

Visit about:policies in the address bar and see if there are any active enterprise policies.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Helpful?

more options

You can check if you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and is normally not present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

zeroknight:

  • browser.shell.checkDefaultBrowser is set to false.
  • browser.newtabpage.activity-stream.asrouter.userprefs.cfr.features is also false.
  • I do have some policies enabled but none of those relate to the message.
  • A new profile solves the problem but since the profile I use is heavily customized, that is not really a solution.

cor-el:

  • This is the only problem with my preferences that I am aware of.
  • I don't have a user.js file yet but if there is a way to prevent the message by creating the file, I would be happy to do so.

Thinking about the suggestions mentioned so far, it might be the case that the setting is saved somewhere outside the usual settings area, as I am routinely performing a rather aggressive profile cleanup and by using an unusual storage, it's conceivable that the setting would get deleted. I will need to experiment with that.

Helpful?

more options

Chosen Solution

Found it.

The information that I refused the change of the default browser is stored in `<profile>\storage\permanent\chrome\idb\3870112724rsegmnoittet-es.sqlite`. If I don't delete the file (which I normally do), the question will not be repeated.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.