Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not asking for Primary Password at startup after update to 121.0.1 on Ubuntu

more options

After after update to 121.0.1 on Ubuntu, I'm not asked anymore for Primary Password at startup, hence I cannot use my saved logins and certificates. If I restart in Troubleshooting mode, I have the pop up for Primary Password back, which is working as expected. Restarting normally after disabled all Add-Ons does not solve the problem.

After after update to 121.0.1 on Ubuntu, I'm not asked anymore for Primary Password at startup, hence I cannot use my saved logins and certificates. If I restart in Troubleshooting mode, I have the pop up for Primary Password back, which is working as expected. Restarting normally after disabled all Add-Ons does not solve the problem.

All Replies (10)

more options

Restarting the PC did not work either.

Helpful?

more options

This may shed some light on the result of troubleshooting mode.

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_the-problem-does-not-happen-in-troubleshoot-mode


As an interim measure, you could use Settings to log in. Go to the Privacy & Security page then Certificates. Press the button labelled Security Devices. In the right panel Software Security Device then the button labelled Log In.

Helpful?

more options

Note that the Primary Password isn't meant to block access to Firefox, canceling this prompt only prevents access to the logins stored in the Password Manager (about:logins).

Firefox only shows the PP dialog when it needs to unlock the logins stored in logins.json, like when you open a page for which a login is stored or if you use Sync as the credentials for the Mozilla Account are stored in logins.json.

Helpful?

more options

Terry said

This may shed some light on the result of troubleshooting mode. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_the-problem-does-not-happen-in-troubleshoot-mode

As an interim measure, you could use Settings to log in. Go to the Privacy & Security page then Certificates. Press the button labelled Security Devices. In the right panel Software Security Device then the button labelled Log In.

Thank you for your answer answer but none of the suggestions worked. 1. following the instructions here https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_the-problem-does-not-occur-in-troubleshoot-mode still brought to Primary Password pop up not to show up 2. "Log In" button is disabled, pls see attached image

Additional finding: when browsing to 'about:logins' there is a banner right below URL box saying something like "to see you passwords you have to Log In" with a button; pressing the button had no effect.

Modified by enzo.simone.dev

Helpful?

more options

cor-el said

Note that the Primary Password isn't meant to block access to Firefox, canceling this prompt only prevents access to the logins stored in the Password Manager (about:logins). Firefox only shows the PP dialog when it needs to unlock the logins stored in logins.json, like when you open a page for which a login is stored or if you use Sync as the credentials for the Mozilla Account are stored in logins.json.

Yes, I guess I was used to see PP box to pop up as soon as I'm starting Firefox because as I'm using Sync.

Helpful?

more options

I can't see from your screenshot whether you selected Software Security Device in the left panel.

It's possible that there is a policy, perhaps created by your distro. Enter about:policies in the address bar to check that.

Helpful?

more options

Troubleshoot Mode disables external PKCS #11 modules (smartcard readers, biometric security devices and external certificate stores).

Does it still happen if you change security.nocertdb to true in about:config then restart the browser?

Helpful?

more options

zeroknight said

Troubleshoot Mode disables external PKCS #11 modules (smartcard readers, biometric security devices and external certificate stores). Does it still happen if you change security.nocertdb to true in about:config then restart the browser?

Yes, setting "security.nocertdb" to "true" has no effect (I mean, still no PP box, no password, no certificate).

Helpful?

more options

Terry said

I can't see from your screenshot whether you selected Software Security Device in the left panel. It's possible that there is a policy, perhaps created by your distro. Enter about:policies in the address bar to check that.

Yes, I tried selecting any item in the left panel, but Log In button stays disabled. In about:policies I read "The Enterprise Policies service is inactive."

Helpful?

more options

Additional info. I was able to create a new profile, activate Sync there with same account, got all Add-Ons and settings for new profile from original account, enable Primary Password also in new profile: Primary Password box pops up each time I start the new profile.

So my guess is that there's something which is corrupted in original profile.

Modified by enzo.simone.dev

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.