Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

URL Completion in FF 119 Broken?

more options

I recently updated to FF 119.0.1. I am finding that URL completion in the address bar is kind of random. In FF 118 and earlier, URLs were completed predictably, and it was pretty clear that they were based on a) bookmarks and b) frequency of use. Now, it seems like the frequency info is lost every time I restart FF. In that case, I might expect that the URL offered would be from the oldest bookmark or maybe the first in alphabetical order or something predictable, but it isn't. It seems to me to be random, and it is very annoying.

Is this a new bug, or is there perhaps a new setting that I can change to stop the madness?

For relevant settings, I have:

 - Provide search suggestion: checked
 - When using address bar, suggest: browsing history and bookmarks are checked, nothing else
 - I'm using Custom History settings: Remember browsing and download history is checked, Clear history when Firefox closes is checked. 

I have used these settings for years in previous versions of FF, and there hasn't been a problem until now.

Thanks!

I recently updated to FF 119.0.1. I am finding that URL completion in the address bar is kind of random. In FF 118 and earlier, URLs were completed predictably, and it was pretty clear that they were based on a) bookmarks and b) frequency of use. Now, it seems like the frequency info is lost every time I restart FF. In that case, I might expect that the URL offered would be from the oldest bookmark or maybe the first in alphabetical order or something predictable, but it isn't. It seems to me to be random, and it is very annoying. Is this a new bug, or is there perhaps a new setting that I can change to stop the madness? For relevant settings, I have: - Provide search suggestion: checked - When using address bar, suggest: browsing history and bookmarks are checked, nothing else - I'm using Custom History settings: Remember browsing and download history is checked, Clear history when Firefox closes is checked. I have used these settings for years in previous versions of FF, and there hasn't been a problem until now. Thanks!

All Replies (5)

more options

Hmm, if you go to the Library window (Ctrl+Shift+O -- O as in Organizer) to view your bookmarks, then enter http into the little search box to pull up the full list:

If you aren't already displaying the Visit Count column, right-click any other column heading to access the column chooser.

Click the Visit Count column heading to sort. Then click again to sort in reverse order (ascending vs. descending).

Does your Firefox still have visit counts or were they zeroed out? I suspect clearing history would zero them out, but maybe there has been a change.

Helpful?

more options

Yes, the visit counts do seem to get reset when history is cleared. But that also happens in FF 118 where I am not experiencing this problem.

Helpful?

more options

Interesting. It sounds like there was a change to how/when the URL's "frecency" score is (re)computed. This is a hidden value in the Places database that is weighted based on how/when the page was accessed, so it's not the same as raw visit count.

I haven't been able to find any documentation on the change. Maybe another support volunteer knows the details. But even if we know what changed, I am not aware of a way to override the frecency (re)computation.

If you think this might have been an unintended change, you can file a bug at: https://bugzilla.mozilla.org/

If it was intentional but undesirable, you can submit an "Idea" on Mozilla Connect to propose a fix to the developers: https://connect.mozilla.org/t5/ideas/idb-p/ideas

Helpful?

more options

Go to about:studies in the address bar and see if there are any relevant active studies.

Check that browser.urlbar.autoFill.adaptiveHistory.enabled is default false in about:config.

Helpful?

more options

There are no active studies and browser.urlbar.autoFill.adaptiveHistory.enabled is indeed false in about:config.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.