Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Make firefox (linux, snap) mouse pointer adhere to system settings

  • 4 replies
  • 0 have this problem
  • 45 views
  • Last reply by Terry

more options

I have recently updated to Xubuntu 22 and in the process my firefox was migrated to the snap version. Now firefox is using its own mouse pointer style (smaller pointer, "hand with cuff pointing left" instead of "hand pointing up" over links). I can edit the system style of my mouse pointer, but that does not change the mouse pointer while in Firefox. This seems the same problem like these two questions: - https://support.mozilla.org/en-US/questions/1380997 - https://support.mozilla.org/en-US/questions/1369875

How do I make Firefox use the system settings for the mouse pointer? Or at least how do I change the mouse pointer style/settings for Firefox snap at all?

For reference my Firefox Version is 104.0.2 (64-bit) Mozilla Firefox Snap for Ubuntu. My desktop environment is xfce 4.16.

Thanks, Peter

I have recently updated to Xubuntu 22 and in the process my firefox was migrated to the snap version. Now firefox is using its own mouse pointer style (smaller pointer, "hand with cuff pointing left" instead of "hand pointing up" over links). I can edit the system style of my mouse pointer, but that does not change the mouse pointer while in Firefox. This seems the same problem like these two questions: - https://support.mozilla.org/en-US/questions/1380997 - https://support.mozilla.org/en-US/questions/1369875 How do I make Firefox use the system settings for the mouse pointer? Or at least how do I change the mouse pointer style/settings for Firefox snap at all? For reference my Firefox Version is 104.0.2 (64-bit) Mozilla Firefox Snap for Ubuntu. My desktop environment is xfce 4.16. Thanks, Peter

All Replies (4)

more options

xfce.... Try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Do you have the same issue in KDE?


Operating System: openSUSE Tumbleweed 20220910 KDE Plasma Version: 5.25.5 KDE Frameworks Version: 5.97.0 Qt Version: 5.15.5 Kernel Version: 5.19.8-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Quadro K3100M/PCIe/SSE2 Manufacturer: Hewlett-Packard Product Name: HP ZBook 17 G2

Helpful?

more options

I installed xfce and noticed the mouse size change when in body of the browser and when pointing at the browser menu. see screenshots Also notice how the size will change over the desktop. None of those issues in KDE.

Modified by jonzn4SUSE

Helpful?

more options

Thanks for the responses and the testing. I tried both the snap and the bin version in xfce and kde plasma:

- the bin version uses the system pointers in both xfce and kde. - the snap version uses its own pointers in both xfce and kde. (see screenshots)

So it seems to be an issue directly with the snap version. I'll try to look into snap directly and maybe find the dedicated snap support team. But since you didn't have those issues with kde, there might also be another thing on my side. Are you using X11 for kde? Then again I might just migrate to a non-snap non-xfce distro soon anyway...

Edit/Update: Yes the issue seems to be with snap/xubuntu settings, as bug reports have been made for opera/chromium as well. (https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1833611)

Modified by peter-lyko

Helpful?

more options

See also this thread on Reddit (remove the blank space).

https://www.reddit. com/r/firefox/comments/xcjxex/ubuntu_2204_and_ff_10402_tiny_mouse_cursor/

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.