Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Problems Accessing Websites

  • 10 replies
  • 2 have this problem
  • 495 views
  • Last reply by edrcpa

more options

I've posted this problem before and did receive replies attempting to help. Unfortunately, the problem has continued for a long time (I think at least a year). I frequently can't access websites (e.g. Yahoo Mail) using Firefox but can using Edge or Brave. With Firefox, I get the following error message:

"Secure Connection Failed An error occurred during a connection to login.yahoo.com. PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem."

I had hoped that the problem would be solved by a Firefox update but that has not happened.

I also regularly get the message "No Internet Connection" while using Firefox but, when I use Edge or Brave while the error message is displayed, there is Internet connection.

I'm using the latest versions of Firefox and Windows 10 Pro.

I've used Firefox for many years and really don't want to have to switch to, say, Brave.

Ed

I've posted this problem before and did receive replies attempting to help. Unfortunately, the problem has continued for a long time (I think at least a year). I frequently can't access websites (e.g. Yahoo Mail) using Firefox but can using Edge or Brave. With Firefox, I get the following error message: "Secure Connection Failed An error occurred during a connection to login.yahoo.com. PR_END_OF_FILE_ERROR The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem." I had hoped that the problem would be solved by a Firefox update but that has not happened. I also regularly get the message "No Internet Connection" while using Firefox but, when I use Edge or Brave while the error message is displayed, there is Internet connection. I'm using the latest versions of Firefox and Windows 10 Pro. I've used Firefox for many years and really don't want to have to switch to, say, Brave. Ed

Chosen solution

You can try to disable DNS over HTTPS.

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

Read this answer in context 👍 1

All Replies (10)

more options

Have you tried in Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search

Did you clear the browser cache? https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

What security software are you running?

more options

Thank you, jonzn4SUSE.

I have not tried running Firefox in Safe Mode. I can try that next time I start Firefox.

I have Firefox set to clear everything on closing. Does that include clearing the cache?

I use VIPRE, Malwarebytes and Superantispyware.

more options

I tried starting Firefox in Safe Mode but that didn't solve the problem.

When I get the error message " Secure Connection Failed," Restarting usually solves the problem.

more options
more options

Chosen Solution

You can try to disable DNS over HTTPS.

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

more options

Thank you, jonzn4SUSE and cor-el.

I tried disabling all security software and also running Windows in Safe Mode. Neither solved the problem.

The connection settings were No Proxy and DNS over HTTPS. Disabling DNS over HTTPS appears to have solved the problem. Usually, Firefox can access Yahoo Mail on boot-up so I closed and restarted Firefox several times. Each time, I was then able to login to Yahoo Mail. I was also able to access my Gmail accounts. I used Yahoo Mail as an example but the error message was occurring with various websites.

What are the implications of disabling DNS over HTTPS? I've read conflicting pro and con reports on the Internet.

more options

Unfortunately, the problem has returned. I couldn't access Yahoo Mail, Gmail, irs.gov and certain other websites. Usually, restarting solves the problem, at least for the first attempt, but restarting didn't solve the problem today. I had to use the Brave browser to access those websites.

more options
more options

Cor-el, I do daily malware scans with multiple security programs. Recently, only one tracking cookie (the same one) has been detected. My security software must now be blocking trracking cookies because, at times in the past, hundreds of tracking cookies were detected when I ran scans.

I previously tried booting in Windows Safe mode with network support (see above). That didn't fix the problem.

Today, on boot-up, Firefox worked - as it usually does on boot-up or restart. When I inadvertently closed Firefox, it worked when I opened it again. By "worked," I mean that I was able to access Yahoo Mail. I don't know how long this will continue. It worked for a day or so when I disabled DNS over HTTPS and then the problem returned.

more options

When I booted up my laptop this evening, once again I couldn't access Yahoo Mail. I tried twice but got the usual error message:

"Secure Connection Failed An error occurred during a connection to login.yahoo.com. PR_END_OF_FILE_ERROR

  The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
  Please contact the website owners to inform them of this problem."

I'm using Brave to post this message.