Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Not Secure noticewhen loading pages after latest upgrade

  • 2 replies
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

When I try to load pages I get the following message on most searches with the message by the tab indicating it is not secure:

   An error occurred during a connection to www.google.com. PR_END_OF_FILE_ERROR

I am using DuckDuckGo and tried switching to StartPage but, get the same result. This started more frequently after the last upgrade. Try duluthtrading.com to see if you get the same result.

Why is the connection through Google? How do I get back to being able to use Firefox as my default without so many issues?

I have reset Firefox, uninstalled and reinstalled Firefox, and set everything to default numerous times.

Thank you for any help you can provide.

All Replies (2)

more options

Let me see whether I understand the scenario:

(1) You run a search on DuckDuckGo and you get a results page, for example,

https://duckduckgo.com/?t=ffab&q=firefox&ia=web

(That URL was generated by searching through Firefox's address bar with the built-in DDG search engine plugin. Searching DDG in other ways would give you a different looking URL.)

(2) You click a link in the page, either a paid ad (which may or may not be through the Google network), or an organic result (which has no reason to be related to Google).

(3) You get a connection error on www.google.com.


Could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

more options

Web search: https://www.bing.com/search?q=pr_end_of_file_error

radi.stoyanov said Turns out the option DNS over HTTPS is what caused the problem.

jamesafuf123 said https://support.mozilla.org/en-US/questions/1264659#answer-1237475 my ISP was blocking sites like that

cor-el said This usually means that Firefox wasn't able to find a cipher suites to use to connect to this server and reached the end of the list. There can be two possibilities: one is that the server is outdated and doesn't support modern cipher suites, another might be that the server only supports a few cipher suites and Firefox doesn't support any of these.

You can check your browser and possibly compare this with the server setup. https://www.ssllabs.com/ssltest/viewMyClient.html


https://appuals.com/pr-end-of-file-error/

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.