Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites became unreadable after updating Firefox

  • 7 replies
  • 1 has this problem
  • 126 views
  • Last reply by FredMcD

more options

Hi! I'm using Firefox 95.0 on Linux Manjaro Gnome. For some reason, strange CSS styles began to appear on some sites, making them unreadable. It is not possible to understand where this styles comes from, but definitely not from the site, since in other browsers they are displayed correctly. Here is a link to screenshots from different sites screenshot 1 screenshot 2 What's most interesting - in the Settings What I have tried: - Fonts And Colors section: The checkbox in the "Use system colors" is unchecked The checkbox in "Allow pages to choose their own fonts" is checked - I also tried to clear the browser cache - Also disabled all plugins - Changed the theme to the default one. - Disabled / Enabled "Use hardware acceleration when available" - I think that styles from userContent.css & userChrome.css are applied to sites. And I removed this files from /home/user/.mozilla/firefox/87syjf8o.default-release/chrome How I can fix this?

Chosen solution

I have found the reason. In Manjaro Gnome after updating you need to open "Tweaks" and in the Appearence section update Applications theme. For example I have selected Adwaita-maia-compact-dark and the problem is gone.

Read this answer in context 👍 0

All Replies (7)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Helpful?

more options

FredMcD said

Make sure you are not blocking content. https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/ https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

I tried to disable tracking protection and the problem is still. I have also deleted all cookies, cache and other data. Also I have opened Firefox in troubleshooting mode and the problem is still. Also enabled "Allow Web Sites To Choose Their Own. "

Make sure you haven't enabled a High Contrast theme in the OS settings.

Done

Helpful?

more options

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]

Helpful?

more options

cor-el said

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.
  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. See also this pref:
  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]

I tried to change this param layout.css.prefers-color-scheme.content-override from 3 to 2 and restarted the browser. The result is the same

Also I tried to create this param ui.systemUsesDarkTheme and set its value to light (0). The result is the same.

I think it has something to do with the files userContent.css & userChrome.css. For example: some styles from userContent.css appeared on the page. But deleting this files not giving the result.

Modified by Phoenix

Helpful?

more options

Chosen Solution

I have found the reason. In Manjaro Gnome after updating you need to open "Tweaks" and in the Appearence section update Applications theme. For example I have selected Adwaita-maia-compact-dark and the problem is gone.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.