Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 89 unusable: washed out, blurry text, transparent background

  • 10 replies
  • 1 has this problem
  • 105 views
  • Last reply by sbucc

more options

I'm using Xubuntu 20.04, yesterday Firefox was updated to version 89 and it is completely unusable. The issues are many: the colors are washed out, the text is blurry, and the window is now semi-transparent (I can see the desktop). The best way to describe it is with a screenshot, I'm attaching one for v89 (horrible) and one for the v75 (perfect), to which I have reverted and I'm using now. As you can see, v89 is almost unusable, with some pages completely impossible to read. I found a couple of pages describing similar problems, all referring to this page, but that solution had no effect whatsoever for me. I found also someone suggesting to disable proton, also ineffective (sorry, I forgot to copy the link.)

I'm using Xubuntu 20.04, yesterday Firefox was updated to version 89 and it is '''completely unusable'''. The issues are many: the colors are washed out, the text is blurry, and the window is now semi-transparent (I can see the desktop). The best way to describe it is with a screenshot, I'm attaching one for v89 (horrible) and one for the v75 (perfect), to which I have reverted and I'm using now. As you can see, v89 is almost unusable, with some pages completely impossible to read. I found a couple of pages describing similar problems, all referring to [https://cameratico.com/color-management/firefox/ this page], but that solution had no effect whatsoever for me. I found also someone suggesting to disable proton, also ineffective (sorry, I forgot to copy the link.)
Attached screenshots

Chosen solution

Were you already using Firefox 89.0.2 as that version addresses some more WebRender related issues ?

This could be a problem with WebRender, so you can try to disable WebRender to see whether this has effect.

You can disable WebRender by setting this pref to true on the the about:config page.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 0

All Replies (10)

more options

BTW, I have these issues only with Linux (Xubuntu), on Win10 v89 is perfectly fine.

more options

Can you paste here the Graphics section of the about:support page?

more options

Chosen Solution

Were you already using Firefox 89.0.2 as that version addresses some more WebRender related issues ?

This could be a problem with WebRender, so you can try to disable WebRender to see whether this has effect.

You can disable WebRender by setting this pref to true on the the about:config page.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

@TyDraniu, If I cut&paste it is too long and loses the formatting, how do I attach a file (zipped xhtml+css)?

Modified by sbucc

more options

@cor-el, thank you, setting gfx.webrender.force-disabled = true fixed it.

more options

Where do I get version 89.0.2? I usually go with whatever is in the ubuntu repository, so I have 89.0.1 installed from apt at the moment.

Modified by sbucc

more options

If you want to keep using Firefox from the Ubuntu repositories then you will have to wait until Firefox 89.0.2 becomes available and possibly give WebRender another try. If you want to receive a new version quicker and without the extras and modifications Ubuntu applies then you can switch to Firefox from the Mozilla server.

You can find the full version of the current Firefox release (89.0.1) in all languages and all operating systems here:

more options

@cor-el, I found and installed 89.0.2 and it still has the same problem out of the box, I have to set gfx.webrender.force-disabled = true to fix it, like in 89.0.1.

more options

This looks like an issue with WebRender that hasn't been fixed yet and maybe also not reported, so you can possibly file a bug report to see if the devs can fix this.

more options

Thanks @cor-el, I have filed bug 1718386 I find it very strange that it doesn't ask any OS or system info: I had to specify in the description that the bug only affects Linux not Windows, and I wonder if it is an issue only with Nvidia cards or maybe the specific driver version...