Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search.....

  • 70 replies
  • 32 have this problem
  • 1644 views
  • Last reply by Chris Ilias

more options

One of your recent updates has all searches forced to the address bar..... I use the Google search box on my homepage and from the first letter its moved to the address bar... Go back to the Google box on the homepage.... You've made it useless....

Chosen solution

There is an option to turn that off at the moment, but I don't know whether it is a permanent option:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Read this answer in context 👍 46

All Replies (10)

more options

I was ready to start a new thread about this annoying feature but I'm glad I was able to find a solution here, this one presented by jscher2000 helped me which I'm grateful for. I don't know why Mozilla added that useless and annoying option, right next to disabling backspace as default option to return to previous page. Wasted about 2 hours trying to find a solution for both options.

more options

Quote: right next to disabling backspace as default option to return to previous page

You can set browser.backspace_action = 0 on the about:config page to enable the history backspace action.

See also Changed in the Firefox 87 release notes.

To prevent user data loss when filling out forms, we’ve disabled the Backspace key as a navigation shortcut for the back navigation button. To re-enable the Backspace keyboard shortcut, you can change the about:config preference browser.backspace_action to 0.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

In answer to why I don't want to use the address bar?

Because I use Firefox as my home page and I have an "in page" search area that Mozilla was gracious enough to give us. I have used this for years and I love my setup and so much is changing I just don't want to lose my homepage setup too. edited only to shorten lines so the hopefully scroll bar would go away.


(note that scrollbars appear if you start a line with a space as this creates a PRE tag - c)

Modified by cor-el

more options

While I am grateful for all of the above comments can I take us back to one simple fact -

There is a tick box in Settings, General, where you can select from "Choose what content you want on your Firefox Home screen", that clearly states "Web Browser". Obviously, this makes the malfunction a cock-up by Firefox.

Similarly, with the "Bookmarks", why remove the ability "save this bookmark" (or whatever it said).

In this world of global communications is there any way to actualy talk to Firefox & get this glitches repaires?

more options

dragonsf8 said

Similarly, with the "Bookmarks", why remove the ability "save this bookmark" (or whatever it said).

Where was it removed from? To bookmark the current page/tab you can:

  • click the star icon in the address bar
  • right-click a blank area of the page > click the star icon on the context menu
  • right-click the page's tab on the tabs bar > Bookmark Tab
  • press the keyboard shortcut (Ctrl+D, or on Mac, Command+D)
more options

Doesn't anybody in the design shop understand that if it ain't broke don't fix it? It's bad enough to deal with every piece of software out there from Word to Photoshop version updates where the same stuff is constantly under a new name or changes how the old stuff works.

If you want to add OPTIONS to Firefox add options, don't screw up a good thing just because some coders are bored and think they know better than the users. Give us consistency, and for god's sake, if you change something make it easy to revert that detail.

So frustrating.

Oh, BTW, I can easily magnify the search window in the middle of the page but not the address bar. Did the 20 year-olds with perfect eyesight ever think of that?

more options

Hi Steve, did the solution work for you? In other words, this is feedback and you don't need help with this workaround?

more options

Why do software writers have yo change the basic configuration of a programme that was working well, by all means update for speed and securty, but if it aint broke, don't fixit, I thought Mozilla was trying to attract people not drive them away, all you do is get people annoyed, as if computers don't waste enough time natrually, you have to add to the problems by altering things that don't need altering. I upgraded , or wrather downgraded to the latest firefox a few weeks ago and ended up re installing an earlier version, leave things alone but offer alternatives to those that want them. I downloaded again today to see if the cockup was fixed, but it was the same, I then wasted time finding the fix to software writer ruination. LEAVE IT ALONE AND STOP FIDDLING WITH IT.

more options

Hi agedbikeman, did the solution work for you? In other words, this is feedback and you don't need help with this workaround?

more options

Hi everyone, jscher2000's post was marked as the solution by the person who asked the original question (koyotee). Your issue may have similar symptoms, but it is likely a different cause/solution. For better help, it would be best to use https://support.mozilla.org/en-US/questions/new/desktop/form where volunteers can get more details about your setup.

Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.

  1. 1
  2. 2
  3. 3
  4. 4