Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search.....

  • 70 replies
  • 32 have this problem
  • 1267 views
  • Last reply by Chris Ilias

more options

One of your recent updates has all searches forced to the address bar..... I use the Google search box on my homepage and from the first letter its moved to the address bar... Go back to the Google box on the homepage.... You've made it useless....

Chosen solution

There is an option to turn that off at the moment, but I don't know whether it is a permanent option:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Read this answer in context 👍 46

All Replies (20)

more options

Hi, if you're using the Google search box on the default Firefox home page, that is virtually identical to searching from the address bar.

The address bar will give you search suggestions (if they are turned on), and it will also give you other suggestions from your Firefox history, open tabs and other items that match your query.

Via the buttons at the bottom of the address bar pop-up you can limit to a single site.

You can also limit what the address bar shows you.

If that doesn't help, please can you explain why searching from the address bar is different or not suitable for your needs?

more options

I want to type my Google search criteria in the provided box on Firefox's home screen and have the results pop up in a Google window... Some of us don't have good eyesight and don't need the strain of examining the address bar.....

Either put it back the way it was, or add code to make it an option in the search section of tools..... Nothing there now solves my issue currently....

more options

Chosen Solution

There is an option to turn that off at the moment, but I don't know whether it is a permanent option:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

more options

I hadn't notice that change in 89 Beta as I'm not using that page. It is quite weird that you have something that looks like a search bar on the Firefox Home page, but if you type in it then suddenly the location bar drop-down list opens. I'm sure that a lot of people have difficulties with such focus switch and probably best would be to disable the search bar and only use the location bar if you are forced to use it anyway.

Actually, I do not see the bottom of the location bar drop-down list that shows the search engines if I limit the height of the Firefox window (it is simply cut off with no way to scroll). Hmm, adjusting the height, I can see that sometimes the search choices appear, but this isn't ensured: I comes and goes if I adjust the height with the drop-down list open (looks like a padding adjustment trying to show 9 items).

Can't it stay at the shortest (most compact) display?

more options

This is ridiculous. A search bar is for searching and an address bar is for addresses and never the twain should interchange. Renaming does not change the function. Quit screwing with things that work as intended.

more options

SeanaMuigean said

A search bar is for searching and an address bar is for addresses and never the twain should interchange.

Firefox has had a unified navigation + search experience in the "address bar" for dozens of versions now because... that's how all the other browsers work. I can't imagine that will change. But if you personally never want to search from the address bar, you can set keyword.enabled to false in about:config, as well as the above-referenced preference.

more options

Standard8 said

If that doesn't help, please can you explain why searching from the address bar is different or not suitable for your needs?

To add my two cents...

An address bar is for typing web page addresses, not search terms. That's what a search entry box is for. One widget, one use.

If I wanted to search from the address bar, I'd switch to Chrome or Edge or whatever other inferior product offers such muddled features.

Just because everyone else is doing it, doesn't mean it's a good idea. ;)

more options

jscher2000 said

There is an option to turn that off at the moment, but I don't know whether it is a permanent option: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste handoff and pause while the list is filtered (3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

It's not awesome, it's not in the middle of the page where I was focused.

That I have to resort to exotic means to restore expected behavior lessens the reason to use firefox to begin with.

Which reminds me, I need to check to see if default bookmark behavior is restored or are we still forced to used the add-on to achieve that.

more options

Colin WG said

Which reminds me, I need to check to see if default bookmark behavior is restored or are we still forced to used the add-on to achieve that.

A few versions ago, Firefox switched from always saving new bookmarks to "Other Bookmarks" by default to always saving new bookmarks to the last used folder by default. That may or may not work better for you.

more options

That works for me!

more options

Thank you koyotee. It took a couple of tries, but it finally worked.

To all: I use the search bar to quickly find stuff, (google it) that gives me a bunch of entries to click on. To find out about things. That is why I use the short search bar, not the address bar at the top.

Thanks ALL!!!

more options

jscher2000 said

SeanaMuigean said

A search bar is for searching and an address bar is for addresses and never the twain should interchange.

Firefox has had a unified navigation + search experience in the "address bar" for dozens of versions now because... that's how all the other browsers work. I can't imagine that will change. But if you personally never want to search from the address bar, you can set keyword.enabled to false in about:config, as well as the above-referenced preference.

I understand this and am grateful for the about:config fix, but it should at least be an option in the normal settings in my opinion.

more options

We come to firefox to avoid all the crap the other browsers force on you. I like to search from the google search window on my firefox homepage. It is very distracting to have it automatically move to the address bar. Please leave basic functions alone. Please stop showing us all that is new. If we want to see new features we can look for them. If there is a feature we want, we can look to see if it is available. When I open firefox I only want to see a clear screen with an empty google search window in the middle. Then I want to type something into that search window and have it stay in the search window. Then I want to hit return and have firefox take me to google showing my search results. Please I only want what I was looking to find. I do not wish to upset anyone, but you have absolutely nothing worth while to ever suggest for me. Remeber that if I want to find something I will go and find it. The same may apply to features. Turn them all off and let us choose what we wish to use. Default should be off for everything that doesn't disable the browser.

Steve

more options

jscher2000 said

There is an option to turn that off at the moment, but I don't know whether it is a permanent option: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste handoff and pause while the list is filtered (3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

What does your "solution" turn off? I want the Web Search box on my Home Page to work as it always did, and NOT jump to the toolbar address box. This is driving me absolutely nuts! Why did Firefox change this? Think I am going mad...... about to ditch Firefox for ever more!

more options

smthiebaud said

We come to firefox to avoid all the crap the other browsers force on you. I like to search from the google search window on my firefox homepage. It is very distracting to have it automatically move to the address bar. Please leave basic functions alone. Please stop showing us all that is new. If we want to see new features we can look for them. If there is a feature we want, we can look to see if it is available. When I open firefox I only want to see a clear screen with an empty google search window in the middle. Then I want to type something into that search window and have it stay in the search window. Then I want to hit return and have firefox take me to google showing my search results. Please I only want what I was looking to find. I do not wish to upset anyone, but you have absolutely nothing worth while to ever suggest for me. Remeber that if I want to find something I will go and find it. The same may apply to features. Turn them all off and let us choose what we wish to use. Default should be off for everything that doesn't disable the browser. Steve

Hi Steve, my frustration & annoyance is totally the same as yours! If you find a solution to make the Web Search box on the Home Page work again, like it used to, before the 89.0 update, could you please let me know. Huge thanks!

more options

jscher2000 said

There is an option to turn that off at the moment, but I don't know whether it is a permanent option: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste handoff and pause while the list is filtered (3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Ok thanks jscher2000 - I followed above instructions & now I can use the Web Search box on the Home Page again - thanks so much!

more options

No! In Firefox 89 fix - browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false is incorrect! The fix is incorrect. Because if the text in the search bar is long, the text does not go under the button. This bug was in Firefox 66. Fix browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false was correct at that time! Not now. Will this be fixed?

more options

kati00555 said

No! In Firefox 89 fix - browser.newtabpage.activity-stream.improve search.hand off To Awesome bar = false is incorrect! The fix is incorrect. Because if the text in the search bar is long, the text does not go under the button.

It's not pretty:

You can file a new bug report here: https://bugzilla.mozilla.org/

more options

This is very sad! Especially when you don't test the solutions you offer.

more options

kati00555 said

This is very sad! Especially when you don't test the solutions you offer.

P.S. I don't work for Mozilla, I'm just giving up my nights and weekends to help my fellow users.

  1. 1
  2. 2
  3. 3
  4. 4