Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons not showing in toolbar

  • 5 replies
  • 2 have this problem
  • 37 views
  • Last reply by Mark

more options

Hello


When it comes to add-ons, then I add three of four at once or the same purpose, I try them all out, decide if I want to keep any of them, and then remove the ones I see that do not serve my target. All normal.


I know that it requires permission in order to have an add-on show in Private Browsing, that's done.

Now I had 8 add-ons on the toolbar, I disabled two or three of them so I can try two new ones. I did not like the new ones, so I just enabled the ones I had disabled, which where previously showing in the toolbar, all of this in Private Browsing having the permission of showing them.


As I enabled the add-ons again, they are not showing anymore in the toolbar..!!

Okay, I removed them and re-added them..not showing. I also did: not allow in Private Mode, then re-allowed..not showing. I simply restarted the browser in both normal and Private Mode, and yet not showing.. I also restarted my pc, and retried all previous steps again

  • This mainly happened as I removed the extension from toolbar, then added it again.

Still also 90% of the time, just disable then enable again, and only a few are showing again. Either when disabled then re-enabled or when removed then re-added*


So, what to do ?

All Replies (5)

more options

At the far right of the toolbar, do you see an arrow? Press it.

Helpful?

more options

Hmm, I think you mean the double arrow to the right side.

I found it as I clicked on customize toolbar, when I hover it says [more tools..]. I found that add-on included in the list and dragged it to the toolbar. So, basically my problem is solved. But now I would like to know how to add those arrows please, if you may know how.

Helpful?

more options

You can try Restore Defaults in customize mode or possibly reset browser.uiCustomization.state on the about:config page to see if that has effect.

Modified by cor-el

Helpful?

more options

Basically, the toolbar only has so much room. So any that can't be placed on the 'visible' bar is placed in the overflow area. (The double arrows.)

You can set up the icons to your liking.

Helpful?

more options

Basically since I have access to the add-on again, then I take this problem as solved. Thank you everyone for your replies !

Just as comments on latest replies:

cor-el said

You can try Restore Defaults in customize mode or possibly reset browser.uiCustomization.state on the about:config page to see if that has effect.

I had restarted the customize page to default, I will try the about:config, but it seems that my default system does not have the overflow area or those double arrows displayed.

FredMcD said

Basically, the toolbar only has so much room. So any that can't be placed on the 'visible' bar is placed in the overflow area. (The double arrows.) You can set up the icons to your liking.

Sure, it seems that I will be going to the customize page every time I want to access the overflow area. At least in a way I know where the solution lies.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.