Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google searh keeps switching to yahoo

  • 10 replies
  • 2 have this problem
  • 149 views
  • Last reply by jscher2000

more options

I cleared all my cookies and the search engine shows google but the results come out in yahoo. Extremely annoying. Please help

All Replies (10)

more options

hi, firefox ships with google as the default engine - if yahoo is showing up without your knowledge that might be a sign of adware or a malicious addon being present on your system.

  1. please go to the firefox menu ≡ > addons > extensions & remove any suspicious entries (toolbars, things that you have not installed intentionally, don't know what purpose they serve, etc).
  2. also go to the windows control panel / programs and remove all toolbars or potentially unwanted software from there.
  3. finally, run a full scan of your system with different security tools like the free version of malwarebytes & adwcleaner, which are specialised in adware and browser hijackers.

Remove a toolbar that has taken over your Firefox search or home page Troubleshoot Firefox issues caused by malware

Helpful?

more options

That kind of hijack -- where the address bar drop-down says it will be sending your query to Google but you get results on Yahoo -- is most commonly perpetrated through an add-on. So with that in mind: you can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or private search, or looks suspicious or you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

After escaping the grip of a rogue add-on, you still might need to update your default search setting and remove suspicious one-click search engines. More on how to do that in this article: Change your default search settings in Firefox.

Any improvement?

Finally, to reduce the potential for reinfection, please supplement your regular security software with some of the well-regarded scanners listed in this support article: Troubleshoot Firefox issues caused by malware.

Helpful?

more options

I realized there are two other similar reports from Windows users in the space of 5 minutes, so something must be going around. Do you want to share your extensions list? You can copy/paste it from the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down past "Application Basics" and "Firefox Features" to "Add-ons". Then you can select and copy the table that follows (not the entire page, please, that's too much information) using either Ctrl+c or right-click > Copy and then paste it into a reply. It will be messy, but we're used it.

Helpful?

more options

I try going to add ons multiple ways and it opens a new blank tab. It's obviously trying to block me from removing it.

Helpful?

more options

please see if you can perform this when starting firefox in safemode: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Helpful?

more options

jscher, Same result. All it does is block me from opening a new page.

Helpful?

more options

Doing the "refresh" solved the issue. Thank you very much

Helpful?

more options

pmw97ws6 said

Doing the "refresh" solved the issue. Thank you very much

Thank you for reporting back!

Okay, your old profile folder should have moved to your desktop inside an Old Firefox Data folder. You can drag-and-drop (or open) the extensions.json file from that folder onto my tool here to list out the extensions from your old profile in a more understandable format:

https://www.jeffersonscher.com/ffu/extensionsjson.html

Anything weird in there?

The full table is unfortunately too much data to paste here, but you could save it or PDF it or screenshot it for future reference. If you want to email the saved table to me, try my username @gmail.com. Thanks.

Helpful?

more options

I am having the same issue on my MacBook. I have tried all of the recommended solutions including Safe Reset and the google search still switches to yahoo.

Helpful?

more options

ibmags4 said

I am having the same issue on my MacBook. I have tried all of the recommended solutions including Safe Reset and the google search still switches to yahoo.

Can you access the Add-ons page, Extensions panel, and see whether any are currently installed/enabled? If you get a blank page, try checking in Firefox's Safe Mode (not using Refresh).

Extension Check

Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Also, someone mentioned in another thread an extension named New Custom Tab; be on the lookout for that one.

Firefox's Safe Mode

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Mac, hold down the Shift key instead of the option/alt key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.