Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not opening correctly

  • 5 replies
  • 2 have this problem
  • 1253 views
  • Last reply by wolfgang52

more options

Hi today I opened my linux installation and Firefox is only getting a window with the text:

             <toolbarbutton <="" class="close-icon" id="UITourTooltipClose" pre="">

I tried to run from the console with the --MOZ_LOG_FILE flag and the generated file has absolutely no text in it.

Some information about my system: kernel: Linux localhost.localdomain 5.7.7-1-default #1 SMP Wed Jul 1 19:03:27 UTC 2020 (cba119b) x86_64 x86_64 x86_64 GNU/Linux

OS: openSUSE 20200715

DE: KDE 5.72.0 / Plasma 5.19.3

Version: 78.0.2-1.1 (according to zypper info MozillaFirefox command)

</toolbarbutton>
Attached screenshots

Modified by Gresthol

Chosen solution

Are you currently using a version from the repositories of your Linux distribution?
Try the Firefox version from the official Mozilla server:

https://www.mozilla.org/en-US/firefox/all/

Read this answer in context 👍 1

All Replies (6)

more options

Chosen Solution

Are you currently using a version from the repositories of your Linux distribution?
Try the Firefox version from the official Mozilla server:

https://www.mozilla.org/en-US/firefox/all/

Helpful?

more options

We had another user with this issue that is using OpenSUSE, so maybe there is a problem with this update. In that case clearing the profile in the ~/.cache location worked.

  • /questions/1295425 Thank you for breaking Firefox? - No more browser window, just a weird error (openSUSE Tumbleweed)

Helpful?

more options

I have exactly the same problem. Clearing ~/.cache did not help.

Helpful?

more options

Same Problem here:

Operating System: openSUSE Tumbleweed 20200721 KDE Plasma Version: 5.19.3 KDE Frameworks Version: 5.72.0 Qt Version: 5.15.0 Kernel Version: 5.7.9-1-default OS Type: 64-bit Processors: 4 × Intel® Core™2 Quad CPU Q9400 @ 2.66GHz Memory: 7.6 GiB of RAM Graphics Processor: GeForce GT 610/PCIe/SSE2

Firefox installed from tumbleweed-repo: Mozilla Firefox Web Browser, Version 78.0.2-2.2 (195,7 MiB)

Edit: Firefox binary (78.0.2, 64-Bit) downloaded from mozilla-webpage runs fine, maybe a Tumbleweed-Problem?

Modified by peter.huyoff

Helpful?

more options

Exactly the same problem for me: OS: openSUSE Tumbleweed 20200726 64-bit KDE-Plasma-Version: 5.19.3 KDE-Frameworks-Version: 5.72.0 Qt-Version: 5.15.0 Kernel-Version: 5.7.9-1-default

Firefox version 78.0.2-2.3 from tumbleweed-repo

Weird thing is: If I create a new profile everything works. If I use safe-mode with old profile, everything works. In safe-mode I also disabled every extension, theme and plugin, but this did not work. Clearing ~/.cache didnt work either.

The official download is already version 79, repo doesnt seem to have switched yet to v79.

Helpful?

more options

openSUSE and Mozilla bug references: https://bugzilla.opensuse.org/show_bug.cgi?id=1174184 https://bugzilla.mozilla.org/show_bug.cgi?id=1653841

It seems addonStartup.json.lz4 in the Firefox profile is not updated as required automatically. Deleting this file is reported to fix the issue. (Please keep a backup.) https://bugzilla.opensuse.org/show_bug.cgi?id=1174184#c21 also explains how to modify the file w/o removing it to fix it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.