Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I permanently turn off "mixed content" blocking?

  • 5 replies
  • 1 has this problem
  • 2 views
  • Last reply by McCoy

more options

I think my Firefox updated, and now there is a feature where any "insecure" sites now have all the media blocked on it. When I click "Disable protection for now," it does nothing and I have no way to unblock any of it. I am literally just trying to read the TF2 comics, which I know are on a safe website (and even if they weren't, I have antivirus software that protects my computer just fine), but because of this "mixed content" block I literally can't see anything but a white page. I've searched settings for a way to permanently disable this protection, but I haven't found anything.

Chosen solution

I cleared my cookies and cache and restarted Firefox after uninstalling the Norton extension completely and now it seems to be working fine. Still, this feature is a bit of an annoyance and should have a place in the settings to be completely disabled rather than re-disabled temporarily over and over again.

Read this answer in context 👍 0

All Replies (5)

more options

Hello   Izzli,

I just went to TF2 Comics and it worked just fine for me .....

Then I took a look at your system details and I noticed that you're using
"Norton Safe Web";   would you (just for now) disable it and see if maybe
that turns out to be the culprit ?

Helpful?

more options

Hi, I tried this and it worked the first time but now it's doing the same thing as before. No matter how many times I click the disable button it won't do anything.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

----

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

Chosen Solution

I cleared my cookies and cache and restarted Firefox after uninstalling the Norton extension completely and now it seems to be working fine. Still, this feature is a bit of an annoyance and should have a place in the settings to be completely disabled rather than re-disabled temporarily over and over again.

Helpful?

more options

Call me stubborn, but I'm still saying that Norton Safe Web was causing the problem; some extensions still work after merely disabling them.
You did the right thing thing removing it.

As for "Mixed content blocking";   you might find this article interesting :

https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox

Firefox only has your best interest ar heart .......

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.