X
Tap here to go to the mobile version of the site.

Support Forum

Website displays most of the items but not the interactive map while using Firefox but displays map in IE

Posted

OK, the websites URL is: https://www.wunderground.com/wundermap. When I use Firefox all the frames, ads and all the other stuff around the map is displayed just like it is in IE. The only problem is the interactive map. This is the map that will display all the PWSs (Personal Weather Stations), that normal people like me have that are connected to the internet, so that I (or anyone else) can see what the temperature and all other aspects of the current weather is like at that location. There seems to be a problem with it being displayed using Firefox that neither IE or Chrome seem to have (those two browsers display the interactive map with no problems). When you bring up the page in Firefox all you get is a blank blue screen where the interactive map should be. Don't know if the problem i with Firefox or with their website. It seems that the Wundermap company sold out to The Weather Channel about the ame time as your last update (which is when I first noticed the problem. The Weather Channels suggest that I just stop using Firefox and start using IE! That will never happen as I have seen to many problems with vulnerability using IE and will only use Firefox and have been since it's first release long long ago. If you find out it is not a problem with Firefox but their website, maybe you can get a hold of The Weather Channels web people and tell they what they need to do go get it to work with Firefox. I know that in the past there have been several other sites that did not work with Firefox as the site makers were using some web page creator that did not "port" to Firefox (at least that is what I was told by their support dept.) and soon after was fixed to work with Firefox. That is what I suggested to them, but as I stated above, their response was to just quit using Firefox.

Attached pictures are suppose to be of the same location on the map but as you can see, with Firefox-no map and with IE-map

OK, the websites URL is: https://www.wunderground.com/wundermap. When I use Firefox all the frames, ads and all the other stuff around the map is displayed just like it is in IE. The only problem is the interactive map. This is the map that will display all the PWSs (Personal Weather Stations), that normal people like me have that are connected to the internet, so that I (or anyone else) can see what the temperature and all other aspects of the current weather is like at that location. There seems to be a problem with it being displayed using Firefox that neither IE or Chrome seem to have (those two browsers display the interactive map with no problems). When you bring up the page in Firefox all you get is a blank blue screen where the interactive map should be. Don't know if the problem i with Firefox or with their website. It seems that the Wundermap company sold out to The Weather Channel about the ame time as your last update (which is when I first noticed the problem. The Weather Channels suggest that I just stop using Firefox and start using IE! That will never happen as I have seen to many problems with vulnerability using IE and will only use Firefox and have been since it's first release long long ago. If you find out it is not a problem with Firefox but their website, maybe you can get a hold of The Weather Channels web people and tell they what they need to do go get it to work with Firefox. I know that in the past there have been several other sites that did not work with Firefox as the site makers were using some web page creator that did not "port" to Firefox (at least that is what I was told by their support dept.) and soon after was fixed to work with Firefox. That is what I suggested to them, but as I stated above, their response was to just quit using Firefox. Attached pictures are suppose to be of the same location on the map but as you can see, with Firefox-no map and with IE-map
Attached screenshots

Chosen solution

Yes, I did. I found the area that said: "WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry:". But didn't tell me where, or who blacklisted it! Or even why. And it doesn't tell me where to go to change something I don't even know where to look for! Also in that area, in Direct2D it told me: "Blocked for your graphics driver version mismatch between registry and DLL.) Well I don't what exactly caused that either since, as I already told you (as a group, and not in these exact words), there are no updates for my video driver. It is the way it came from HP and the way I bought it! HP has never put out an update for the drivers and never EVER has any other driver (even from the maker of the chips) ever created one that will work for one installed on this HP unit. so why it wouild not match between the Reg. and the DLL is beyond me.

Anyway, I a lighter note, It did start me searching again and found this on the web: https://www.sitepoint.com/firefox-enable-webgl-blacklisted-graphics-card/ That explained to me that it was actually Firefox that is blocking and Blacklisting my video drivers from running WebGL and Direct2D from working (which is apparently why it works just fine on MS IE but not on Firefox). I kind of figured something like this should have been common knowledge to guys like you and should have know the quick and simple fix explained on this website. after doing the 3 simple and little steps described on this link all is working perfectly......so, problem fixed

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 61.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Support URL: https://support.mozilla.org/1/firefox/61.0.2/WINNT/en-US/

Extensions

  • Honey 10.7.5 (jid1-93CWPmRbVPjRQA@jetpack)
  • New Tab Homepage 0.6.2 ({66E978CD-981F-47DF-AC42-E3CF417C1467})
  • Norton Identity Safe 5.4.2.19 (idsafe@norton.com)
  • RetailMeNot Genie 1.2.103 (retailmenot-genie@rmn.com)
  • Strict Pop-up Blocker 0.6 (jid1-P34HaABBBpOerQ@jetpack)
  • Adblock Plus Pop-up Addon 0.9.2.1-signed.1-signed (adblockpopups@jessehakanen.net) (Inactive)
  • Flash Control 2.1.4 (jid1-sNL73VCI4UB0Fw@jetpack) (Inactive)
  • Norton Home Page 2.8.0.54 (nortonhomepage@symantec.com) (Inactive)
  • Norton Safe Search 2.8.0.54 (nortonsafesearch_ul_2@symantec.com) (Inactive)
  • Norton Safe Web 2.8.0.53 (nortonsafeweb@symantec.com) (Inactive)
  • PasswordsPlus 3.000.209 (PasswordsPlus@dataviz.com) (Inactive)
  • Pop-up Controller 0.9.1-signed.1-signed (jid1-MIAJd5BiK7V4Pw@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 165a103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedMismatchedVersion']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 9-30-2011
  • driverDate2:
  • driverVersion: 8.882.2.3000
  • driverVersion2:
  • failures: [u'CP+[GFX1-]: Mismatched driver versions between the registry 8.882.2.3000 and DLL(s) 8.15.10.2476, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 8.882.2.3000 and DLL(s) 8.15.10.2476, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 8.882.2.3000 and DLL(s) 8.15.10.2476, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 8.882.2.3000 and DLL(s) 8.15.10.2476, reported.']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_', u'type': u'env'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blacklisted', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_', u'type': u'env'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • indices: [0, 1, 2, 3]
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedMismatchedVersion']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: False
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (Software Adapter Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.fcbca0e873c3)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000000000) EGL_VERSION: 1.4 (ANGLE 2.1.0.fcbca0e873c3) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry:
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

When I clicked on your link I got the blank blue screen you mentioned.

Then I clicked on 'Map Settings' and : voilà  !

When I clicked on your link I got the blank blue screen you mentioned. Then I clicked on 'Map Settings' and : voilà !

Question owner

If you are talking about the "Map Settings" on the top right of the webpage, that does not do anything for me except bring up the settings for the map and no matter what settings I choose the map never ever comes up. The attached picture is after clicking on the "Map Setting". You will see that there are only two boxes that you can change, one for whether or not you want have displayed °F or °C temps and the other chooses the type of map and on that one I have as, I have for years, chosen the "Wundermap" (which is the one that is suppose to display all the PWS in the area you are focused on. As you can see in the picture the map screen is still blank blue with no map. Even if you click back on "Map Settings" again, all it does is make the drop down disappear, and you are still left with (only larger) a blank blue map.

If you are talking about the "Map Settings" on the top right of the webpage, that does not do anything for me except bring up the settings for the map and no matter what settings I choose the map never ever comes up. The attached picture is after clicking on the "Map Setting". You will see that there are only two boxes that you can change, one for whether or not you want have displayed °F or °C temps and the other chooses the type of map and on that one I have as, I have for years, chosen the "Wundermap" (which is the one that is suppose to display all the PWS in the area you are focused on. As you can see in the picture the map screen is still blank blue with no map. Even if you click back on "Map Settings" again, all it does is make the drop down disappear, and you are still left with (only larger) a blank blue map.

Modified by DOMAPOI

McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Well, if it is the 'Map Settings' button that doesn't work, then let's try Firefox in Safe Mode, to see if maybe one of your extensions (if you have any) could be causing this :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Well, if it is the 'Map Settings' button that doesn't work, then let's try Firefox in Safe Mode, to see if maybe one of your extensions (if you have any) could be causing this : If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !) See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Separate issue :

Your system details show that you need to update your Adobe Flash Player - you're running an old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is 30.0.0.154

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.

Separate issue : Your system details show that you need to update your Adobe Flash Player - you're running an old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is '''30.0.0.154''' Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html https://get.adobe.com/flashplayer/ Note : some 'extras' may be offered in the download.

Question owner

Well, it is getting better. I first shut down Firefox and as instructed pressed the shift key an started Firefox back up. Chose the Safe Mode option in the little box that had popped up and the resulting screen shot is what I go when I went to the www.wunderground.com/wundermap. As you can see, the dots and wind indicators coming off some of the dot are there, as well as some rain indicated by the green blobs, but there are no numbers indicating the temp. inside those dots as there should be and there still is no map. I also went the other direction using your second method for starting Firefox if it was already running (following those instructions you gave me for that incident, same results. I then went into the "add-ons" menu and disabled EVERY add-on, extension, theme and anything else that I could have changed and then restarted Firefox again and instead of having the blank dots and wind indicators it was blank like it was when I first filed this support ticket. Don't know what else "safe mode" disables but it must be more than just add-ons, extensions and themes. I also started thinking that since the map may be a shockwave I would try and upgrade the Shockwave player. Found out that the old shockwave player only works with a 32 bit version of Firefox so I downloaded it and installed it. Still no map or dots or anything but blank blue. Made sure it was the 32 bit version by checking the "Help" "About Firefox" which verified it was indeed 32 bit. Since that didn't work, I reinstalled the 64 bit version and made sure that the "Flash Player" was up to date (which I found out also includes a new version of Shockwave (at least it seems that way since after the "flash Player" up date the Shockwave player says it has a update date of today). But, alas, still just a blank blue screen when started normally.

Well, it is getting better. I first shut down Firefox and as instructed pressed the shift key an started Firefox back up. Chose the Safe Mode option in the little box that had popped up and the resulting screen shot is what I go when I went to the www.wunderground.com/wundermap. As you can see, the dots and wind indicators coming off some of the dot are there, as well as some rain indicated by the green blobs, but there are no numbers indicating the temp. inside those dots as there should be and there still is no map. I also went the other direction using your second method for starting Firefox if it was already running (following those instructions you gave me for that incident, same results. I then went into the "add-ons" menu and disabled EVERY add-on, extension, theme and anything else that I could have changed and then restarted Firefox again and instead of having the blank dots and wind indicators it was blank like it was when I first filed this support ticket. Don't know what else "safe mode" disables but it must be more than just add-ons, extensions and themes. I also started thinking that since the map may be a shockwave I would try and upgrade the Shockwave player. Found out that the old shockwave player only works with a 32 bit version of Firefox so I downloaded it and installed it. Still no map or dots or anything but blank blue. Made sure it was the 32 bit version by checking the "Help" "About Firefox" which verified it was indeed 32 bit. Since that didn't work, I reinstalled the 64 bit version and made sure that the "Flash Player" was up to date (which I found out also includes a new version of Shockwave (at least it seems that way since after the "flash Player" up date the Shockwave player says it has a update date of today). But, alas, still just a blank blue screen when started normally.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Bummer  !

Let's try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this change anything  ?

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:


If the above didn't make a difference, then let's try the Refresh feature :

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
Bummer ! Let's try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this change anything ? If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] --------------------------------------------------------------------------------------------------------- If the above didn't make a difference, then let's try the Refresh feature : The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen.

Question owner

Still a no-go an still a blank blue map. Won't send picture but if you look at the first one I sent, that is what it looks like still. As far as updating my video drivers, that will never happen, it seems. HP, in their wisdom doesn't seem to ever want to put out an update for their video chips. I have tried and tried to get them to do so for this model laptop to to no avail. I have also tried every upgrade that Radeon has put out for this version but they always come up saying that it is incompatible with my video. It seems it has to be from HP but HP won't update their drivers.

Still a no-go an still a blank blue map. Won't send picture but if you look at the first one I sent, that is what it looks like still. As far as updating my video drivers, that will never happen, it seems. HP, in their wisdom doesn't seem to ever want to put out an update for their video chips. I have tried and tried to get them to do so for this model laptop to to no avail. I have also tried every upgrade that Radeon has put out for this version but they always come up saying that it is incompatible with my video. It seems it has to be from HP but HP won't update their drivers.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Would you give this a try :

Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try :

"Remove the Cookies" from websites that cause problems :

Options => Privacy & Security => Cookies and Site Data => Manage Data

"Clear the Cache":

Options => Privacy & Security => Cookies and Site Data => Clear Data => Cached Web Content : Clear (uncheck 'Cookies and Site Data first)


If none of the suggestions work, and nobody else comes up with the perfect solution for you, maybe you'd consider contacting wunderground.com :

https://www.wunderground.com/about/contact-us

When you scroll down to the bottom of the page, you'll see :

"Our Tech Support staff will be more than happy to assist you with any issues. Please submit a ticket to Tech Support using our customer service center. Or email them directly at help@wunderground.com "

Would you give this a try : Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R' Another thing to try : "Remove the Cookies" from websites that cause problems : Options => Privacy & Security => Cookies and Site Data => Manage Data "Clear the Cache": Options => Privacy & Security => Cookies and Site Data => Clear Data => Cached Web Content : Clear (uncheck 'Cookies and Site Data first) ---------------------------------------------------------------------------------------------------------- If none of the suggestions work, and nobody else comes up with the perfect solution for you, maybe you'd consider contacting wunderground.com : https://www.wunderground.com/about/contact-us When you scroll down to the bottom of the page, you'll see : "Our Tech Support staff will be more than happy to assist you with any issues. Please submit a ticket to Tech Support using our customer service center. Or email them directly at help@wunderground.com "
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

One thing I haven't asked you yet (and should have) :

Could it be that you're using Tracking Protection  ?

If so : it could be blocking some content ......

See : https://support.mozilla.org/en-US/kb/tracking-protection

One thing I haven't asked you yet (and should have) : Could it be that you're using Tracking Protection ? If so : it could be blocking some content ...... See : https://support.mozilla.org/en-US/kb/tracking-protection
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

The posted screenshots do not show the shield icon indicating that TP is blocking content. I do see the shield icon, but that doesn't affect the map.

The map uses WebGL, so you can check the graphics section on the "Help -> Troubleshooting Information" (about:support) page for possible isdsues with WebGL.

Also make sure that WebGL isn't disabled, so check the about:config page. You can paste this in the location/address bar and accept the warning.

  • about:config?filter=webgl

That will open the about:config page with prefs that match this filter.

You can also check the Web Console for error messages.

The posted screenshots do not show the shield icon indicating that TP is blocking content. I do see the shield icon, but that doesn't affect the map. The map uses WebGL, so you can check the graphics section on the "Help -> Troubleshooting Information" (about:support) page for possible isdsues with WebGL. Also make sure that WebGL isn't disabled, so check the <b>about:config</b> page. You can paste this in the location/address bar and accept the warning. *about:config?filter=webgl That will open the <b>about:config</b> page with prefs that match this filter. You can also check the Web Console for error messages. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console

Question owner

OK, attached is a copy of the output for the about:config?filter=webgl where it shows everything is set to the "default". Don't know what I would have to change (if anything) in there.

I would like to send you the "Web_console" report after I started the Wundergrounds Wundermap. But, there is no way to attach a text file using this format as it will only except image files, not text files. And it is much to big to do a screenshot copy and paste into an image file. It does show error message indications that involve the "Webgl" , but I am at a loss as to why webgl doesn't work in Firefox but seems to work just fine in IE. How and where can I send this text report.

OK, attached is a copy of the output for the about:config?filter=webgl where it shows everything is set to the "default". Don't know what I would have to change (if anything) in there. I would like to send you the "Web_console" report after I started the Wundergrounds Wundermap. But, there is no way to attach a text file using this format as it will only except image files, not text files. And it is much to big to do a screenshot copy and paste into an image file. It does show error message indications that involve the "Webgl" , but I am at a loss as to why webgl doesn't work in Firefox but seems to work just fine in IE. How and where can I send this text report.

Question owner

This response it to McCoy in reference to the question about "Tracking Protection"

After reading your question I checked and did have tracking protection on, I disabled "tracking protection" to see if that would fix the problem an that did not work either. I set it to "Never" and then shut down and restarted Firefox an went to Wundermap and still had the blank/blue map.

This response it to McCoy in reference to the question about "Tracking Protection" After reading your question I checked and did have tracking protection on, I disabled "tracking protection" to see if that would fix the problem an that did not work either. I set it to "Never" and then shut down and restarted Firefox an went to Wundermap and still had the blank/blue map.

Question owner

Another response to McCoy on "Would you give this a try :"

Tried the: Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try :

"Remove the Cookies" from websites that cause problems :

Options => Privacy & Security => Cookies and Site Data => Manage Data

"Clear the Cache":

Options => Privacy & Security => Cookies and Site Data => Clear Data => Cached Web Content : Clear (uncheck 'Cookies and Site Data first)

And this did not work either. I have been in contact with Wunderground for months now an all the keep responding with is that they can not find any problem on there end and since it seems to work just fine while using MS IE they have washed their hands of any fault.

Another response to McCoy on "Would you give this a try :" Tried the: Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R' Another thing to try : "Remove the Cookies" from websites that cause problems : Options => Privacy & Security => Cookies and Site Data => Manage Data "Clear the Cache": Options => Privacy & Security => Cookies and Site Data => Clear Data => Cached Web Content : Clear (uncheck 'Cookies and Site Data first) And this did not work either. I have been in contact with Wunderground for months now an all the keep responding with is that they can not find any problem on there end and since it seems to work just fine while using MS IE they have washed their hands of any fault.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Thank you for reporting back to us. Sorry to put you through all that trouble and still come up with no solution - must be so frustrating  ! You've tried just about everything in the book ..... The only thing I can think of now is to ask you : have you set Shockwave Flash to 'Always Activate'  ?

Thank you for reporting back to us. Sorry to put you through all that trouble and still come up with no solution - must be so frustrating ! You've tried just about everything in the book ..... The only thing I can think of now is to ask you : have you set Shockwave Flash to 'Always Activate' ?

Question owner

Yes, I tried that too. What is strange is that in the past it worked just fine with all my settings the way they were and never had a problem with it until your last Firefox update and the purchase of Wunderground.com by The Weather Channels which both happened about the same time (or at least between the time I checked my wundermap when it worked and when it started not working. Nothing had changed other than those two things as far as I know.

Yes, I tried that too. What is strange is that in the past it worked just fine with all my settings the way they were and never had a problem with it until your last Firefox update and the purchase of Wunderground.com by The Weather Channels which both happened about the same time (or at least between the time I checked my wundermap when it worked and when it started not working. Nothing had changed other than those two things as far as I know.
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

Can you post a screenshot that shows some WebGL related error messages in the Web Console?

Note that there is a button on the toolbar in the developer toolbox to show the console in a standalone window.

Can you post a screenshot that shows some WebGL related error messages in the Web Console? Note that there is a button on the toolbar in the developer toolbox to show the console in a standalone window. *https://developer.mozilla.org/en-US/Tools/Web_Console

Question owner

Here is the screenshot of a section of the webgl error

Here is the screenshot of a section of the webgl error
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

You can see the "Failed to initialize WebGL" and "Failed to create WebGL context" and some other error messages about unable to create a buffer.

Do you see any WebGL errors listed on the on the "Help -> Troubleshooting Information" (about:support) page?

You can see the "Failed to initialize WebGL" and "Failed to create WebGL context" and some other error messages about unable to create a buffer. Do you see any WebGL errors listed on the on the "Help -> Troubleshooting Information" (about:support) page? *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox

Chosen Solution

Yes, I did. I found the area that said: "WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry:". But didn't tell me where, or who blacklisted it! Or even why. And it doesn't tell me where to go to change something I don't even know where to look for! Also in that area, in Direct2D it told me: "Blocked for your graphics driver version mismatch between registry and DLL.) Well I don't what exactly caused that either since, as I already told you (as a group, and not in these exact words), there are no updates for my video driver. It is the way it came from HP and the way I bought it! HP has never put out an update for the drivers and never EVER has any other driver (even from the maker of the chips) ever created one that will work for one installed on this HP unit. so why it wouild not match between the Reg. and the DLL is beyond me.

Anyway, I a lighter note, It did start me searching again and found this on the web: https://www.sitepoint.com/firefox-enable-webgl-blacklisted-graphics-card/ That explained to me that it was actually Firefox that is blocking and Blacklisting my video drivers from running WebGL and Direct2D from working (which is apparently why it works just fine on MS IE but not on Firefox). I kind of figured something like this should have been common knowledge to guys like you and should have know the quick and simple fix explained on this website. after doing the 3 simple and little steps described on this link all is working perfectly......so, problem fixed

Yes, I did. I found the area that said: "WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry:". But didn't tell me where, or who blacklisted it! Or even why. And it doesn't tell me where to go to change something I don't even know where to look for! Also in that area, in Direct2D it told me: "Blocked for your graphics driver version mismatch between registry and DLL.) Well I don't what exactly caused that either since, as I already told you (as a group, and not in these exact words), there are no updates for my video driver. It is the way it came from HP and the way I bought it! HP has never put out an update for the drivers and never EVER has any other driver (even from the maker of the chips) ever created one that will work for one installed on this HP unit. so why it wouild not match between the Reg. and the DLL is beyond me. Anyway, I a lighter note, It did start me searching again and found this on the web: https://www.sitepoint.com/firefox-enable-webgl-blacklisted-graphics-card/ That explained to me that it was actually Firefox that is blocking and Blacklisting my video drivers from running WebGL and Direct2D from working (which is apparently why it works just fine on MS IE but not on Firefox). I kind of figured something like this should have been common knowledge to guys like you and should have know the quick and simple fix explained on this website. after doing the 3 simple and little steps described on this link all is working perfectly......so, problem fixed

Modified by DOMAPOI

cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

Make sure you have the latest drivers for your graphics display card.

You can check the blacklist here:

It is possible to force enabling for some components, but proceed with care if your drivers are very old.

Make sure you have the latest drivers for your graphics display card. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration You can check the blacklist here: *https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers It is possible to force enabling for some components, but proceed with care if your drivers are very old. *https://www.sitepoint.com/firefox-enable-webgl-blacklisted-graphics-card/