Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why I can't use facebook call?

  • 8 replies
  • 1 has this problem
  • 15 views
  • Last reply by Happy112

more options

Hello, I don't know why but I can't use the call option on facebook, but it's worked fine with all types of different browser (egde, chrome ...). I have using 2 browser all the time (chrome for facebook and firefox for normal browsing) but it's so anoying sometime. Please help.

Hello, I don't know why but I can't use the call option on facebook, but it's worked fine with all types of different browser (egde, chrome ...). I have using 2 browser all the time (chrome for facebook and firefox for normal browsing) but it's so anoying sometime. Please help.

All Replies (8)

more options

Hi, please try clearing your cache and cookies and disabling uBlock Origin while trying to use Facebook Call.

Please let us know if this solved your issue or if need further assistance.

more options

Hello, thanks for your fast response. I cleared cache and Facebook cookies, disabled ublock origin but it's still show the message "Connect a camera and a microphone to make a call. If they're already connected, try restarting your browser and closing any other applications that use a camera or microphone." Please help, thanks!

more options

Hi, Would you please do this :

Click the padlock or the little 'i' in a circle to the left of the site's address, then click the '>' icon, then 'More Information' => Permissions

Scroll down to 'Use Your Microphone' and uncheck the 'Use default' box, then choose 'Allow' to make sure the microphone is accessible during your call.

If necessary : do the same with 'Use the Camera'.

more options

Hi, thanks for your fast response. I set my permissions option like that since the problem is happen.

more options

lubdeptrai said

Hi, thanks for your fast response. I set my permissions option like that since the problem is happen.

Bummer  ! (but : good for you though)

You will undoubtedly already have checked the settings for microphone and camera in Options => Privacy & Security, under Permissions ...... (?)

more options

lubdeptrai said

I set my permissions option like that since the problem is happen.

Maybe a rhetorical question, but after you changed those settings, did you then close and restart Firefox  ?

I found this - probably won't be much help either, but thought I'd show you anyway :

https://www.facebook.com/help/232232800134371

more options

I chose the hardcore way, the problem has solved after reinstall windows. Thanks for your support.

more options

lubdeptrai said

I chose the hardcore way, the problem has solved after reinstall windows.

But that's great - well done, you  !!!

Now, would you please mark your own, last post as Chosen Solution  ?

That way others will know (might be very helpful to users with the same problem).