Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New tabs all open my home page

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by jscher2000

more options

I want new tabs (not the first tab when I open the browser) to display a blank window. Now they all open my home page which slows down the process of opening a new tab.

I saw some of the help page of "Show a blank new tab" which says go to Options, New Tab Controls and then click on Show Blank Page.

My Options doesn't give me a choice of "New Tab Controls."

How do I get to the page that will allow me to click on "Show Blank Page."

I do not use Tiles.

All Replies (2)

more options

I find the Tiles very useful and use them daily but I understand that users have different habits. To show a blank page, you have to go into the New Tab options, not Firefox's options. Open a new tab then go to the gear icon on the top right corner of the page and select "Show blank page."

more options

Hi llsavp, if you are getting a different page on a new tab instead of Firefox's built-in new tab page, that usually would be caused by one of your extensions. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Hopefully after disabling whatever is overriding Firefox's built-in new tab page, you can flip that to blank the way the support article describes: Customize your New Tab page to hide or display content.