Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I keep the screen from going to sleep?

  • 2 replies
  • 1 has this problem
  • 36 views
  • Last reply by FredMcD

more options

I have created a Raspberry Pi media screen within Iceweasel, the version of Firefox for Raspberry Pi. However, after 10 minutes, the screen goes black. I have searched the Raspberry Pi help boards with no success. Now I'm hoping the Firefox community can help.

Chosen solution

I think I finally found a solution. Edit the file /etc/xdg/lxsession/LXDE/autostart to add these 3 lines: @xset s noblank @xset s off @xset -dpms

It's been on for 17 minutes! New record!

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

I think I finally found a solution. Edit the file /etc/xdg/lxsession/LXDE/autostart to add these 3 lines: @xset s noblank @xset s off @xset -dpms

It's been on for 17 minutes! New record!

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.