Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am using 40.0.3 and have selected to save my passwords, and have private browsing turned off. The save password function is not working.

  • 6 replies
  • 2 have this problem
  • 2 views
  • Last reply by bplus

more options

Along with the information provided above. 1. Some sites will ask and others do not. 2. It never ask me to update a password if it has changed. 3. The save passwords check box becomes unchecked and I have not made any changes.

All Replies (6)

more options

Please, open Preferences, Navigate to Security and check if "Remember logins for sites" is checked. Also check Sync tab for Password Sync.

more options

Thanks for your post. Both items were already checked.

more options

bplus said

Thanks for your post. Both items were already checked.

In privacy check if "Remember History" is selected under History. Also it can be master password problem, if you have master password you should enter it before using password manager.

more options

Thanks for the suggestion but I checked and that is how mine is setup.

more options

Why don't you update to Firefox 45 which has a new Logins Manager, which new features that weren't in the old Password Manager.

more options

We have a software program that is not compatible with the newer version of the software. We hope that will be resolved later this year but until it is we will be working with this version. Thanks for asking.