Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox will not remember form history.

  • 13 replies
  • 1 has this problem
  • 394 views
  • Last reply by jonblock

more options

I have many times set Firefox to remember history, close Firefox and reopen later only to find it has reverted to using custom settings. The setting to clear history upon closing is unchecked and should not affect. But again, the "Firefox will", resets itself when I close Firefox. Firefox acts this way on both my desktop and my laptop, so should not be a problem with a particular PC.

Chosen solution

To both jscher2000 and cor-el. I have found the problem. I use a program/app called Dashlane to manage my passwords. I have used it for quite a while and this problem is fairly recent. After trying all your suggestions, I once again tried to "refresh" Firefox, only this time I opened Firefox immediately after refreshing, and found the history setting stayed on remember after closing and reopening. Then I enabled Dashlane and the problem reappeared. Disabled and gone again. So it appears that there is a problem between Firefox and Dashlane that popped up after one or the other put out an update. Thanks for all your help. I was getting tired of banging my head and pulling out what is left of my hair.

Read this answer in context 👍 0

All Replies (13)

more options

Hi Jon, when you change the selector under Options > Privacy to "Firefox will: Remember history", it doesn't actually override the specific details you see when you have it set to "Firefox will: Use custom settings for history." You need to modify them manually if they are inconsistent with the default settings.

But... what is the actual culprit here?

Could you make sure "Remember search and form history" is turned on using its individual checkbox?

Assuming you are not clearing history at shutdown, that should be all you need.

more options

"Use custom settings for history" allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".


If you do not keep changes after a restart or otherwise have problems with preferences, see:

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

jscher2000- for the "Firefox will..", I have repeatedly tried to set it to remember. I check all the boxes and uncheck the clear memory on closing. Yet time after time, when I close Firefox and later open it, it goes back to "Firefox will use custom settings for history." I wish there were an apply button so I could force it to keep the settings I want.

more options

cor-el- I tried looking for the "prefs.js.moztmp" mention in the "Read-only or locked preference file" section in the link you posted. But could not find it. Tried using search in Windows Explorer and even opened the Mozilla Firefox folder and checked the "pref" and "js" files. Did not see "prefs.js.moztmp".

more options

Hi Jon, I think you're affirming the same thing I said. Could you check the setting this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste form and pause while the list is filtered

(3) If the browser.formfill.enable preference is bolded and "user set" to false, double-click it to restore the default value of true

If it is already true:

  • Does the feature work during the same session in the same form, and lose data when you close Firefox, or does it never work at all?
more options

I followed your instructions, found the setting was false. Changed it to true, double checked the history settings. Filled a form, then closed Firefox. Reopened again and tried that same form, did not work. Checked the history settings and again they were on "use custom" with remember search and form unchecked. I also double checked the enable true/false and found it was false again.

more options

Okay, I understand some of the symptoms better now. When you turn form history back on, is the old history remembered at that point, or is it starting from scratch?

Lost History Settings

When you were looking in your profile folder, did you see any other files named similarly to prefs.js such as prefs-1.js?

The easiest way to get back to that folder is from the support information page, which you can open as follows:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Firefox sometimes is unable to update the "real" prefs.js file and starts creating a new file, but after startup, Firefox doesn't know to use the newer file and uses the old one. Do you see any indication of that problem such as prefs-number.js files?

Try renaming prefs.js to prefs.txt after you exit out of Firefox (allow 10-15 seconds for Firefox to finish shutting down and release file locks).

If there is an updated prefs-1.js or other numbered file: Rename that file to prefs.js. Firefox then should use those settings are your next startup.

If there is no updated prefs-number.js file: Firefox will create a new prefs.js file with default settings at your next startup to replace the missing file.

Note: if your Windows does not show the .js file extension, to avoid frustrations of fighting with Windows, please turn on display of all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Any difference?

more options

Yes it does remember the form history, until you close Firefox, then the next time you open Firefox, the history is turned off again. I looked for the "prefs.js" folder and there is only the one.

more options

Did renaming prefs.js to prefs.txt and letting Firefox create a new one change anything?

Did you already rule out external software rolling back your changes (e.g., Advanced SystemCare)?

more options

I looked for "prefs.js" in Widows Explorer, which found a pref file for Firefox. This file is a .js file. I renamed it "pref.txt" and restarted Firefox, but same result. I should mention that I also tried the refresh Firefox by downloading and installing, did not help.

more options

Hmm, the Refresh feature creates a new folder on your desktop named Old Firefox Data. Was it that kind of Refresh?

Since you seem to have done everything necessary for Firefox to retain settings between sessions, I would be suspicious of other software potentially interfering. That was mentioned in the second part of this reply: https://support.mozilla.org/questions/1089767#answer-796220

Modified by jscher2000

more options

You can use this button to go to the current Firefox profile folder:

more options

Chosen Solution

To both jscher2000 and cor-el. I have found the problem. I use a program/app called Dashlane to manage my passwords. I have used it for quite a while and this problem is fairly recent. After trying all your suggestions, I once again tried to "refresh" Firefox, only this time I opened Firefox immediately after refreshing, and found the history setting stayed on remember after closing and reopening. Then I enabled Dashlane and the problem reappeared. Disabled and gone again. So it appears that there is a problem between Firefox and Dashlane that popped up after one or the other put out an update. Thanks for all your help. I was getting tired of banging my head and pulling out what is left of my hair.