Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I access a website that I accessed just 10 minutes ago?

  • 3 replies
  • 1 has this problem
  • Last reply by cor-el

more options

I was working in my online class tonight and decided to take a break. I logged out for 10 minutes and when I tried to log back in I keep getting a message that Firefox has "blocked" the site for security reasons. I have used Firefox to access my online classes for the past seven years and now all of a sudden the school's website is a "security risk"! If this problem is not resolved quickly, I have no alternative but to remove Firefox and use another browser.

All Replies (3)

more options

What is the web address? No personal information please.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

more options

Thank you Fred McD. However, to the best of my knowledge nothing changed on my computer in the 10 minutes I had logged out. The website I was accessing is Http://, which takes me to the log in screen to enter my course. I have no added tool bars and the only anti-virus on my computer is Norton which I have used for years. As I said, nothing changed in the 10 minutes when I was able to access my class and then couldn't access it. I still cannot access it this morning.

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window