Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Natao arisiva ity resaka mitohy ity. Mametraha fanontaniana azafady raha mila fanampiana.

Websearch in urlbar search not working after disabling new "unified" bar

  • 3 valiny
  • 1 manana an'ity olana ity
  • 7 views
  • Valiny farany nomen'i Wesley Branton

more options

Hey

As per suggestion in here, I set

  • browser.urlbar.unifiedcomplete = false

to disable the new url bar behavior that includes the "visit..." link.

However, now websearch in the url bar is also entirely turned off, which is **not** what I want. If I type "foo" in the urlbar and press enter, FF autoresolves is as a url, and will visit "foo.com".

Is this intended behavior (i.e. setting unifiedcomplete to false is supposed to disable web search in the url bar) or not? And in any case, how I can I make it work as I would like to: **without** "visit...", but **with** websearch from the url bar?

Hey As per suggestion in here, I set * browser.urlbar.unifiedcomplete = false to disable the new url bar behavior that includes the "visit..." link. However, now websearch in the url bar is also entirely turned off, which is **not** what I want. If I type "foo" in the urlbar and press enter, FF autoresolves is as a url, and will visit "foo.com". Is this intended behavior (i.e. setting unifiedcomplete to false is supposed to disable web search in the url bar) or not? And in any case, how I can I make it work as I would like to: **without** "visit...", but **with** websearch from the url bar?

Vahaolana nofidina

Disabling the unified location bar should not disable your websearching capabilities. It is possible that it was turned off for whatever reason. Please try the following to turn it back on:

  1. Go to about:config
  2. Locate the keyword.enabled boolean
  3. Toggle the value to true

This should turn the websearching feature back on.

Note: You may need to restart Firefox for the changes to take effect.

For more information on the address bar and using it to search the web, please refer these Mozilla support articles:

Hamaky an'ity valiny ity @ sehatra 👍 1

All Replies (3)

more options

Vahaolana Nofidina

Disabling the unified location bar should not disable your websearching capabilities. It is possible that it was turned off for whatever reason. Please try the following to turn it back on:

  1. Go to about:config
  2. Locate the keyword.enabled boolean
  3. Toggle the value to true

This should turn the websearching feature back on.

Note: You may need to restart Firefox for the changes to take effect.

For more information on the address bar and using it to search the web, please refer these Mozilla support articles:

more options

Perfect, that solved it. Thanks!

more options

Glad I could help. Thanks for contacting the Mozilla support team and happy holidays.