Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

Browser now redirects to mobile sites

more options

Recently, Firefox has been directing me to mobile sites not the desktop version of the site. I'm using a laptop (windows 10). If I quarry my user agent it says it's using Android (Mozilla/5.0 (Linux; Android 6.0.1; SM-J700T1 Build/MMB29K; wv)). I can't seem to change this either in the about:config as I tried: general.useragent.override = Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 How can I fix this?

Recently, Firefox has been directing me to mobile sites not the desktop version of the site. I'm using a laptop (windows 10). If I quarry my user agent it says it's using Android (Mozilla/5.0 (Linux; Android 6.0.1; SM-J700T1 Build/MMB29K; wv)). I can't seem to change this either in the about:config as I tried: general.useragent.override = Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 How can I fix this?

All Replies (7)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

more options

I've done all of the above with no success.

more options

Your useragent seems to have been reported correctly to this site. Do you use any privacy-oriented add-ons that could be modifying it on a site-by-site basis? How about external software or a proxy/Private VPN service?

more options

No, no add ons that are recent, and I tried starting in safe mode with no luck. No external software or vpn service either. I am tethered via my android phone as internet service, but I've always done that with out having this issue before.

more options

frustrated66 said

I am tethered via my android phone as internet service, but I've always done that with out having this issue before.

I agree. Tethering should not modify your actual requests if that Android feature is operating normally.

Does the problem affect both HTTPS and HTTP connections, or only HTTP? For comparison:

more options

It appears to only effect http sites

more options

Perhaps there is some software on the Android device that is proxying the connection. If you check bandwidth usage, does anything seem unusually high that could be a "man in the middle"?