Showing questions tagged: Show all questions

Lags whenever I tried to use Web Developer Tools

Firefox slows down when I use web developer tools, I use this whenever I try to save an image on Instagram or other sites that I go to just to save an image or look for t… (read more)

Firefox slows down when I use web developer tools, I use this whenever I try to save an image on Instagram or other sites that I go to just to save an image or look for the video using the web tools.

Is there a way to fix this issue it lags the browser or it freezes for a second.

Asked by mark_vincent_16 5 hours ago

Firefox Debian significantly slower page loads than Chromium Debian

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling … (read more)

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling with slowness in Firefox, page loads take easily 15 seconds whereas loading the exact same page in another window at the same time with Chromium Debian build has near instantaneous load times. I've tried the following troubleshooting steps: - Created a new firefox profile - Tried "Troubleshooting Mode" in Firefox - Disabled ipv6 in firefox about:config and in Debian - Tried different DNS servers - Tried different non-debian specific builds of Firefox - Tried Firefox Beta and Firefox Nightly for Debian

None of these steps made any difference, and Chromium has continued to be significantly faster. Am really stuck here and would love to get to the bottom of this as Firefox is the only browser that works with a HiDPI display in Sway without blurryness. Happy to provide any and all diagnostics and reports that are needed. Thanks in advance!

EDIT: It seems to be some kind of networking issue, using a VPN solves it. But still doesn't explain why Chromium would behave differently.

Asked by Samuel (+Uni) 7 hours ago

Canvas two-factor authentificatiton

Canvas is working on all other browsers normally, but when I try to login on firefox an error 403 message shows up at the two factor authentification step. I allowed popu… (read more)

Canvas is working on all other browsers normally, but when I try to login on firefox an error 403 message shows up at the two factor authentification step. I allowed popups already in this browser so that is not the issue.

Asked by Elise Clancy 8 hours ago

Firefox extremely slow to load pages or connect to Web sites after startup - Follow-Up

I see my original question is now archived at https://support.mozilla.org/en-US/questions/1380948#question-reply I never closed it because I didn't know if my last proc… (read more)

I see my original question is now archived at https://support.mozilla.org/en-US/questions/1380948#question-reply I never closed it because I didn't know if my last process could really fix the issue. It didn't, not always. Over the years, there have been times when the issue would still pop up, but not as often as before (2022 and earlier).

I have a feeling that during an issue, FF is having difficulty setting up shop after starting up. Consequently, it is spending more time before it could become prepared to connect to the Net. I've come up with another "solution," which is deleting (or moving out) xulstore.json in the profile folder after exiting or before starting FF. You can create a batch command or script to execute the process.

So far, FF is connecting immediately after startup.

Asked by mobilesuit 6 days ago

Last reply by mobilesuit 9 hours ago

WebGL creation failed after reinstalling lbgl1* libegl*

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02… (read more)

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02).

I used to play this game named narrow.one, which before I reinstalled the mentioned libraries, was working fine except for crashing a few times. I thought these libraries were causing some issue, so I tried reinstalling them.

I reinstalled the libraries using: `sudo apt install --reinstall --fix-missing libgl1* libegl*`

After installation, I start getting that error. So, I tried reinstalling firefox (using the same command), and then restarting the laptop - but of no use. Chrome seems to be running WebGL, including the game.

In firefox, on the https://get.webgl.org/ page, I see Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

After that, I also tried reinstalling `libopengl0` and `libglu1-mesa` and `intel-microcode`, but of no use. Running although, `sudo intel_gpu_top` and then chrome, it seems that the GPU is in use by chrome as well.

I then go to about:support. It shows me the images I have attached. Reading the logs, there several `blocklisted` values in `Decision Log` section. I suspect that's the cause of this issue, but then I don't know how can I un-blocklist the blocklisted things, and even after that, why does Chrome runs webgl if these are blocklisted?

Running `glxinfo -B`, I get the following: `name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer):

   Vendor: Intel (0x8086)
   Device: Mesa Intel(R) HD Graphics 620 (KBL GT2) (0x5916)
   Version: 23.2.1
   Accelerated: yes
   Video memory: 7697MB
   Unified memory: yes
   Preferred profile: core (0x1)
   Max core profile version: 4.6
   Max compat profile version: 4.6
   Max GLES1 profile version: 1.1
   Max GLES[23] profile version: 3.2

OpenGL vendor string: Intel OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2) OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-1ubuntu3.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20`

I do not know much about OpenGL, but reading the above stuff, I suppose my GPU is in use and also has a compatible driver (although I am not sure).

Also, running `glxdemo`, `glxheads`, and `glxgears` seems to be rendering stuff.

Should I reinstall firefox after purging it first? Please help.

Thanks!

Asked by Lakshay Rohila 20 hours ago

Last reply by Lakshay Rohila 15 hours ago

Since the last two updates, Firefox enhanced tracking is out of control

FF loads so slowly and blocks so many sites that I had to disable enhanced tracking to get to mozilla.org. It can take up to 30 seconds for a site to load if I don't dis… (read more)

FF loads so slowly and blocks so many sites that I had to disable enhanced tracking to get to mozilla.org. It can take up to 30 seconds for a site to load if I don't disable enhanced tracking, and even then, some won't load and will time out. I have 7 pinned items that load when FF opens, and it can take up to 5 minutes for all of those to load. Even on some sites where I have enhanced tracking turned off, I have to close the initial block page to get the site to load. Sometimes I have to stop the download and refresh to get the page to load. It is blocking sites that I've used for years with no problems.

What I have done: Troubleshoot mode - loaded a bit faster, but still had problems with some bookmarked pages I've used for years with no problems. It seems to hate all Google Pages, especially Google News Turned off Deceptive Content and Dangerous Software protection Turned off HTTPS only mode Turned off Block Popup Windows

Asked by D A 20 hours ago

Last reply by D A 16 hours ago

latest Firefox (125) locks up when typing to address bar in new tab while VPN is active

Since the update to version 125 Firefox on Windows 11 (all updates installed), when I open a new tab and start typing to the address bar WHILE the VPN to the office is ac… (read more)

Since the update to version 125 Firefox on Windows 11 (all updates installed), when I open a new tab and start typing to the address bar WHILE the VPN to the office is active, Firefox locks up and can not be used anymore.

In taskmanager, there is no spike in memory or cpu usage visible. All I can do at this point is to kill Firefox via taskmanager.

I can enter anything in the address bar of an already open tab with an other website open, I can open new tab from the bookmarks, but I can not open a new tab and start typing in the address bar while the VPN is active.

Once I disable the VPN to the office, everything goes back to normal.

I never had this issue on a previous version of Firefox.

Any ideas whats causing this?

Asked by maniac 23 hours ago

Last reply by maniac 17 hours ago

Pages won't load after update

After the latest update to 125.0.2 (64-bit) the browser works fine for a few minutes and then pages won't load. It starts working again after a restart [ for a few min… (read more)

After the latest update to 125.0.2 (64-bit) the browser works fine for a few minutes and then pages won't load. It starts working again after a restart [ for a few minutes]. I have cleared the cache & data. Chrome works ok.

Asked by markp13a 19 hours ago

firefox does not respond to mouse clicks after update on MacOS

After Firefox updates itself, the restarted browser session is unresponsive to mouse clicks - can't follow links, can't respond to UI dialog boxes, the browser is unusabl… (read more)

After Firefox updates itself, the restarted browser session is unresponsive to mouse clicks - can't follow links, can't respond to UI dialog boxes, the browser is unusable for practical purposes. It's fixed after another manual restart. This unfortunately breaks all the streamlining Firefox has done to restore the session after an update, because none of that stuff works the same after a manual quit and restart. This is happening on MacOS, and it happens across multiple computers.

Asked by uqrcobgezp 1 day ago

Secure connection failed - SEC_ERROR_LIBRARY_FAILURE

I'm running Firefox 102.4.0 ESR (32 bit) on a Win-7 (32 bit) PC. It works fine. I visit a LOT of websites, it works fine. Until just now. I'm trying to bring up namec… (read more)

I'm running Firefox 102.4.0 ESR (32 bit) on a Win-7 (32 bit) PC.

It works fine. I visit a LOT of websites, it works fine.

Until just now. I'm trying to bring up namecheap.com (a domain registrar) and I'm getting this message:

Secure Connection Failed An error occurred during a connection to www.namecheap.com. security library failure. Error code: SEC_ERROR_LIBRARY_FAILURE

I'm not given any option to alter any FF settings or to otherwise create an exception to "trust" this site to be able to access it.

I've read where changing security.pki.crlite_mode (currently 3) to something else (like 0) and I've tried that, and unless I have to close and restart FF for that to take effect (which I have not done) then that setting doesn't fix the issue.

What exactly is going on here? Why is only THAT SITE giving me problems?

Asked by junk26 1 day ago

Firefox hangs when adding or removing monitors

This is a problem I've had for a while and thought it would be eventually fixed, but no luck so far. TL;DR - Almost every time I add or remove monitors my Firefox hangs.… (read more)

This is a problem I've had for a while and thought it would be eventually fixed, but no luck so far.

TL;DR - Almost every time I add or remove monitors my Firefox hangs.

More context: I use a PC laptop and constantly switch from using just the laptop screen to using just a set of two monitors, with the laptop closed. What I do is, I lock my machine, with Firefox open on the laptop screen, connect the monitors, close the laptop lid, and unlock the machine. That causes Firefox to hang and I'm forced to kill it and open it back again. It usually reopens all tabs without a problem but the issue is pretty annoying.

My current version is 125.0.2 and I'm sure the problem dates from several versions

Asked by Victor 1 day ago

Cursor speed is insanely slow only in Firefox

Out of nowhere, my cursor speed in Firefox has slowed to a truly unusable crawl. I refreshed a page and it was suddenly inching along at worse than a snail's pace. I'm us… (read more)

Out of nowhere, my cursor speed in Firefox has slowed to a truly unusable crawl. I refreshed a page and it was suddenly inching along at worse than a snail's pace. I'm using a USB trackball mouse. This is only affecting Firefox; no other applications have this issue. Using Windows 10.

Here's what I've tried so far:

  • Restart Firefox
  • Started Firefox in Safe Mode
  • Restart computer
  • Create a new profile in Firefox
  • Check my mouse's firmware
  • Try a different mouse

There was another question about this years ago, but the accepted answer about accidentally enabling a Windows accessibility feature doesn't say which feature it is or how to disable it (if that's indeed the case). The link also seems to redirect to a generic accessibility page.

Asked by Greyson Niedbalski 1 day ago

Serious Problem: Firefox Only Opens In "Safe Mode"???

Greetings everyone, I've had this problem for a while and I don't know what to do. I had a problem where Firefox kept crashing before it had finished loading up all of… (read more)

Greetings everyone,

I've had this problem for a while and I don't know what to do.

I had a problem where Firefox kept crashing before it had finished loading up all of my former tabs and windows and so I was given the option of opening Firefox in "Safe mode" which I did, but now Firefox only starts in "Safe mode"...

I'm running the most up to date version of Firefox.

Thank you for any help!

Asked by Helpless_Quest 3 weeks ago

Last reply by Helpless_Quest 1 day ago

Firefox Buttons dont work - Linux

When I run firefox on WSL2, buttons dont work on any pop up windows. Foe example when installing a firefox extention - it will download and pop up a small window at the t… (read more)

When I run firefox on WSL2, buttons dont work on any pop up windows. Foe example when installing a firefox extention - it will download and pop up a small window at the top right to add the extentionto firefox. The buttons dont work. Another example is when opening up the firefox menu bar (hamburger bar) - it will pup up a small window to allow to open up settings, go to add ons, open bookmarks or history. The buttons dont work. Last example is the pop up window for this Ash your question page for firefox support - When clicking "Which topic best described your question - it will pop up a small window to select what type of question Im gonna ask. The buttons dont work.

I dont know how to fix this. I restarted, deleted my firefox profile, started of safe mode, nothing worked. How do I solve this issue?

Asked by Ian Teves 2 days ago

The application was unable to start correctly (0xc0000022)

Even after numerous Uninstalls and a Reinstalls I keep getting this error notice when trying to open Firefox... The application was unable to start correctly (0xc0000022… (read more)

Even after numerous Uninstalls and a Reinstalls I keep getting this error notice when trying to open Firefox...

The application was unable to start correctly (0xc0000022)

Asked by peter carrs 2 days ago

Microphone very quiet when Firefox uses it on Mac

Running Firefox 125.0.1 on MacOS 14.2.1, all audio input is very quiet for all applications, not just Firefox. Experiments I ran: people can barely hear me in Google… (read more)

Running Firefox 125.0.1 on MacOS 14.2.1, all audio input is very quiet for all applications, not just Firefox.

Experiments I ran:

  • people can barely hear me in Google Meets
  • microphone works great in Quicktime (making a recording) when Firefox is running but not receiving audio input
  • microphone is very quiet in Quicktime when running a Google Meet in Firefox
  • microphone is very quiet in Quicktime when running a discord voice channel in Firefox
  • microphone works great in Quicktime when running Google Meet in Chrome

This started maybe ~3 months ago for me. I'd love to see a fix, since Firefox is my favorite browser in most other ways - otherwise I'll have to give up and switch to Chrome at long last :'(

Asked by m.w.loncaric 3 days ago

Can't close Firefox with multi pages opened through right clicking the taskbar.

Firefox Version: 124.0.2 (64 bit) Windows Version: Windows 10 LTSC 2019 (Version 1809) When I right click the taskbar and press close Firefox, here comes the interface j… (read more)

Firefox Version: 124.0.2 (64 bit) Windows Version: Windows 10 LTSC 2019 (Version 1809)

When I right click the taskbar and press close Firefox, here comes the interface just as the screenshot uploaded. The blue close button doesn't response no matter how I click it and the Firefox's taskbar is flashing yellow. This bug only occurs on the first window of Firefox and only when user right click the taskbar.

It has been a long time for me wishing that some updates would be released soon to fix this issue, while noting happens. Or this bug is only for me?

Asked by Feeling Unreal 1 week ago

Last reply by Feeling Unreal 4 days ago

Can't open firefox settings

When I open firefox in ubuntu linux. (WSLg) Fresh install. I can't go to settings in firefox. Steps: press the hamburger menu, press settings, nothing happens. OS: Ubunt… (read more)

When I open firefox in ubuntu linux. (WSLg) Fresh install. I can't go to settings in firefox. Steps: press the hamburger menu, press settings, nothing happens.

OS: Ubuntu 22.04.4 LTS on Windows 10 x86_64 Kernel: 5.15.146.1-microsoft-standard-WSL2 Shell: bash 5.1.16

Asked by Ceel Beckers 5 days ago

Last reply by Ceel Beckers 4 days ago