Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After the most recent FF update, FF 3.6.6 will not load, citing the error message: "XULRunner / Error: Platform version '1.9.2.3' is not compatible with minVersion>=1.9.2.6 / maxVersion". Tried updating XULRunner with no luck. Downloaded fresh copy and

more options

After the most recent FF update, FF 3.6.6 will not load, citing the error message: "XULRunner / Error: Platform version '1.9.2.3' is not compatible with minVersion>=1.9.2.6 / maxVersion". Tried updating XULRunner with no luck. Downloaded fresh copy and installed. Still no luck.


This happened

Every time Firefox opened

FF updated to 3.6.6

User Agent

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.4; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

All Replies (3)

more options

Similar problem with a twist. Firefox stopped working under one profile but worked under others. I did a clean install of Firefox 3.6.8 (Windows XP SP3). I tried it from both profiles, but it still only works under one of the profiles. The error message complains that 1.9.2.3 is not compatible with the required 1.9.2.8.

more options

Do a clean reinstall and download a fresh Firefox copy from http://www.mozilla.com/firefox/all.html and save the file to the desktop. Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer. It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

You can skip the step to create a new profile, that is not necessary for this issue. ..... See http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

more options

On netbook Lenovo S10e, XP SP3, FFx 3.6.8 cannot start. Message XULrunner error 1.9.2.6 not compatible with 1.9.2.8 After complete de-install (including remaining FFx folder) and clean re-install problem persists.