Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cant open any google site in Firefox

  • 14 replies
  • 1 has this problem
  • 4110 views
  • Last reply by Mamun

more options

Hi Since yesterday 2-Feb-21, i cant open any Google sites (Search engine, Photos, Drive, mails etc)! I have no idea how this happened. showing below message once i enter Google.com

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to www.google.com because this website requires a secure connection.

What can you do about it?

www.google.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem.

Someone could be trying to impersonate the site and you should not continue.

Websites prove their identity via certificates. Firefox does not trust www.google.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates.

Error code: SEC_ERROR_UNKNOWN_ISSUER

View Certificate

Hi Since yesterday 2-Feb-21, i cant open any Google sites (Search engine, Photos, Drive, mails etc)! I have no idea how this happened. showing below message once i enter Google.com ************************* Did Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to www.google.com because this website requires a secure connection. What can you do about it? www.google.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. The issue is most likely with the website, and there is nothing you can do to resolve it. If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem. Someone could be trying to impersonate the site and you should not continue. Websites prove their identity via certificates. Firefox does not trust www.google.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates. Error code: SEC_ERROR_UNKNOWN_ISSUER View Certificate

Chosen solution

I don't think you can Accept and Continue on Google sites due to HSTS.

If you click View Certificate, does the Issuer Name section list

  • Organization: Google Trust Services
  • Common Name: GTS CA 1O1

Or does it list something else?

Several users have reported theirs switching to a fake Digicert-issued certificate, which seems to be associated with a proxy. As a test, you can change your connection setting:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Read this answer in context 👍 2

All Replies (14)

more options

What virus software are you running and can you turn it off and try again? What version of Firefox? Are you running Windows, Mac, or Linux? Can you post a full browser screenshot showing the error?

more options

Hi jonzn4SUSE

NO antivurus Version 85 Windows 10 screenshot attached

more options

You can click on advanced and there should be some option to accept.

more options
more options

4AM here in the US on the East Coast. Going to sleep... ;-))

more options

see screeshot of mine. there is no button for accept and continue'

more options

Chosen Solution

I don't think you can Accept and Continue on Google sites due to HSTS.

If you click View Certificate, does the Issuer Name section list

  • Organization: Google Trust Services
  • Common Name: GTS CA 1O1

Or does it list something else?

Several users have reported theirs switching to a fake Digicert-issued certificate, which seems to be associated with a proxy. As a test, you can change your connection setting:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

more options

Yeah, we are waiting to View Certificate!

more options

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Certificate attached...

more options

So are you able to accept and get to the site?

more options

hi i got to solve the issue, From jscher2000 , as below-- The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

thank you all for kind support!