Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fix Firefox Does Not Save, Store or Remember Password On Some Sites Permanently for Always Auto-Complete

  • 5 replies
  • 141 have this problem
  • 1801 views
  • Last reply by aremkay

more options

Firefox web browser has built-in password manager that able to save, store or remember user name, ID and password credentials to auto-fill and auto-complete the login or logon text fields on next and subsequent visits. However, on some sites, Firefox, including both Firefox version 2 and Firefox 3, fails or does not prompt and offer user a choice to remember and save the password, and hence won’t store the password for AutoComplete or AutoFill.

All Replies (5)

more options

Some web sites, including many banks and a few other sites, tell browsers not to remember passwords for visitors by using autocomplete="off". Firefox respects the web page author's coding in pages like that.

This bookmarklet makes the browser ignore autocomplete="off" temporarily, allowing you to save passwords even on sites that use autocomplete="off".

Remember Password bookmarklet:
https://www.squarefree.com/bookmarklets/forms.html#remember_password

Or, you can use the Saved Passwords Editor extension for web sites where Firefox doesn't offer to save the Username /Password.
https://addons.mozilla.org/en-US/firefox/addon/60265/

more options

thanks 'the-edmeister'. Your response is appreciated, and your fixes are better than the manual hack that I have been using up until now. The only other point I would make is your statement 'Firefox respects the web page author's coding in pages like that' is not entirely true. Firefox allows you to block pop up windows, as well as disabling many other javascript actions such as disabling context menu's, status bar messages etc. This is in direct contradiction to the web page author's coding. My point is that it would be nice if this was one of the hundreds of config options that allowed the flexibility that I've come to expect from firefox.

I appreciate your sentiment however, and thanks for your answer.

more options

Many websites attempt to prevent browser password retention by disabling autocomplete. To defeat this and enable user ID and password Auto Complete for these sites, edit

C:\Program Files\Mozilla Firefox\components\nsLoginManager.js so that _isAutoCompleteDisabled returns false, eg:

  /*
    * _isAutoCompleteDisabled
    *
    * Returns true if the page requests autocomplete be disabled for the
    * specified form input. (This is what our edit defeats - ral)
    */
   _isAutocompleteDisabled :  function (element) {

// if (element && element.hasAttribute("autocomplete") &&

// element.getAttribute("autocomplete").toLowerCase() == "off")

// return true;

       return false;
   }

In Firefox 4 the file is in omni.jar, so you need to extract, edit and rejar.

If you installed Firefox elsewhere, you may need to search for the file.

Use any plaintext editor.

There are more reasons than one to make a backup copy.

Other schemes that prevent user id and password retention are addressed elsewhere [pending].

(Original source unknown)

more options

What about FF 4? As far as I can tell, there is no nsLoginManager.js file. So what do FF4 users do?

more options

Here is more info on the problem of FF4 on a Mac running 10.6.7 failing to auto login :

I check my weather on wunderground.com, a site that uses a permanent cookie to facilitate auto login. I have used this site for years, and auto login works fine when I use Safari set to private browsing. But I must login each time using FF4. I have tested out the following on FF4: I've tried with private browsing turned on and off. I have used exceptions in the preferences, entering www.wunderground.com in the allow always setting. I have verified that the wunderground cookie IS stored in the browser. But these effort do not work. I still must always login each time when I browse to this site with FF4. So I immediately switch back to Safari, and auto login works. I would prefer to use FF4, because Safari requires turning on private browsing each time I launch it. FF4 on the other hand sets this feature permanently. But I cannot use FF4 until this problem is fixed.

Modified by aremkay