Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What's an application/octet-stream and why does Firefox want me to open or save it?

  • 9 replies
  • 700 have this problem
  • Last reply by mtfrancis

more options

I had just updated Firefox, I opened up Google, googled something and entered into the first webpage that came up- or tried to. What I got was a box from Firefox saying:

You have chosen to open the file

(URL of the webpage)

which is an application/octet-stream What would you like to do with this file?

          []Open With...   [Browse] (as a button)
          []Save As...
                           [Ok]              [Cancel]

This happens with every webpage that isn't from Google or Mozilla. If I hit Cancel, the webpage won't load, if I select Save As, no program I have can open it and if I select Open With, same situation. So... what gives? What's an application/octet-stream? Why won't Firefox open webpages apart from Google or Mozilla pages (my previous version of Firefox worked fine)?

Modified by trekkie

All Replies (9)

more options

application/octet-stream is a generic content (MIME) type. Firefox will always show the "open with" download dialog if a server sends a file with such a MIME type. You shouldn't get that MIME type with every web page that you open. You may have security software (firewall) that has changed the original content type.

A possible cause is security software (firewall) that blocks or restricts Firefox without informing you about that, possibly after detecting changes (update) to the Firefox program.
Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process.

See Server Not Found - Troubleshoot connection problems and Configure firewalls so that Firefox can access the Internet and

more options

That's because the zealots at firefox like to harass the end users.

If you instead use Internet Explorer, you can just check that it should always save the file instead of annoying the user like Firefox wants to do (they refuse to fix this problem)

more options

The developers consider it a security issue.

more options

The problem seems to have gone away by itself. Thing is, I still don't know what caused it in the first place (cor-el, nothing I did to my firewall fixed the problem), so it could pop up again at any time.

more options

I am getting the message on the Royal Caribbean Website. This is occurring on the page where the 360 Tour of the Stateroom is located.

No suitable plugins were found.

      Unknown Plugin (application/octet-stream) 

This only happens with Firefox not IE or Safari. I'm getting this error every time I go to this page. I have upgraded Firefox several times since I first noticed this error with no changes.

more options

Try disable Adblock Plus

more options

Silly games to be played Save the file. Go to the FireFox pulldown menu top left corner, choose Downloads. Select the file that you saved and and click on Launch (top left). Often that will make the document open in the original format.

If that doesn't work, try this. Click on Save, go to the saved file on your hard drive, select it and right click on Rename and add whatever extension you need. For example when Firefox stops what I know is an Excel 2007 file from a student, I just rename it like this: Joestats.xlsx. Then the renamed file will open normally in Excel 2007 just like Joe sent it to me.

more options

Here's how I get around the mess with this application/octet-stream files. I save as WinRar when that comes up at download. And to open once DL'ed I right click open then it opens all apps that you have on file. Pick WinRar and click open to then extract to were you want files to be held.. hope it helped..

more options

I tried opening a unknown file that was described as an application.octet-stream with OpenOffice and it worked just fine. Hope this helps others.