X
Tap here to go to the mobile version of the site.

Support Forum

firefox 3.6.3 Google search stopped working on googles web site

Posted

Firefox Google search not working? firefox 3.6.3 Google search stopped working. When I hit the search button nothing happens. The query suggestions in the search box also stopped working. If I hit the feeling lucky button it works and when I hit the back button and go back the search button will then work but the query suggestions still won't. If I go to advanced search I can search. Tried turning off add-ons and safe mode, no luck. Any suggestions or help would be appreciated

URL of affected sites

http://www.google.com/

Firefox Google search not working? firefox 3.6.3 Google search stopped working. When I hit the search button nothing happens. The query suggestions in the search box also stopped working. If I hit the feeling lucky button it works and when I hit the back button and go back the search button will then work but the query suggestions still won't. If I go to advanced search I can search. Tried turning off add-ons and safe mode, no luck. Any suggestions or help would be appreciated == URL of affected sites == http://www.google.com/

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.0 r45
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • Google Updater pluginhttp://pack.google.com/
  • Version 0.9.15, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.15, copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
AVG Safe Search
9.0.0.825
false
{3f963a5b-e555-4543-90e2-c3908898db71}
AVG Security Toolbar
4.002.023.004
false
avg@igeared
fireform
0.7
true
fireform@mozilla.org
Java Console
6.0.13
true
Java Console
6.0.15
true
Java Console
6.0.17
true
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Java Console
6.0.18
true
Java Console
6.0.20
true
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
1
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
google.com
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
keyword.URL
http://us.yhs.search.yahoo.com/avg/search?fr=yhs-avg&type=yahoo_avg_hs2-tb-web_us&p=
network.cookie.prefsMigrated
true
places.last_vacuum
1274036657
print.print_printer
Canon MX310 series Printer
print.printer_Canon_MX310_series_Printer.print_bgcolor
false
print.printer_Canon_MX310_series_Printer.print_bgimages
false
print.printer_Canon_MX310_series_Printer.print_command
print.printer_Canon_MX310_series_Printer.print_downloadfonts
false
print.printer_Canon_MX310_series_Printer.print_edge_bottom
0
print.printer_Canon_MX310_series_Printer.print_edge_left
0
print.printer_Canon_MX310_series_Printer.print_edge_right
0
print.printer_Canon_MX310_series_Printer.print_edge_top
0
print.printer_Canon_MX310_series_Printer.print_evenpages
true
print.printer_Canon_MX310_series_Printer.print_footercenter
print.printer_Canon_MX310_series_Printer.print_footerleft
&PT
print.printer_Canon_MX310_series_Printer.print_footerright
&D
print.printer_Canon_MX310_series_Printer.print_headercenter
print.printer_Canon_MX310_series_Printer.print_headerleft
&T
print.printer_Canon_MX310_series_Printer.print_headerright
&U
print.printer_Canon_MX310_series_Printer.print_in_color
true
print.printer_Canon_MX310_series_Printer.print_margin_bottom
0.5
print.printer_Canon_MX310_series_Printer.print_margin_left
0.5
print.printer_Canon_MX310_series_Printer.print_margin_right
0.5
print.printer_Canon_MX310_series_Printer.print_margin_top
0.5
print.printer_Canon_MX310_series_Printer.print_oddpages
true
print.printer_Canon_MX310_series_Printer.print_orientation
0
print.printer_Canon_MX310_series_Printer.print_pagedelay
500
print.printer_Canon_MX310_series_Printer.print_paper_data
1
print.printer_Canon_MX310_series_Printer.print_paper_height
11.00
print.printer_Canon_MX310_series_Printer.print_paper_size_type
0
print.printer_Canon_MX310_series_Printer.print_paper_size_unit
0
print.printer_Canon_MX310_series_Printer.print_paper_width
8.50
print.printer_Canon_MX310_series_Printer.print_reversed
false
print.printer_Canon_MX310_series_Printer.print_scaling
1.00
print.printer_Canon_MX310_series_Printer.print_shrink_to_fit
true
print.printer_Canon_MX310_series_Printer.print_to_file
false
print.printer_Canon_MX310_series_Printer.print_unwriteable_margin_bottom
0
print.printer_Canon_MX310_series_Printer.print_unwriteable_margin_left
0
print.printer_Canon_MX310_series_Printer.print_unwriteable_margin_right
0
print.printer_Canon_MX310_series_Printer.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

Question owner

3.6.6 on XP

3.6.6 on XP

Question owner

same problem version 3.6.6 on XP

same problem version 3.6.6 on XP

Question owner

Want to be more clear. Got the same problem with 3.6.6 on XP. When click on search, the Google search result didn't update (the google search page didn't update). BUT the url bar on top did have the Google URL updated with the new search term. Something like http://www.google.com/#hl=en&q=firefox+3.6+problem+with+google+search+button&aq=f&aqi=&aql=&oq=&gs_rfai=&fp=dd2d1939af06a5a So the URL is changed when I click the Google SEARCH button on the page. Just the page not changed nor updated.

And when I click "Reload current Page", then the page is reloaded with the new google search result.

Want to be more clear. Got the same problem with 3.6.6 on XP. When click on search, the Google search result didn't update (the google search page didn't update). BUT the url bar on top did have the Google URL updated with the new search term. Something like http://www.google.com/#hl=en&q=firefox+3.6+problem+with+google+search+button&aq=f&aqi=&aql=&oq=&gs_rfai=&fp=dd2d1939af06a5a So the URL is changed when I click the Google SEARCH button on the page. Just the page not changed nor updated. And when I click "Reload current Page", then the page is reloaded with the new google search result.

Question owner

I have the same problem, anybody know how to fix this?

I have the same problem, anybody know how to fix this?

Question owner

I don't know why it says I have 3.6.3, I have 3.6.6! And, I have XP not Vista! I don't know how that happened.....this is the first time I've posted about Firefox.

Bing works fine it's just with Google.

Mine's the same as the above post;

"Want to be more clear. Got the same problem with 3.6.6 on XP. When click on search, the Google search result didn't update (the google search page didn't update). BUT the url bar on top did have the Google URL updated with the new search term."

"So the URL is changed when I click the Google SEARCH button on the page. Just the page not changed nor updated.

And when I click "Reload current Page", then the page is reloaded with the new google search result."

Thanks

I don't know why it says I have 3.6.3, I have 3.6.6! And, I have XP not Vista! I don't know how that happened.....this is the first time I've posted about Firefox. Bing works fine it's just with Google. Mine's the same as the above post; "Want to be more clear. Got the same problem with 3.6.6 on XP. When click on search, the Google search result didn't update (the google search page didn't update). BUT the url bar on top did have the Google URL updated with the new search term." "So the URL is changed when I click the Google SEARCH button on the page. Just the page not changed nor updated. And when I click "Reload current Page", then the page is reloaded with the new google search result." Thanks

Question owner

Sorry, A different Craig!

We have two Craigs with the same problems!

Sorry, A different Craig! We have two Craigs with the same problems!

Question owner

I've got a similar problem on Firefox 3.6.6 on Windows 7 Ultimate 64. The top google page works fine, but from a page with earch results, clicking search or hitting Enter changes the URL in the address bar, but otherwise does nothing.

If I search for "HelpMe" from the main google page, the search works, and the URL becomes: http://www.google.com/webhp?hl=en#hl=en&source=hp&q=helpme&aq=f&aqi=g10&aql=&oq=&gs_rfai=C3poa-dIuTO_dMqigzASW1LX_CwAAAKoEBU_Q8PcX&fp=36ec6be010d257f

But if I try the same search from the results page, I get no effect, and this URL: http://www.google.com/webhp?hl=en#hl=en&q=helpme&aq=f&aqi=&aql=&oq=&gs_rfai=&fp=dd2d1939af06a5a

I hope to hear about a fix for this soon.

I've got a similar problem on Firefox 3.6.6 on Windows 7 Ultimate 64. The top google page works fine, but from a page with earch results, clicking search or hitting Enter changes the URL in the address bar, but otherwise does nothing. If I search for "HelpMe" from the main google page, the search works, and the URL becomes: http://www.google.com/webhp?hl=en#hl=en&source=hp&q=helpme&aq=f&aqi=g10&aql=&oq=&gs_rfai=C3poa-dIuTO_dMqigzASW1LX_CwAAAKoEBU_Q8PcX&fp=36ec6be010d257f But if I try the same search from the results page, I get no effect, and this URL: http://www.google.com/webhp?hl=en#hl=en&q=helpme&aq=f&aqi=&aql=&oq=&gs_rfai=&fp=dd2d1939af06a5a I hope to hear about a fix for this soon.

Question owner

Interestingly, both links work from within this forum...

Interestingly, both links work from within this forum...

Question owner

I'm on Windows 7 Professional 64 bit and I'm experiencing the same problem.

The initial search will work fine. If I type www.google.com in the URL and then my search, it works normally.

When I try to start a new search, then nothing happens. The URL actually changes, but nothing changes on the page. If I hit the REFRESH button, the new search results do appear however. Chrome seems to work fine. I wonder if Google did something to their search that affected Firefox.

I'm on Windows 7 Professional 64 bit and I'm experiencing the same problem. The initial search will work fine. If I type www.google.com in the URL and then my search, it works normally. When I try to start a new search, then nothing happens. The URL actually changes, but nothing changes on the page. If I hit the REFRESH button, the new search results do appear however. Chrome seems to work fine. I wonder if Google did something to their search that affected Firefox.

Question owner

Okay, I just found the culprit in my case. It turned out to be the QuickTime Plugin 7.6.6, which I had recently updated from 7.4.

To disable this, seelct Add-ons from the Tools menu and go to the Plugins tab. Find your Quick-Time Plugin and click the disable button. Restart firefox and see if this resolves your issue. If it does, you will have to make the same choice I am faced with: Deal with the Google issue, leave the plug-in disabled except when it's needed, or roll back to an earlier version of QuickTime. This last option is what I'll try. You can download older versions of QuickTime from apple.com, right here.

QuickTime 7.4 for Windows, which is on the third page of the link above, had been working fine for me, so that will probably do the trick. I can't say whether or not there is a newer version than 7.4 that won't cause the issue.

Good luck, all.

Okay, I just found the culprit in my case. It turned out to be the QuickTime Plugin 7.6.6, which I had recently updated from 7.4. To disable this, seelct Add-ons from the Tools menu and go to the Plugins tab. Find your Quick-Time Plugin and click the disable button. Restart firefox and see if this resolves your issue. If it does, you will have to make the same choice I am faced with: Deal with the Google issue, leave the plug-in disabled except when it's needed, or roll back to an earlier version of QuickTime. This last option is what I'll try. You can download older versions of QuickTime from apple.com, right [http://support.apple.com/downloads/#quicktime here]. QuickTime 7.4 for Windows, which is on the third page of the link above, had been working fine for me, so that will probably do the trick. I can't say whether or not there is a newer version than 7.4 that won't cause the issue. Good luck, all.

Question owner

Same problem in vista ultimate firefox 3.6.6

Same problem in vista ultimate firefox 3.6.6

Question owner

Well, I got the same problem with QuickTime 7.5.5, so I ended up rolling all the way back to QuickTime 7.4 and the issue still occured as long as the add-on was enabled. I guess I'll be using Firefox without the QuickTime plugin enabled then.

Oh well. I least I can make it work. Disable the QuickTime plugiin and restart Firefox. If this doesn't do it, run firefox from the run box using the command: firefox -safemode

This will run Firefox without the add-ons. If that resolves the problem and you don't have a QuickTime plugin, you'll have to restart Firefox normally and disable a few add-ins at a time, restarting Firefox between tests, to isolate the one(s) causing the problem. Post it here so we know what you find.

Well, I got the same problem with QuickTime 7.5.5, so I ended up rolling all the way back to QuickTime 7.4 and the issue still occured as long as the add-on was enabled. I guess I'll be using Firefox without the QuickTime plugin enabled then. Oh well. I least I can make it work. Disable the QuickTime plugiin and restart Firefox. If this doesn't do it, run firefox from the run box using the command: firefox -safemode This will run Firefox without the add-ons. If that resolves the problem and you don't have a QuickTime plugin, you'll have to restart Firefox normally and disable a few add-ins at a time, restarting Firefox between tests, to isolate the one(s) causing the problem. Post it here so we know what you find.

Question owner

Having same problems. Google search works once. Then re-query nothing happens. Link changes in address bar but won't load. Right click reload it comes up. Disabled every plugin on firefox with exception of default one. Restarted firefox with same results. This doesn't appear to be a plugin problem. Hope someone comes up with a solution soon I google alot.

Having same problems. Google search works once. Then re-query nothing happens. Link changes in address bar but won't load. Right click reload it comes up. Disabled every plugin on firefox with exception of default one. Restarted firefox with same results. This doesn't appear to be a plugin problem. Hope someone comes up with a solution soon I google alot.

Question owner

Alas, Mike is right. The problem has recurred for me even with the QuickTime Plugin disabled. It is interesting that the second page Google search worked occasionally after a restart for me, but the fact that it worked after I disabled the QuickTime plugin looks like it may have just been i coincidence.

Alas, Mike is right. The problem has recurred for me even with the QuickTime Plugin disabled. It is interesting that the second page Google search worked occasionally after a restart for me, but the fact that it worked after I disabled the QuickTime plugin looks like it may have just been i coincidence.

Question owner

I have the same issue. I have Firefox 3.6.6 and am using Windows XP. I have disabled all Extensions and Plug-ins, and the problem did not resolve. To reiterate, searching on www.google.com works the first time. On the results page, typing a new entry and pressing either "enter" or clicking "search" changes the URL address bar but does not reload the page. And the search autofill (via ajax) on the results page does not work either.

I have the same issue. I have Firefox 3.6.6 and am using Windows XP. I have disabled all Extensions and Plug-ins, and the problem did not resolve. To reiterate, searching on www.google.com works the first time. On the results page, typing a new entry and pressing either "enter" or clicking "search" changes the URL address bar but does not reload the page. And the search autofill (via ajax) on the results page does not work either.

Helpful Reply

I can give you a temporary solution. Enter the letter s after the http at the top and hit enter. This will take you to Goggle's secure search which seems to be working just fine for me with Fifefox. Doesn't solve the problem in the long run, but gives you a way to use Google until the problem is fixed.

I can give you a temporary solution. Enter the letter s after the http at the top and hit enter. This will take you to Goggle's secure search which seems to be working just fine for me with Fifefox. Doesn't solve the problem in the long run, but gives you a way to use Google until the problem is fixed.

Question owner

Same problem and I've never had the quicktime addon installed. I think it's something else. First page of google works, second (context query) page does not work when i click the button. I hate this bug. Doesn't happen with Bing, doesn't happen with Internet Explorer and google.

Same problem and I've never had the quicktime addon installed. I think it's something else. First page of google works, second (context query) page does not work when i click the button. I hate this bug. Doesn't happen with Bing, doesn't happen with Internet Explorer and google.

Question owner

forgot to say, I have 3.6.6

forgot to say, I have 3.6.6

Question owner

Same problem FF 3.6.6 on Mac OS 10.6

Same problem FF 3.6.6 on Mac OS 10.6

Question owner

I've had the same problem. Sorry, I made another forum question that is a little more in depth before realizing that you asked the same thing.

Yesterday, I asked about this on the google forums, but you can see how well THAT turned out. http://www.google.com/support/forum/p/Web+Search/thread?tid=5b21efd3b15e5c7d&hl=en

I've had the same problem. Sorry, I made another forum question that is a little more in depth before realizing that you asked the same thing. Yesterday, I asked about this on the google forums, but you can see how well THAT turned out. http://www.google.com/support/forum/p/Web+Search/thread?tid=5b21efd3b15e5c7d&hl=en