Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 78.0.1 hangs trying to access websites but other browsers can

  • 9 replies
  • 1 has this problem
  • 97 views
  • Last reply by d.

more options

I have been using firefox for years and am very happy with it. I have a Dell optiplex 7010 desktop. I am running Ubuntu 18.04.4 LTS. I do not have a firewall turned on. Apparently, my desktop browser was updated to Firefox 78.0.1 (64-bit) on 7-1-2020. Since that time, I have been unable to access any websites from Firefox including mozilla.org. I am connected through WiFi. After downloading the Opera browser I have been able to access any website with no problems. I read community troubleshooting on this issue and tried various fixes including turning off IPv6. I read the community article about turning off my personal firewall. I was unaware of using any firewall so I installed Gufw Firewall 18.04.0. Running this program shows my firewall status is "OFF". I checked my AT&T modem and could not find any firewall settings that specifically mentioned Firefox. I would like to continue using Firefox since I use it on my phone and laptop also use it.

My laptop is a Dell Vostro 1520 running Ubuntu 18.04.2 LTS 64 bit. It also accesses the internet through the same WiFi. It currently has no problems loading web sites with Firefox version 78.0.1

Please help.

Chosen solution

Hi FredMcD, It was not hardware acceleration. I was able to disable all add-ons except Adblock Plus. The blue button for Adblock Plus apparently could not disable the extension. With all the extensions disabled EXCEPT Adblock Plus, websites could not load. I had to REMOVE Adblock Plus in order to "disable" it. Once Adblock Plus was removed the problem disappeared. I reinstalled Adblock Plus and the problem has not returned. By the way, while the problem was active, clicking the blue button to disable ABP and exiting Firefox seemed to hang its closing. About 2 hours spent trying to get to the bottom of the problem. Thanks very much FredMcD

Charlie

Read this answer in context 👍 0

All Replies (9)

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network.

[56+] Type about:preferences#general<enter> in the address bar. Look for Network.
+++++++++++++++++++++
Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

Helpful?

more options

Thanks for the suggestion FredMcD. i tried No Proxy - still doesn't connect to any web sites I next tried System Proxy and still no connection. The little dot in the left of the tab just continues to move back and forth endlessly.

Helpful?

more options

It's interesting that the suggested web sites "Recommended by Pocket" When I open a new tab are populated. but when I click on any of the selections the browser will not bring up any of the web pages.

Helpful?

more options

I would normally have you check your firewall, but you said you don't have one.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox.
Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode
Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Hi FredMcD, I started Firefox in safe mode (not Refresh) and the problem disappears. Thanks! What do I need to do to find out which feature or extension causes the problem? Charlie

Helpful?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration.
How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager.
Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again.

Let us know who the suspect is, detective.

Helpful?

more options

Chosen Solution

Hi FredMcD, It was not hardware acceleration. I was able to disable all add-ons except Adblock Plus. The blue button for Adblock Plus apparently could not disable the extension. With all the extensions disabled EXCEPT Adblock Plus, websites could not load. I had to REMOVE Adblock Plus in order to "disable" it. Once Adblock Plus was removed the problem disappeared. I reinstalled Adblock Plus and the problem has not returned. By the way, while the problem was active, clicking the blue button to disable ABP and exiting Firefox seemed to hang its closing. About 2 hours spent trying to get to the bottom of the problem. Thanks very much FredMcD

Charlie

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

more options

Glad to read about your efforts. I tried turning off all extensions, then turned off Hdwe Accel as you suggested. No love =( Ffx 78.0.1, Mac OS 10.15.5 Catalina, MacBook Pro 2.5GHz quad-core I7, 16Gb RAM.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.