X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox suddenly disabled all my add-ons

Posted

I got home, turned on the PC, loaded up Firefox, and ALL my addons are disabled and tossed into their 'legacy' pool of crap. No happy colorful theme, NO adblocker, no Ghostery... it even disabled my Bitdefender add-ons. Something is NOT right here. Anyone know what's going on? Firefox has NOT updated in at least a week or two, so I doubt it was an update breaking anything.

I got home, turned on the PC, loaded up Firefox, and ALL my addons are disabled and tossed into their 'legacy' pool of crap. No happy colorful theme, NO adblocker, no Ghostery... it even disabled my Bitdefender add-ons. Something is NOT right here. Anyone know what's going on? Firefox has NOT updated in at least a week or two, so I doubt it was an update breaking anything.

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

blueboy714 1 solutions 15 answers

jscher2000 said

Hi blueboy714, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

That's good news - because I hate Chrome's features and limited privacy.

''jscher2000 [[#answer-1218001|said]]'' <blockquote> Hi blueboy714, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon. </blockquote> That's good news - because I hate Chrome's features and limited privacy.
Artmaker 1 solutions 17 answers

OH holy hell.... WHY suddenly did all my add ons get disabled? I DO NOT UPGRADE for this very reason. Bad enough I'm forced to click the NOT NOW thing over and over.... but I do it. So WHY are my adblockers all gone now? Come on mozilla. THEY WORKED JUST FINE. FIX THIS!!!!!

OH holy hell.... WHY suddenly did all my add ons get disabled? I DO NOT UPGRADE for this very reason. Bad enough I'm forced to click the NOT NOW thing over and over.... but I do it. So WHY are my adblockers all gone now? Come on mozilla. THEY WORKED JUST FINE. FIX THIS!!!!!
spacepope68 0 solutions 2 answers

@jscher2000, Firefox on my Windows10 disabled all the add-ons suddenly, however on my Linux machine that hasn't happened, so far. I am not sure if that will be any help to anyone, but it does seem strange to me.

@jscher2000, Firefox on my Windows10 disabled all the add-ons suddenly, however on my Linux machine that hasn't happened, so far. I am not sure if that will be any help to anyone, but it does seem strange to me.
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

Hi Artmaker, this is not due to an update, but the cruel march of time: the problem is that a certificate expired.

Some people are rolling back their system clocks 24 hours to a time that the certificate will pass verification. However, I don't know whether you just need to exit Firefox and restart it after that, or you need to reinstall your add-ons. Also, it may be confusing.

Hi Artmaker, this is not due to an update, but the cruel march of time: the problem is that a certificate expired. Some people are rolling back their system clocks 24 hours to a time that the certificate will pass verification. However, I don't know whether you just need to exit Firefox and restart it after that, or you need to reinstall your add-ons. Also, it may be confusing.
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

Hi spacepope68, I have not seen an explanation for when Firefox realizes the certificate expired. Possibly your Linux build turns off auto-updating? In that case, Firefox might not be checking with the Add-ons site as often as a regular build.

Hi spacepope68, I have not seen an explanation for when Firefox realizes the certificate expired. Possibly your Linux build turns off auto-updating? In that case, Firefox might not be checking with the Add-ons site as often as a regular build.
Artmaker 1 solutions 17 answers

jscher2000 said

Hi Artmaker, this is not due to an update, but the cruel march of time: the problem is that a certificate expired. Some people are rolling back their system clocks 24 hours to a time that the certificate will pass verification. However, I don't know whether you just need to exit Firefox and restart it after that, or you need to reinstall your add-ons. Also, it may be confusing.

So I just tried to find new ones.... every one I try "fails to download." There is nothing wrong with my internet connection. Right now I'm playing music off youtube. Working just fine though now my add on to automatically keep the music playing without clicking "continue" no longer works. I sure hope this gets fixed. And I will NEVER be upgrading to anything that automatically upgrades every time the wind shifts. I think I have the last version where at least I can click "not now." (or ever... leave me alone.)

''jscher2000 [[#answer-1218034|said]]'' <blockquote> Hi Artmaker, this is not due to an update, but the cruel march of time: the problem is that a certificate expired. Some people are rolling back their system clocks 24 hours to a time that the certificate will pass verification. However, I don't know whether you just need to exit Firefox and restart it after that, or you need to reinstall your add-ons. Also, it may be confusing. </blockquote> So I just tried to find new ones.... every one I try "fails to download." There is nothing wrong with my internet connection. Right now I'm playing music off youtube. Working just fine though now my add on to automatically keep the music playing without clicking "continue" no longer works. I sure hope this gets fixed. And I will NEVER be upgrading to anything that automatically upgrades every time the wind shifts. I think I have the last version where at least I can click "not now." (or ever... leave me alone.)

Question owner

jscher2000 said

UPDATE The Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

Best news I've had since getting home and finding out the family decided to order pizza LOL. Thanks sir. :-)

''jscher2000 [[#answer-1217977|said]]'' <blockquote> '''UPDATE''' The Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon. </blockquote> Best news I've had since getting home and finding out the family decided to order pizza LOL. Thanks sir. :-)
af32vxl 1 solutions 11 answers

A temporary solution. Go to about:config from address bar. Find 'xpinstall.signatures.required' and double click to toggle it to false.

A temporary solution. Go to about:config from address bar. Find 'xpinstall.signatures.required' and double click to toggle it to false.
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

af32vxl said

A temporary solution. Go to about:config from address bar. Find 'xpinstall.signatures.required' and double click to toggle it to false.

This will work on Firefox Developer Edition and Firefox Nightly, but it probably won't work on the regular release.

''af32vxl [[#answer-1218098|said]]'' <blockquote> A temporary solution. Go to about:config from address bar. Find 'xpinstall.signatures.required' and double click to toggle it to false. </blockquote> This will work on Firefox Developer Edition and Firefox Nightly, but it probably won't work on the regular release.
af32vxl 1 solutions 11 answers

Works on mine. Ubuntu LTS version.

Works on mine. Ubuntu LTS version.
James
  • Top 25 Contributor
  • Moderator
1600 solutions 11315 answers

Release as in official Release from Mozilla like say www.mozilla.org/firefox/all/ and not third-party builds of Firefox that Mozilla did not well build.

Release as in official Release from Mozilla like say www.mozilla.org/firefox/all/ and not third-party builds of Firefox that Mozilla did not well build.
Melchior (aka Joseph) 1 solutions 26 answers

me too... I am very unhappy with Mozilla... Firefox was WAY better with XUL/XPCOM extension system.. MOZILLA GUTTED Firefox's best feature for signed web-extensions..... ops signature expired... GOOD GRIEF even my themes GOT disabled... THIS CATASTROPHE has me really upset on Mozilla short sited nonsense...

jscher2000 thx for the info on what happened... hope they fix this soon...

me too... I am very unhappy with Mozilla... Firefox was WAY better with XUL/XPCOM extension system.. MOZILLA GUTTED Firefox's best feature for signed web-extensions..... ops signature expired... GOOD GRIEF even my themes GOT disabled... THIS CATASTROPHE has me really upset on Mozilla short sited nonsense... jscher2000 thx for the info on what happened... hope they fix this soon...
Yardy_83 0 solutions 3 answers

Thank God I'm not the only one having this problem. I am pissed: why does this $#it keep happening w/ Mozilla? Incidents like this is the reason I switched to chrome years ago (and I really don't want to go back). I lost all my add-ons including Adblock (the most important one). I figured it was mozilla acting up, so I tried dloading straight from ABP's website, and I still was unable to dload. Hopefully these screenshots I took will help. If anyone has a solution, please help.

Thank God I'm not the only one having this problem. I am pissed: why does this $#it keep happening w/ Mozilla? Incidents like this is the reason I switched to chrome years ago (and I really don't want to go back). I lost all my add-ons including Adblock (the most important one). I figured it was mozilla acting up, so I tried dloading straight from ABP's website, and I still was unable to dload. Hopefully these screenshots I took will help. If anyone has a solution, please help.
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

Hi Yardy_83, there isn't a solution yet.

A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, preventing many extensions from being used, updated, or installed. So it's not your connection; it's everyone's connection.

The Add-ons team is working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround for the regular release of Firefox is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

Hi Yardy_83, there isn't a solution yet. A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, preventing many extensions from being used, updated, or installed. So it's not your connection; it's everyone's connection. The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround for the regular release of Firefox is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.
oscarM 0 solutions 1 answers

any chance that a future update will allow the user to override disabled add-ons? I understand the concern about security, but in cases like tonight it would still allow people to work. I'm a big fan of letting people control their tools.

any chance that a future update will allow the user to override disabled add-ons? I understand the concern about security, but in cases like tonight it would still allow people to work. I'm a big fan of letting people control their tools.
Aimhere 1 solutions 8 answers

jscher2000 said

The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

That link isn't working. I get "502 Bad Gateway".

''jscher2000 [[#answer-1218188|said]]'' <blockquote> The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 </blockquote> That link isn't working. I get "502 Bad Gateway".
Chris Ilias
  • Moderator
357 solutions 1952 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
blueboy714 1 solutions 15 answers

So far - no change. Why does Mozilla keep shooting itself in the foot when the browser doesn't have any problem? I'm switching over to Chrome until Mozilla gets this mess resolved.

PS - your link isn't working for https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047/14

So far - no change. Why does Mozilla keep shooting itself in the foot when the browser doesn't have any problem? I'm switching over to Chrome until Mozilla gets this mess resolved. PS - your link isn't working for https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047/14

Modified by blueboy714

Question owner

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

YES! Finally! I got on just a few min ago and my add-ons reenabled. I had to manually enable the theme again, but it looks like FINALLY everything is back to normal. Although I do have to say the whole 'silent sneaking around in the background' thing that Studies has as a default, on top of the oversight that caused this issue in the first place, has me more than a bit leery about continued use of Firefox. I had NO idea about this 'feature' or that it was enabled, but it certainly makes a LOT more sense on how many seemingly 'random' glitches suddenly happened with Quantum. Like my notifications suddenly getting turned off, it sometimes (now always) not actually updating passwords when asked, this security certificate issue... I'm not a fan of the 'live service' mentality, especially if it means they can literally change something I have set, without caring if I don't want it changed, and are basically saying they don't care, it's gonna happen anyway.

''Chris Ilias [[#answer-1218384|said]]'' <blockquote> Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote> YES! Finally! I got on just a few min ago and my add-ons reenabled. I had to manually enable the theme again, but it looks like FINALLY everything is back to normal. Although I do have to say the whole 'silent sneaking around in the background' thing that Studies has as a default, on top of the oversight that caused this issue in the first place, has me more than a bit leery about continued use of Firefox. I had NO idea about this 'feature' or that it was enabled, but it certainly makes a LOT more sense on how many seemingly 'random' glitches suddenly happened with Quantum. Like my notifications suddenly getting turned off, it sometimes (now always) not actually updating passwords when asked, this security certificate issue... I'm not a fan of the 'live service' mentality, especially if it means they can literally change something I have set, without caring if I don't want it changed, and are basically saying they don't care, it's gonna happen anyway.
blueboy714 1 solutions 15 answers

Has anyone had any success getting their add-ons back? Do we have reinstall the add-ons or do they automatically get reinstalled whenever we get this Mozilla update?

Has anyone had any success getting their add-ons back? Do we have reinstall the add-ons or do they automatically get reinstalled whenever we get this Mozilla update?