Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

My bottom horizontal scroll bar is missing on most (but not all webpages) on Firefox. I'm having

  • 10 件の返信
  • 7 人がこの問題に困っています
  • 8 回表示
  • 最後の返信者: cor-el

more options
I have tried all the suggestions in the Mozilla Help archives, including resetting Firefox, and disabling add ons. I still have the problem in Safe Mode. I've also tried minimizing and maximizing the window, but that that only solves the problem on certain web pages. I'm having particular trouble on the following page: https://accounts.google.com/o/oauth2/auth?response_type=code&redirect_uri=https%3A%2F%2Fhootsuite.com%2Fgoogle%2Fgoogle-auth-confirm&client_id=821312493542-0tk7virs4gc21trhvk6mehbocbim53ag.apps.googleusercontent.com&scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.me+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.stream.read+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.stream.write+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.circles.read+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.circles.write+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.pages.manage+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.media.readwrite&access_type=offline&approval_prompt=force

すべての返信 (10)

more options

Hi Suzzmind, I have tried to reproduce this with the webpage that you provided as an example on a few computers and the horizontal scroll only showed up for this page on a mac. The horizontal scroll on a Win 7 machine indeed did not have a horizontal scrollbar.

If you can find another page where this happens I can narrow down the root cause. I would like to make sure it is not a css feature of the webpage.

Please post back when you can. Thank you!

more options

When I view that page on Windows 7 -- I am not logged in to Google -- it is very narrow and in fact I cannot shrink the window small enough to get a horizontal scrollbar unless I enlarge the page content using Ctrl+ (holding down Ctrl and tapping the + key a couple of times).

If that page is opening for you in a popup window, there could be an additional factor: when scripts open a popup window, they can specify that Firefox should not display a scroll bar (or various toolbars). To prevent sites from suppressing such features, you can make a change in Firefox's about:config preferences editor. Here are the steps.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste dom and pause while the list is filtered

(3) Double-click the dom.disable_window_open_feature.scrollbars preference to switch it from false to true. By choosing true, you disable sites from deciding whether there can be scrollbars on a window, and Firefox uses its standard behavior for the page.

If you want to always get other bars, here are the corresponding settings:

  • Menu Bar: dom.disable_window_open_feature.menubar
  • Navigation Toolbar: dom.disable_window_open_feature.toolbar
  • Bookmarks Toolbar: dom.disable_window_open_feature.personalbar

Edit: cleaned out stray text

この投稿は jscher2000 - Support Volunteer により に変更されました

more options

That worked for me, thanks!

Part of the problem with problems like this is the complex system that you can develop for your browser. I have an ad-blocker, Request Policy (websites have to get approval from me to access other websites), and now No Script.

The problem started with the No Script. Now if I could figure out how to get No Script to stop blocking my eBay sniper...I'd have less money and more toys. Maybe things are better this way.

more options

Hi, I figured I'd find another page with a problem for ya. Same thing here on a windows XP computer using FF 30.0 the bottom horizontal scrollbar is missing on some pages but not all... It's driving me nuts! I personally think FF needs to have a Variable integer specifically for the horizontal views. Every page that comes up with vertical scrolls has no problems. it can go on and on and on. but yet with Horizontal we have misery all over. Firefox is the only browser I really trust now and it;s sad to see we are one of the only browsers unable to keep horizontal scrollbars to see entire pages. That's just my opinion... I don't even know how many pixels i have it set at. I have it set at this lol

layout.css.devPixelsPerPx; userset string -5.0

it's horrible but it's the only way I can see anything on this computer. I've even seen people with recommendations of

layout.css.devPixelsPerPx set at -1.0 and 1.1

but that just doesn't work for me. But the web page is http://www.nbcsports.com/ a simple site. shouldn't be any problems yet I have to hit Ctrl (+) - to zoom out to see the dang page because there is no horizontal scrollbar.... anyways. as i was saying we need a universal variable horizontal scrollbar setting. I was looking in the about:config and i saw

layout.scrollbar.side default integer 0

Is there a way we can set up for the bottom???

I tried Layout.scrollbar.bottom userset interger 0 and it didn't put anything there.

although I'm not that computer technical savy I figured I'd at least give it a try. I don't know or understand the whole configuration setup thing but I do try to learn it when I can...

comments on this please???? -John

more options

Hi NJvfc123, the NBC Sports page has a style rule that sets overflow-x (horizontal overflow) to hidden. (See screenshot) This stops Firefox from showing the scrollbar.

I'm not aware of any built-in setting to prevent sites from doing that. However, you can apply a custom style rule to websites using either a userContent.css file or the Stylish extension. I've attached a screenshot showing the result of this rule:

@namespace url(http://www.w3.org/1999/xhtml);
html, body {
    overflow-x: visible !important;
}

Since I haven't tested it much, I can't guarantee it won't cause other issues. To only modify this one site, you could use this site-specific rule:

@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("www.nbcsports.com") {
    html, body {
        overflow-x: visible !important;
    }
}

To use the Stylish extension, first install it from the Add-ons site. Then its "S" icon should appear on the toolbar. Click that, Write New Style > Blank Style, and in the large editing area, paste the rule. Then click Preview to see the effect. if it works, go ahead and give it a name and save it.

https://addons.mozilla.org/firefox/addon/stylish/

more options

okay, thanks, now I'm wondering is there a way to force the site that says overflow-x: hidden to overflow-x visible no matter what the site is???\

more options

Hi John, yes, that is what the first style rule is designed to do.

more options

jscher2000, thanks!

Your about:config tip worked for me (dom.disable_window_open_feature.scrollbars).

I wonder why it's set to "false" by default to begin with....

(UPDATE) - actually I thought it worked but it didn't. I was looking at the wrong page. I'm having the same problem of no horizontal scrollbar at the bottom of the page on some sites. I'll have to try the more detailed fix you mentioned in a later post but I'm reluctant to install yet one more add-on to solve something that should be built into the browser.... oh, well.

この投稿は miffed214 により に変更されました

more options

Hi miffed214, each of those "fixes" is for a different problem, so unfortunately neither is a complete solution on its own.

more options

Can you post a screenshot of the http://www.nbcsports.com/ page?

What are your screen dimensions?