Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

Why do some websites load in french?

  • 1 件の返信
  • 3 人がこの問題に困っています
  • 13 回表示
  • 最後の返信者: cor-el

more options

I recently changed the language settings on my Macbook to full French language for a couple months. During this time, while Firefox of course was not able to translate all English websites to French, it did seem to automatically switch to the French versions of some websites that offer such language options.

Today I switched back to English, but for some reason Firefox is still automatically selecting the French version of available websites (this very Mozilla's support site, for example). Is this something that can be corrected by resetting my Firefox settings, or could it be a deeper Mac issue? As far as I can tell my computer and network recognizes my current location as English-based. Thanks.

I recently changed the language settings on my Macbook to full French language for a couple months. During this time, while Firefox of course was not able to translate all English websites to French, it did seem to automatically switch to the French versions of some websites that offer such language options. Today I switched back to English, but for some reason Firefox is still automatically selecting the French version of available websites (this very Mozilla's support site, for example). Is this something that can be corrected by resetting my Firefox settings, or could it be a deeper Mac issue? As far as I can tell my computer and network recognizes my current location as English-based. Thanks.

すべての返信 (1)

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

You can check the intl.accept_languages pref on the about:config page.