Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドは閉じられ、アーカイブに保管されました。 必要であれば新たに質問してください。

Firefox searching instead of dns resolving internal websites

  • 2 件の返信
  • 1 人がこの問題に困っています
  • 96 回表示
  • 最後の返信者: sydmackintosh

more options

I have multiple internal websites, which all follow the pattern of [site.one.two] which resolves fine using the internal DNS server i have configured by going to https://site.one.two and through other programs via site.one.two, and all the [one.two] suffixes are blacklisted from being resolved with DoH in firefox, but it still forces a web-search, even with searching from address bar being turned off, instead of resolving through my local DNS server (local server resolves local domain suffixes, anything else gets resolved through cloudflare DNS). I haven't found a fix in any other forums, and there are enough unique internal addresses that manually adding each and [every site.one.two] as an exception would be something i would like to avoid. Is there any way to tell firefox to resolve through DNS first for addresses or domain suffixes?

I have multiple internal websites, which all follow the pattern of [site.one.two] which resolves fine using the internal DNS server i have configured by going to https://site.one.two and through other programs via site.one.two, and all the [one.two] suffixes are blacklisted from being resolved with DoH in firefox, but it still forces a web-search, even with searching from address bar being turned off, instead of resolving through my local DNS server (local server resolves local domain suffixes, anything else gets resolved through cloudflare DNS). I haven't found a fix in any other forums, and there are enough unique internal addresses that manually adding each and [every site.one.two] as an exception would be something i would like to avoid. Is there any way to tell firefox to resolve through DNS first for addresses or domain suffixes?

選ばれた解決策

I assume the .two in your addresses does not map to an official TLD (like .com or .net or .xyz) or one that Firefox has whitelisted in advance (like .internal or .local or .test).

When you type site.one.two in the address bar, Firefox will usually show "Search with [default search engine]" in the top row of the drop-down before you submit the entry. Then after your search results appear, Firefox may show an info bar above the page asking whether you meant to go to http://site.one.two/ -- with a button to go there. Are you seeing that bar?

For dotted host names on unofficial TLDs, Firefox sends your input to search first and checks (or should check) DNS second, unless you signal that it is meant to be understood as a host name by modifying your query in one of these ways:

  • add a slash after: site.one.two/
  • add the protocol before: https://site.one.two

If you want Firefox to always resolve dotted host names for an internal .two TLD without having to add anything, you can create a new preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.fixup.domainsuffixwhitelist.two (replacing two with the actual TLD) and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a "+" button.

(3) Keep the selection on Boolean and click the "+" button to create a new preference.

(4) If the preference does not end up being set to true, double-click it (or click the Toggle button or Reset button at the right end of the row) to set its value to true

Now when you type site.one.two in the address bar, instead of saying "Search with..." it should say "Visit".

Success?

この回答をすべて読む 👍 4

すべての返信 (2)

more options

選ばれた解決策

I assume the .two in your addresses does not map to an official TLD (like .com or .net or .xyz) or one that Firefox has whitelisted in advance (like .internal or .local or .test).

When you type site.one.two in the address bar, Firefox will usually show "Search with [default search engine]" in the top row of the drop-down before you submit the entry. Then after your search results appear, Firefox may show an info bar above the page asking whether you meant to go to http://site.one.two/ -- with a button to go there. Are you seeing that bar?

For dotted host names on unofficial TLDs, Firefox sends your input to search first and checks (or should check) DNS second, unless you signal that it is meant to be understood as a host name by modifying your query in one of these ways:

  • add a slash after: site.one.two/
  • add the protocol before: https://site.one.two

If you want Firefox to always resolve dotted host names for an internal .two TLD without having to add anything, you can create a new preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.fixup.domainsuffixwhitelist.two (replacing two with the actual TLD) and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a "+" button.

(3) Keep the selection on Boolean and click the "+" button to create a new preference.

(4) If the preference does not end up being set to true, double-click it (or click the Toggle button or Reset button at the right end of the row) to set its value to true

Now when you type site.one.two in the address bar, instead of saying "Search with..." it should say "Visit".

Success?

more options

yup! that works perfectly, makes sense why firefox behaves that way. all my variations of `.two` are invalid TLDs outside of the local network