Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

After updating to Version 29.0.1, high contrast no longer works.

  • 1 件の返信
  • 13 人がこの問題に困っています
  • 12 回表示
  • 最後の返信者: Gingerbread Man

more options

I use Windows 7's High Contrast frequently (it is much easier on my eyes). After Firefox updated to Version 29.0.1, the browser no longer displayed web pages in high contrast (white text on black background). Is there a way to fix this? (I am now back to using Version 28, which works correctly)

すべての返信 (1)

more options

Firefox 28 exposes your system to security vulnerabilities.


You can override website colors under Options → Content → Colors.

I don't recommend it though. That also hides background images, which some sites use to display information that's essential to navigation. There are two methods that are preferable to the above:

Method 1

  1. Install the NoSquint add-on.
  2. Open the Add-ons Manager (Ctrl+Shift+A; Mac: Command+Shift+A), then the Extensions category.
  3. Next to the NoSquint entry, click the Options button.
  4. Click the Colors tab. Check whatever options you're interested and set the colors, but make sure "Disable background images" remains unchecked.

Method 2

  1. Install Stylish and restart Firefox when prompted.
  2. Click the ≡ Menu Button and choose Add-ons.
  3. In the Add-ons Manager, click User Styles on the left.
  4. Click the Write New Style button at the top. Paste the either of the following styles in the text box, give the style a name, then click the Save button.
    • You can then toggle the style on or off by clicking the Stylish icon on the toolbar.

@-moz-document url-prefix("http://"), url-prefix("https://") {
/* Dark background and light text. For more color names, see http://www.w3schools.com/HTML/html_colornames.asp */

* { background-color: rgb(20,20,20) !important; color: whitesmoke !important; }

a:link { color: royalblue !important; }
a:visited { color: blue !important; }
a:hover { color: lightblue !important; }
a:active { color: red !important; }

}

@-moz-document url-prefix("http://"), url-prefix("https://") {

/* Light background and dark text. For more color names, see http://www.w3schools.com/HTML/html_colornames.asp */
* { background-color: whitesmoke !important; color: rgb(20,20,20) !important; }

a:link { color: royalblue !important; }
a:visited { color: blue !important; }
a:hover { color: dodgerblue !important; }
a:active { color: red !important; }
 
}

If you don't want to install an add-on, you can use the userContent.css file instead, but I don't recommend it.

この投稿は Gingerbread Man により に変更されました