Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

When Firefox restarts no titles come up

  • 11 risposte
  • 1 ha questo problema
  • 11 visualizzazioni
  • Ultima risposta di scottylightning

more options

When Firefox restarts(either from a previous day's session when shutting down the computer or a crash) it takes me about ten minutes to reload each window to find out the title for the webpage I was on. What is causing this and how can I prevent this from happening? Say I have 6 windows open(I hate tabs) and one will actually the site I was on before, but the other 5 just say "Mozilla Firefox".

Soluzione scelta

Tough question to answer. Usually it's best to disable all extensions (that's one of the options in the Safe Mode dialog, or you can do it manually) and see whether that fixes it. Then reenable the most essential ones as a first group, restart, see whether it's still good, then try the other ones in batches.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (11)

more options

Could you test the following setting if you haven't already tried this?

There is a new-ish feature when you restore a previous session to wait until you click a tab before loading the page. Maybe this affects windows as well?

This option is set here:

orange Firefox button or classic Tools menu > Options > General

Right below "Use my windows and tabs from last time" there is a checkbox you can uncheck labeled "Don't load tabs until selected".

Does that make any difference?

more options

Actually that just made it worse! Haha

I have now 25 windows open when I restarted and only two had the title.

more options

Did you actually have 25 windows open in your previous session?

Firefox stores session information in a file named sessionstore.js. Perhaps that file has become corrupted? To start clean -- naturally this will purge your last session -- you can rename that file and let Firefox create a new one.

To access your current settings folder (your active Firefox profile folder), use

Help > Troubleshooting Information > Show Folder

Copy all the sessionstore... files to a save location for future reference if necessary.

Switch back to Firefox and use Exit to fully close the browser.

In the Windows Explorer window, rename sessionstore.js to have a different extension, such as sessionstore.js.bak.

If you want to salvage URLs from your old sessionstore files, the format is somewhat challenging to read, but if you open it in a text editor that is aware of URLs, then they will be underlined at least.

more options

I actually did have 25 windows open(working on a paper for grad school); I did change the sessonstore.js to sessionstore.js.bak and exited Firefox. It did make a new sessionstore.js as I restarted it, but now there is not a single window had a title on it this time.

Weird, huh?

more options

Hmmm, I assumed you would just have 1 new window if you renamed your sessionstore.js file. Somehow it found your old session anyway? Hopefully someone more knowledgeable about this area of Firefox can pitch in.

Meanwhile, at the time that the Task Bar doesn't show the true title, does the actual window display the true title, or are those windows still not loading, even after turning off the deferred loading feature?

more options

I wonder whether any of your add-ons could be interfering with windows loading? A standard diagnostic for that is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

Still slow loading? Better?

more options

When I renamed the file and started up firefox it popped up to restore my previous session-go figure.

The windows show up themselves with the pages fully loaded, but I have to click on each window to see what site that popped up(I used to just be able to see the title right when I clicked from the taskbar)...and this was after turning off that feature.

I appreciate the help you gave me anyway. :)

more options

Let me try that first...

more options

In safe mode right now and it works like a charm! All 25 windows popped up the titles....

SO now the question is what add-on is causing this?

more options

Soluzione scelta

Tough question to answer. Usually it's best to disable all extensions (that's one of the options in the Safe Mode dialog, or you can do it manually) and see whether that fixes it. Then reenable the most essential ones as a first group, restart, see whether it's still good, then try the other ones in batches.

more options

Well, at least we got to the root of the problem and now it's just some "Trial and error" .

Thanks for your help! I really appreciate it! :)


EDIT: It was "DivX Plus Web Player HTML5" that was doing it.

Modificato da scottylightning il