Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I get FF to stop changing my proxy settings?

  • 11 risposte
  • 39 hanno questo problema
  • 11100 visualizzazioni
  • Ultima risposta di anas_dad

more options

I'm running FF 4 and every time I close it and re-open, I get the error message "Firefox is configured to use a proxy server that is refusing connections." I go into Options and change it to No Proxy and the same thing will happen the next time I open. FF will not keep the settings I make. Before a suggestion is made to upgrade, I will not go to FF5 until my favourite add-ons are made compatible. Thank you in advance.

Soluzione scelta

Did you check for an extension causing it?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (11)

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


more options

It didn't help. I restarted in Safe Mode (with add-ons disabled), got the same error message. I made sure the Appearance Tab was set to the Default Theme, still the same error. I disabled all Add-ons and Plug-ins manually and restarted, still the same error. FF insists on changing my settings to a Manual Proxy no matter what. I have asked for updates on all the add-ons again just to be sure. And I also looked for any recent additions that might have snuck in - there are none. Nothing has changed in that area within the past couple weeks at all and this problem only started a couple days ago.

more options

Update: having been forced to upgrade to FF5, I'm still having the same problem. Why will FF not leave my proxy settings where I put them?

A separate issue is something I found only with FF5 - a blue line down the right side of the screen about 3/4 the way across. It is everywhere, on every page. What is causing that?

Modificato da sage il

more options

Do you see that blue in Safe mode?

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.


Did you check all possibilities from *http://kb.mozillazine.org/Preferences_not_saved ?

Did you try to delete the file prefs.js and checked for the presence of a file user.js?

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Okay, blue line is gone after driver update. Thank you :) Original problem of resetting to manual proxy is still there. The "preferences not saved" doesn't really address that problem. I did delete prefs.js and user.js, still happening. <sigh>

more options

Soluzione scelta

Did you check for an extension causing it?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Yes, I started FF in Safe Mode with all add-ons disabled. The problem was there too. And I've been on default theme throughout. I have it set to "remember tabs on opening" and have 3 pinned tabs on top. The home page starts up fine, the pinned tabs are "no connection" because of proxy settings. If I try to switch to a new window or tab from home page, it gives the error message. I've tried everything I can think of...setting to "no proxy" or "system proxy" or "auto detect proxy" as Administrator then re-opening normally; I've rebooted numerous times; cleared history and cache; tried all the extensions. I'm confuddled.  :(

more options

It is either an extension that causes settings to change or you have a file user.js that overrides settings or there is a problem with the file prefs.js. I can't think of any other causes.


Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile:

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

SOLVED: The problem, at least for me, was the Xmarks 4.0.1 extension (this has worked fine for me for as long as I can remember until a few days ago when my proxy started changing) Here is how I found the problem, Start firefox with all add-ons disabled. Next, you MUST now change the proxy settings back to normal : network-Settings-no proxy Next starting from the first add-on, activate them one by one, restart firefox each time , and check to see if the proxy was changed. I discovered that Xmarks was the guy messing with my proxy settings, disable this and everything works fine, at least for me Hope this helps

more options

Problem solved. Yes, one of the add-ons was causing it. Weird, I've had that add-on for almost a year now and have been using it constantly. It's gone through all the FF updates no problem and all of a sudden started causing the proxy reset. What was confusing was that the proxy problem was also happening in safe mode with all add-ons disabled. Guess I'll have to make a second profile.  :( Thanks for all the help, it is appreciated.

more options

SOLVED: I still really don't know what was causing it but this was just one of a host of problems Iv'e been working on for a week. The fairly easy fix was to create a new profile and move needed files over.