X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I set Flash Player to autoplay on Youtube in Firefox?

Inserita

I went to some website that asked me to run Adobe Flash Player and now ever since I did the videos on youtube wont start playing until I click on them to. I want to set them so they start playing on their own again.

I tried turning on autoplay on youtube, but that didn't help. I tried going to the add-ons and changing to Always Activate, but that didn't work. I even tried Never Activate. I then looked at the Adobe Flash Player settings within the Control Panel, but nothing there helped.

I'm now considering uninstalling the program, but I'm confused, is it Adobe Flash Player that I need to uninstall or Adobe Shockwave Player? And, will this make it so videos don't play at all?

I went to some website that asked me to run Adobe Flash Player and now ever since I did the videos on youtube wont start playing until I click on them to. I want to set them so they start playing on their own again. I tried turning on autoplay on youtube, but that didn't help. I tried going to the add-ons and changing to Always Activate, but that didn't work. I even tried Never Activate. I then looked at the Adobe Flash Player settings within the Control Panel, but nothing there helped. I'm now considering uninstalling the program, but I'm confused, is it Adobe Flash Player that I need to uninstall or Adobe Shockwave Player? And, will this make it so videos don't play at all?

Modificato da markfleener il

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 32.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Ulteriori informazioni

WestEnd 60 soluzioni 5387 risposte

Most Browser use now html5 if flash is needed you have to install it separately. If you need flash you have to go and download the version needed from adobe site and install it. You already stated it said you needed Flash to be installed.

Most Browser use now html5 if flash is needed you have to install it separately. If you need flash you have to go and download the version needed from adobe site and install it. You already stated it said you needed Flash to be installed.

Utente che ha posto la domanda

I did run flash at that website, but it's changed how youtube functions and I'd like to get it back to the way it was.

I did run flash at that website, but it's changed how youtube functions and I'd like to get it back to the way it was.

Utente che ha posto la domanda

I just now uninstalled Adobe Flash Player and the Shockwave Player, but it's still not back the way it was before.

I just now uninstalled Adobe Flash Player and the Shockwave Player, but it's still not back the way it was before.
McCoy
  • Top 10 Contributor
590 soluzioni 5652 risposte

Hello markfleener,

First : Adobe Flash Player is installed on your system, and shows in Firefox (Add-ons => Plugins) as Shockwave Flash.

Your system details show that you have Flash installed.

About the YourTube videos not autoplaying :

As YouTube uses HTML5, this is not related to Flash.

Would you please do this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.autoplay

Look for the preferences :

media.autoplay.default and make sure its value is set to 1

and :

media.autoplay.block-webaudio and make sure its value is set to false

If you had to change anything, then close and restart Firefox.

'Hope that helps .....

Hello markfleener, First : Adobe Flash Player is installed on your system, and shows in Firefox (Add-ons => Plugins) as Shockwave Flash. Your system details show that you have Flash installed. About the YourTube videos not autoplaying : As YouTube uses HTML5, this is not related to Flash. Would you please do this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''media.autoplay''' Look for the preferences : '''media.autoplay.default''' and make sure its value is set to '''1''' and : '''media.autoplay.block-webaudio''' and make sure its value is set to '''false''' If you had to change anything, then close and restart Firefox. 'Hope that helps .....

Utente che ha posto la domanda

Those settings were already set like that, so I didn't change anything. I'm now noticing that I have Adobe AIR installed. Should I get rid of that too? Then again, you say this has nothing to do with Adobe, but it was my running Flash at that one website that changed how youtube functions, despite youtube not really using Flash.

Those settings were already set like that, so I didn't change anything. I'm now noticing that I have Adobe AIR installed. Should I get rid of that too? Then again, you say this has nothing to do with Adobe, but it was my running Flash at that one website that changed how youtube functions, despite youtube not really using Flash.

Modificato da markfleener il

jscher2000
  • Top 10 Contributor
8893 soluzioni 72769 risposte

Risposta utile

Hi markfleener, Adobe AIR is a tool to run Flash outside of a browser, so you can ignore that for now.

You can give permanent autoplay permission for YouTube. When you click that slashed-circling-arrow-play-button icon in the address bar and change the permission from Block to Allow, it should be remembered. Is it not remembered? How soon is it forgotten? For example:

  • next time going to YouTube in the same session
  • after exiting Firefox and starting it up again
  • after shutting down and restarting Windows
  • some other pattern

Hi markfleener, Adobe AIR is a tool to run Flash ''outside'' of a browser, so you can ignore that for now. You can give permanent autoplay permission for YouTube. When you click that slashed-circling-arrow-play-button icon in the address bar and change the permission from Block to Allow, it should be remembered. Is it not remembered? How soon is it forgotten? For example: * next time going to YouTube in the same session * after exiting Firefox and starting it up again * after shutting down and restarting Windows * some other pattern <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-03-29-09-21-28-441c0f.png" width="500">