X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to Disable Quick Find Hotkeys (" ' " and "/")?

Inserita

Problem:

Unable to disable/modify default Quick Find keybindings (the apostrophe key and the forward slash key).

Attempted (and Failed) Solutions:

(1) Not able to use Murphy's solution (https://support.mozilla.org/en-US/questions/1215667), because there is no 'Options' subheading in my 3-bar drop-down menu and I am otherwise unable to find a 'Browsing' subheading.

(2) Not able to use cor-el's solution (https://support.mozilla.org/en-US/questions/984845), because the modification suggested is no longer supported by my version of Firefox (61.0.1 (64-bit) on Linux Xenial).

(3) Not able to use suggestion at https://techdows.com/2018/06/disable-quick-find-firefox.html, because ‘accessibility.typeaheadfind.manual‘ preference is not listed. Toggling value of 'accessibility.typeaheadfind', 'accessibility.typeaheadfind.flashBar', and 'accessibility.typeaheadfind.linksonly' did not disable Quick Find after restarting Firefox.

(4) I also tried adding the preference 'searchkeys.disable.all' to 'about:config' and setting its boolean value to 'true' (I am unable to recall source of this suggestion), but it also did not work.

Your help is greatly appreciated! Thank you in advance for your time and effort!

Problem: Unable to disable/modify default Quick Find keybindings (the apostrophe key and the forward slash key). Attempted (and Failed) Solutions: (1) Not able to use Murphy's solution (https://support.mozilla.org/en-US/questions/1215667), because there is no 'Options' subheading in my 3-bar drop-down menu and I am otherwise unable to find a 'Browsing' subheading. (2) Not able to use cor-el's solution (https://support.mozilla.org/en-US/questions/984845), because the modification suggested is no longer supported by my version of Firefox (61.0.1 (64-bit) on Linux Xenial). (3) Not able to use suggestion at https://techdows.com/2018/06/disable-quick-find-firefox.html, because ‘accessibility.typeaheadfind.manual‘ preference is not listed. Toggling value of 'accessibility.typeaheadfind', 'accessibility.typeaheadfind.flashBar', and 'accessibility.typeaheadfind.linksonly' did not disable Quick Find after restarting Firefox. (4) I also tried adding the preference 'searchkeys.disable.all' to 'about:config' and setting its boolean value to 'true' (I am unable to recall source of this suggestion), but it also did not work. Your help is greatly appreciated! Thank you in advance for your time and effort!

Soluzione scelta

Solved the problem.

1. Add add-on 'Shortkeys' (https://addons.mozilla.org/en-US/firefox/addon/shortkeys/) to Firefox.

2. Find Shortkeys in your Add-ons Manager ( 3-Bar Menu in upper right-hand corner of browser ==> 'Add-Ons' ==> 'Extensions' ==> 'Shortkeys'), and click on its 'Preferences' button.

3. Scroll down to the very bottom of the Shortkeys 'Preferences' page and select the 'Edit Shortcuts' tab (the one not labeled 'Import' or 'Export').

4. Add 'New Keyboard Shortcut' for forward slash and apostrophe keys (type "/" and " ' " in the 'Keyboard Shortcut' field), leaving the 'Behavior' fields blank. Save each shortcut.

5. Restart Firefox. Problem solved!

Leggere questa risposta nel contesto 0

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 30.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

Ulteriori informazioni

Soluzione scelta

Solved the problem.

1. Add add-on 'Shortkeys' (https://addons.mozilla.org/en-US/firefox/addon/shortkeys/) to Firefox.

2. Find Shortkeys in your Add-ons Manager ( 3-Bar Menu in upper right-hand corner of browser ==> 'Add-Ons' ==> 'Extensions' ==> 'Shortkeys'), and click on its 'Preferences' button.

3. Scroll down to the very bottom of the Shortkeys 'Preferences' page and select the 'Edit Shortcuts' tab (the one not labeled 'Import' or 'Export').

4. Add 'New Keyboard Shortcut' for forward slash and apostrophe keys (type "/" and " ' " in the 'Keyboard Shortcut' field), leaving the 'Behavior' fields blank. Save each shortcut.

5. Restart Firefox. Problem solved!

Solved the problem. 1. Add add-on 'Shortkeys' (https://addons.mozilla.org/en-US/firefox/addon/shortkeys/) to Firefox. 2. Find Shortkeys in your Add-ons Manager ( 3-Bar Menu in upper right-hand corner of browser ==> 'Add-Ons' ==> 'Extensions' ==> 'Shortkeys'), and click on its 'Preferences' button. 3. Scroll down to the very bottom of the Shortkeys 'Preferences' page and select the 'Edit Shortcuts' tab (the one not labeled 'Import' or 'Export'). 4. Add 'New Keyboard Shortcut' for forward slash and apostrophe keys (type "/" and " ' " in the 'Keyboard Shortcut' field), leaving the 'Behavior' fields blank. Save each shortcut. 5. Restart Firefox. Problem solved!

Utente che ha posto la domanda

Caveat: The shortcuts are only disabled on non-Mozilla webpages.

For example, when I go to nytimes.com, pressing the apostrophe and forward slash keys does nothing. However, while on these forum pages and in the Firefox preferences page, the hotkeys still open the Quick Find bar.

Weird and annoying, but ultimately not a big deal for me, at least.

Caveat: The shortcuts are only disabled on non-Mozilla webpages. For example, when I go to nytimes.com, pressing the apostrophe and forward slash keys does nothing. However, while on these forum pages and in the Firefox preferences page, the hotkeys still open the Quick Find bar. Weird and annoying, but ultimately not a big deal for me, at least.
cor-el
  • Top 10 Contributor
  • Moderator
17691 soluzioni 160067 risposte

This website and all other Mozilla websites use CSP rules that prohibit injecting script on their pages. This makes it impossible for WebExtensions (and bookmarklets) to work properly.

This website and all other Mozilla websites use CSP rules that prohibit injecting script on their pages. This makes it impossible for WebExtensions (and bookmarklets) to work properly.