X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Thunderbird is taking over all outgoing mail, even though it is not set as the default email program in Windows

Inserita

I use Outlook as my default email client, but occassionally I use Thunderbird. Even though Outlook is set as the default in Windows, in many programs when I use that program's "Send as email" function it brings out a Thunderbird dialog box instead of Outlook. If I uninstall Thunderbird then it works correctly.

How do I prevent Thunderbird from taking over this function even when it's not set as the default?

Ken

I use Outlook as my default email client, but occassionally I use Thunderbird. Even though Outlook is set as the default in Windows, in many programs when I use that program's "Send as email" function it brings out a Thunderbird dialog box instead of Outlook. If I uninstall Thunderbird then it works correctly. How do I prevent Thunderbird from taking over this function even when it's not set as the default? Ken

Soluzione scelta

Please check registry key: HKEY_CURRENT_USER\Software\Clients\Mail

'Start' > Run > type regedit Locate this registry entry: HKEY_CURRENT_USER\Software\Clients\Mail on right side double click on 'Default' Enter Microsoft Outlook in 'Value Data'

Windows 10 may have some variants. eg: HKEY_CURRENT_USER\Software\Clients\Mailto

also check: HKEY_CLASSES_ROOT\mailto\shell\open\command

I'm not using Windows 10. Suggest you use google to double check. such as : https://www.windows10forums.com/threads/send-to-option-not-recognizing-mail-as-default-email-program-even-when-set-as-such.6725/ treborkalarg comment. https://stackoverflow.com/questions/3940358/how-and-where-exactly-does-the-default-email-client-gets-set-in-the-registry

Leggere questa risposta nel contesto 3

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Ulteriori informazioni

Toad-Hall
  • Top 10 Contributor
1836 soluzioni 12368 risposte

It may be that your computer still has the default 'MAILTO' protocol setting as Thunderbird.

Control Panel > Default Programs select 'Associate a file type or protocol with a program' Under 'Protocols' select: MAILTO line click on 'Change Program' Select the one you want as default' click on 'Close'

It may be that your computer still has the default 'MAILTO' protocol setting as Thunderbird. Control Panel > Default Programs select 'Associate a file type or protocol with a program' Under 'Protocols' select: MAILTO line click on 'Change Program' Select the one you want as default' click on 'Close'

Utente che ha posto la domanda

The MAILTO Protocol was set correctly to Outlook 2016, and Outlook 2016 was set as the default email program as well. It still calls up Thunderbird. The only way to have it correctly call up Outlook is to uninstall Thunderbird.

The MAILTO Protocol was set correctly to Outlook 2016, and Outlook 2016 was set as the default email program as well. It still calls up Thunderbird. The only way to have it correctly call up Outlook is to uninstall Thunderbird.
Toad-Hall
  • Top 10 Contributor
1836 soluzioni 12368 risposte

Thunderbird is not setting the Mailto, that option has to be selected so that the computer or program knows what to use.

Test to see if the default mail client keeps changing depending upon which Email Client was last opened.

Please close Outlook if open and then open Thunderbird. Check your computer 'MAILTO' settings to see if they have changed.

In Thunderbird, please check this setting:

  • 'Menu icon' > 'Options' > 'Options' 'Advanced' > 'General' tab

under 'system Integration' section

  • uncheck 'Always check to see if Thunderbird is the default mail client on startup'
  • click on 'OK'


If you use eg: Firefox browser program - check the 'MailTO' settings: open Mozilla Firefox browser 'Tools' > 'Options' > 'Applications' 'Mailto' choose the default program you want to use.

Thunderbird is not setting the Mailto, that option has to be selected so that the computer or program knows what to use. Test to see if the default mail client keeps changing depending upon which Email Client was last opened. Please close Outlook if open and then open Thunderbird. Check your computer 'MAILTO' settings to see if they have changed. In Thunderbird, please check this setting: * 'Menu icon' > 'Options' > 'Options' 'Advanced' > 'General' tab under 'system Integration' section * '''uncheck''' 'Always check to see if Thunderbird is the default mail client on startup' * click on 'OK' If you use eg: Firefox browser program - check the 'MailTO' settings: open Mozilla Firefox browser 'Tools' > 'Options' > 'Applications' 'Mailto' choose the default program you want to use.
Toad-Hall
  • Top 10 Contributor
1836 soluzioni 12368 risposte

re :many programs when I use that program's "Send as email" function it brings out a Thunderbird

You need to find out what you have got setup for those programs. As an example....if you open Adobe Reader open any pdf document File > Preferences > Email Accounts check the settings.

re :''many programs when I use that program's "Send as email" function it brings out a Thunderbird '' You need to find out what you have got setup for those programs. As an example....if you open Adobe Reader open any pdf document File > Preferences > Email Accounts check the settings.

Utente che ha posto la domanda

It doesn't matter which program I use to send mail (Word, Excel, Paint, PdfXChange, etc., all of them will use Thunderbird if it is installed, regardless of the fact that Outlook is set as my default in both Windows and the individual programs. As far as the Thunderbird setting you mentioned, I have it set not to check to see if Thunderbird is the default. In Firefox, the default "mailto" shows "Use Outlook 2016 (default)", yet it will still use Thunderbird. I first saw this come up in using PdfXChange, will also is set to use Outlook but will call up Thunderbird anyway. I have spoken to them about it and they have been able to duplicate the problem and can't figure it out either. It has to be something that Thunderbird is doing.

It doesn't matter which program I use to send mail (Word, Excel, Paint, PdfXChange, etc., all of them will use Thunderbird if it is installed, regardless of the fact that Outlook is set as my default in both Windows and the individual programs. As far as the Thunderbird setting you mentioned, I have it set not to check to see if Thunderbird is the default. In Firefox, the default "mailto" shows "Use Outlook 2016 (default)", yet it will still use Thunderbird. I first saw this come up in using PdfXChange, will also is set to use Outlook but will call up Thunderbird anyway. I have spoken to them about it and they have been able to duplicate the problem and can't figure it out either. It has to be something that Thunderbird is doing.
Toad-Hall
  • Top 10 Contributor
1836 soluzioni 12368 risposte

Soluzione scelta

Please check registry key: HKEY_CURRENT_USER\Software\Clients\Mail

'Start' > Run > type regedit Locate this registry entry: HKEY_CURRENT_USER\Software\Clients\Mail on right side double click on 'Default' Enter Microsoft Outlook in 'Value Data'

Windows 10 may have some variants. eg: HKEY_CURRENT_USER\Software\Clients\Mailto

also check: HKEY_CLASSES_ROOT\mailto\shell\open\command

I'm not using Windows 10. Suggest you use google to double check. such as : https://www.windows10forums.com/threads/send-to-option-not-recognizing-mail-as-default-email-program-even-when-set-as-such.6725/ treborkalarg comment. https://stackoverflow.com/questions/3940358/how-and-where-exactly-does-the-default-email-client-gets-set-in-the-registry

Please check registry key: HKEY_CURRENT_USER\Software\Clients\Mail 'Start' > '''Run''' > type '''regedit''' Locate this registry entry: HKEY_CURRENT_USER\Software\Clients\Mail on right side double click on 'Default' Enter Microsoft Outlook in 'Value Data' Windows 10 may have some variants. eg: HKEY_CURRENT_USER\Software\Clients\Mailto also check: HKEY_CLASSES_ROOT\mailto\shell\open\command I'm not using Windows 10. Suggest you use google to double check. such as : https://www.windows10forums.com/threads/send-to-option-not-recognizing-mail-as-default-email-program-even-when-set-as-such.6725/ treborkalarg comment. https://stackoverflow.com/questions/3940358/how-and-where-exactly-does-the-default-email-client-gets-set-in-the-registry

Risposta utile

Thank you, Toad-Hall. That registry change did the trick. I am using Windows 10, but the registry key was still "...\Clients\Mail" (I didn't see any "...\Clients\Mailto" key). That key was still showing Thunderbird, even though I had uninstalled Thunderbird. For some reason that key wasn't getting updated.

Thanks so much!

Ken

Thank you, Toad-Hall. That registry change did the trick. I am using Windows 10, but the registry key was still "...\Clients\Mail" (I didn't see any "...\Clients\Mailto" key). That key was still showing Thunderbird, even though I had uninstalled Thunderbird. For some reason that key wasn't getting updated. Thanks so much! Ken