Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Unable to set paper size at all when using Firefox built-in PDF viewer

  • 12 risposte
  • 2 hanno questo problema
  • 6863 visualizzazioni
  • Ultima risposta di RBay

more options

I use the built-in Firefox pdf viewer and think it's fab.

But if I try to print, I go to print preview and go through the page setup and it's useless because it assumes my paper is nearly SQUARE, and the only options I have are portrait and landscape. I use A4 paper, like most of the UK and Europe.

Obviously I can't bypass the print preview otherwise it ends up defaulting to the wrong settings.

Shrink to fit (default) makes it only fit the width (if I set the margins to zero - this is okay), but misses the bottom half of page because Firefox thinks my paper is SQUARE for some reason.

The only thing that works is to set the print zoom to 60% and have everthing tiny, which is ridiculous.

Any ideas? Is there a way of manually setting the width and height of the paper?

Thanks if anyone can help with this - my alternative is to use Toshiba Reader for PDFs, and it prints terribly so as to be illegible. The print quality on Firefox is great, if I could get it to fit on the paper...

Soluzione scelta

Hmm, in your screen shots, why does the title bar of the window mention Yahoo mail? Is this an attachment that is somehow embedded in the message? If so, can you find a way to view it in its own tab? Sometimes right-click > This Frame > Open Frame in New Tab will do it, but I haven't opened Yahoo Mail to experiment.

Leggere questa risposta nel contesto 👍 2

Tutte le risposte (12)

more options

You can try installing adobe reader to further pdf capabilities.

more options

Is this problem unique to the PDF viewer? In other words, when you print web pages, they automatically use the correct paper size?

If both are wrong, here would be my general advice:

If Firefox is not using the whole sheet of paper, this can be caused by Firefox having extracted the wrong paper size settings from Windows when reading the print driver data. Clearing it can involve finding some obscure settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste print and pause while the list is filtered

(3) For each setting that specifically mentions the problem printer, right-click and Reset it. The fastest way is to right-click with the mouse and then press the r key on the keyboard with your other hand.

Note: In a couple threads involving Brother printers, the preference printer_printer_name.print_paper_data was set to 256 and when the user edited it to 1 that by itself fixed the paper size problem. If you use a Brother printer and see a 256 there, you can edit the value by doubling-clicking it or using right-click>Modify.

Any improvement?

more options

Hi jscher.

Thanks for the informative and thorough reply.

Sadly, the problem seems to be much the same if printing a web-page and the printer started the page with hieroglyphics.

Still the same weird things with the paper size in preview looking nothing like the A4 I am using. (The settings on the page you referred me to had the paper size in mm correct by the way though I reset them as you said to).

I remember setting this printer up with Windows 8 and remember while it works very well for Libreoffice text documents, it seems to have issues with everything else, including Notepad! Not a printer problem as such (have had the printer since 1990 and know it can handle graphics), but the legacy drivers in Windows 8 seem to have limitations. Or the USB-parallel port converter (virtual port) is the source of the problem, possibly.

Having seen the paper sizes were correct in the settings, I'm inclined to think this isn't a Firefox fault. A pity, as the printer seems to handle graphics better in Firefox than in anything else, so I had hoped this might be resolvable.

I'm thinking driver error though, now. You reckon?

more options

By the way, I later tried setting print paper data to settings other than the 9 it had chosen. I tried smaller numbers. With 0, I got no pdf view at all, with 256, I got a marginal improvement in the length of page, with 256000000, I got the same as with 256 :)

more options

Some printers or printer drivers have an "unprintable area" setting for the bottom of the page. Is it possible that your printer has an unreasonably large one set somewhere?

By default, Firefox will query Windows for this information, but you could try overriding it.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste bottom and pause while the list is filtered

(3) Double-click the print.print_unwriteable_margin_bottom preference and change it from -1 to 0 (zero)

(4) If there is a nonzero unwriteable_margin_bottom for your printer, set that to 0 as well.

Any difference?

more options

printer_printer_name.print_paper_data should be at 8 for A4 size paper (not the A4 Borderless). 1 is the US Letter size paper.

But that setting should get set via the Properties window accessed thru the "native print dialog" window - what you see with {Ctrl + P} or after using the Print button in the Print Preview window. Once set in Properties (and a print performed) Firefox should remember your choice and use that setting for subsequent printing - as long as print.save_print_settings is at default = true.

As far as the hieroglyphics = indicative of an issue with the PDF format and printer drivers usually.

1990 printer and the Win8 legacy drivers could be part of the problem that you are having. Any chance of using OEM print drivers?

more options

the-edmeister said

1990 printer and the Win8 legacy drivers could be part of the problem that you are having. Any chance of using OEM print drivers?

I wish. The printer is an Olivetti DM100. It does not have its own drivers. Instead it 'emulates' either a Proprinter, an Epson FX-(?)80, or an IBM 9-pin graphics printer. The only driver I can get that is compatible for this printer and Windows 8 is the Windows generic IBM graphics 9 pin.

I think I have tried the FX series driver designed for Windows 7. It didn't work.

Modificato da RBay il

more options

the-edmeister said

Once set in Properties (and a print performed) Firefox should remember your choice and use that setting for subsequent printing - as long as print.save_print_settings is at default = true.

It does remember, but this doesn't change the fact that the visualisation of the page is weird. Will do a screenprint.

more options

Sorry, I had to cover the personal details on this pdf before putting on an open forum.

First pic is with the paper landscape (wrong), second and third show top and bottom of portrait.

For reference, the pdf is shown as my 4th picture.

Modificato da RBay il

more options

jscher2000 said

Some printers or printer drivers have an "unprintable area" setting for the bottom of the page. Is it possible that your printer has an unreasonably large one set somewhere? By default, Firefox will query Windows for this information, but you could try overriding it. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste bottom and pause while the list is filtered (3) Double-click the print.print_unwriteable_margin_bottom preference and change it from -1 to 0 (zero) (4) If there is a nonzero unwriteable_margin_bottom for your printer, set that to 0 as well. Any difference?

Performed 3: no difference, but thanks for trying. The 3 lines referring to the 'IBM' printer print margins were already at 0, by the way.

more options

Soluzione scelta

Hmm, in your screen shots, why does the title bar of the window mention Yahoo mail? Is this an attachment that is somehow embedded in the message? If so, can you find a way to view it in its own tab? Sometimes right-click > This Frame > Open Frame in New Tab will do it, but I haven't opened Yahoo Mail to experiment.

more options

It's an attachment in Yahoo Mail, hence the tab. I don't use Firefox as Fullscreen even for viewing PDFs.

But... I tried fiddling around with downloading the document and then opening it and then setting the scale custom to 95% so it fits lengthwise and then printing.

Instead of the massive blank space I was expecting on the right (as I'd shrunk it apparently so small as seen on the Preview), it turned out that the paper wasn't as wide as Print Preview was suggesting. So now, I have the paper printed slightly off-centre to the page, but passable.

And now I have printed the document, print preview has modified the paper size so it looks right too.

Tried on another document, and again goes funny when I open the attachment from Yahoo, but if I download it and open in Firefox, it works as above, well: not quite as well, but just about okay although this time the blank space on the right on the Preview won't go away after printing. What is really odd is that changing the print resolution seems to affect the size of printed document so it only works properly(ish) at the high quality setting. But it's a start.

THANK YOU

Modificato da RBay il