X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 34.0.5 is blocking "necessary" popups & preventing me from viewing/using several sites, even though I've un- checked the box, "Block Popups".

Inserita

Hi! I've been having an unusual problem relating to, what I was told is the "built-in popup blocker" in Firefox, & that there's an about:config setting(s) that I need to change. Here are the problems I've been having: 1. When I try to place an order online I can't use Firefox, (& I'm forced to use the nasty old IE), because when I click on certain items I don't get the small drop-down menu that allows me to choose the flavor/size/quantity. (e.g. My dog's chew bones come in 4 flavors, but when I click on the bones I want I don't get the little drop-down menu that shows the flavors; I'm unable to continue placing the order because the site needs to know what flavor I want to order) 2. There are 5 sites showing streaming media of "nest-cams" of Bald Eagles; Peregrine Falcons & various other wildlife that I view daily. One site is http://www.wildearth.tv/cam/pittsburgh-bald-eagles; however, I can't view the site on my PC because this site, (& the other 4 as well), rely on "pop-up ads" for revenue, & if you have a free account rather than a paid subscription, the pop-up ads are just part of the viewing experience on the site. I was told by one of the Moderators that Firefox has a 'built-in' pop-up blocker, (not one that's added on as an extension/add-on/plugin), & that there's an about:config setting(s) that I need to change so I'm able to view my nest-cams on their sites. ***IMPORTANT INFORMATION*** If I go to any of the 5 'problem' sites using my iPad...sitting only inches away from my PC...using the same Internet connection...I can watch these sites perfectly!! Weird, huh?!?! So, I was told I need to go to about:config & make adjustment(s), but I don't want to screw anything up! I went there & looked through everything & there are several lines containing the word "pop-up", so I need the advice of someone who knows what to do. Tada...so her I am bothering you nice people! I'm running Windows 8.1 & using Firefox 34.0.5, (this is the device that won't let me view the nest cams); my iPad is new, v.8, (I think)..& I can & do watch any site I want, (including the 5 'problem' sites any time I want...the picture is too tiny for regular viewing & I can't take screenshots for the detailed records I keep, or I'd just use my iPad all the time). I have the box in Tools>Options UN-checked for 'Block Pop-up Windows', & I do NOT have any other pop-up blocker enabled in Firefox. I hope I gave enough info, but if you need to know anything else, just ask. Thank you for taking the time to read my post, & thanks in advance for any suggestions/instructions you may provide. I really need to be able to access these 5 sites using my PC because the nest-cams have been turned on for the 2015 Season & I'm desperate to get this matter resolved. It won't be long till there are eggs being laid & I have to be ready!  :) Thanks a bunch! Nuts4Mutts  :)

Hi! I've been having an unusual problem relating to, what I was told is the "built-in popup blocker" in Firefox, & that there's an about:config setting(s) that I need to change. Here are the problems I've been having: 1. When I try to place an order online I can't use Firefox, (& I'm forced to use the nasty old IE), because when I click on certain items I don't get the small drop-down menu that allows me to choose the flavor/size/quantity. (e.g. My dog's chew bones come in 4 flavors, but when I click on the bones I want I don't get the little drop-down menu that shows the flavors; I'm unable to continue placing the order because the site needs to know what flavor I want to order) 2. There are 5 sites showing streaming media of "nest-cams" of Bald Eagles; Peregrine Falcons & various other wildlife that I view daily. One site is http://www.wildearth.tv/cam/pittsburgh-bald-eagles; however, I can't view the site on my PC because this site, (& the other 4 as well), rely on "pop-up ads" for revenue, & if you have a free account rather than a paid subscription, the pop-up ads are just part of the viewing experience on the site. I was told by one of the Moderators that Firefox has a 'built-in' pop-up blocker, (not one that's added on as an extension/add-on/plugin), & that there's an about:config setting(s) that I need to change so I'm able to view my nest-cams on their sites. ***IMPORTANT INFORMATION*** If I go to any of the 5 'problem' sites using my iPad...sitting only inches away from my PC...using the same Internet connection...I can watch these sites perfectly!! Weird, huh?!?! So, I was told I need to go to about:config & make adjustment(s), but I don't want to screw anything up! I went there & looked through everything & there are several lines containing the word "pop-up", so I need the advice of someone who knows what to do. Tada...so her I am bothering you nice people! I'm running Windows 8.1 & using Firefox 34.0.5, (this is the device that won't let me view the nest cams); my iPad is new, v.8, (I think)..& I can & do watch any site I want, (including the 5 'problem' sites any time I want...the picture is too tiny for regular viewing & I can't take screenshots for the detailed records I keep, or I'd just use my iPad all the time). I have the box in Tools>Options UN-checked for 'Block Pop-up Windows', & I do NOT have any other pop-up blocker enabled in Firefox. I hope I gave enough info, but if you need to know anything else, just ask. Thank you for taking the time to read my post, & thanks in advance for any suggestions/instructions you may provide. I really need to be able to access these 5 sites using my PC because the nest-cams have been turned on for the 2015 Season & I'm desperate to get this matter resolved. It won't be long till there are eggs being laid & I have to be ready! :) Thanks a bunch! Nuts4Mutts :)

Dettagli aggiuntivi sul sistema

Plugin installati

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Exent® AOD Gecko Plugin
  • np-rf-plugin
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.4.154
  • 5.1.30514.0
  • WildTangent Games App V2 Presence Detector

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Ulteriori informazioni

freakedout 1 soluzioni 6 risposte

Try restarting Firefox first and then restarting your computer if that solution fails.

Try restarting Firefox first and then restarting your computer if that solution fails.

Utente che ha posto la domanda

Hi! I must've missed something, freakedout, what solution do you mean? As far as restarting/rebooting, etc., I've done that so many times I can do it in my sleep! I really need to know what I should change in about:config so Firefox stops blocking 'necessary' popups. Please clarify your response if I missed something RE: 'solution' Thanks

Hi! I must've missed something, freakedout, what solution do you mean? As far as restarting/rebooting, etc., I've done that so many times I can do it in my sleep! I really need to know what I should change in about:config so Firefox stops blocking 'necessary' popups. Please clarify your response if I missed something RE: 'solution' Thanks
FredMcD
  • Top 10 Contributor
4269 soluzioni 59855 risposte

Type about:preferences#content<enter> in the address bar Under Content turn on Block pop-up windows. To its right, press Exceptions. List any sites that you do not want pop-ups to be blocked.

Type '''about:preferences#content'''<enter> in the address bar Under '''Content''' turn on '''Block pop-up windows.''' To its right, press '''Exceptions.''' List any sites that you do not want pop-ups to be blocked.

Utente che ha posto la domanda

Hi FredMcD, I tried your suggestion, but it doesn't help...thanks anyway for trying!

I guess I wasn't specific enough...a Moderator at WildEarth told me I needed to make changes in "about:config", because there is a built-in popup blocker in Firefox by default, that's different from the popup blocker we can control by checking/unchecking the little box in Tools>Options...it's also different from popup blockers we can add as addons/plugins/extensions.

I went to about:config & there are several entries that include "popup(s)", it's just that I don't know which line I need to change so I can access websites that can't function without "necessary" popups, (please see my initial post explaining what's blocked by Firefox that prevents me from doing online shopping; viewing streaming nest-cams that rely on popup ads for their revenue).

Thanks for your input, but adding the effected sites as exceptions doesn't work. I tried many different configurations adding/removing the 5 sites that "don't work", & I even UN-checked the box for "block popups", & none of these made these sites function correctly.

If you go to about:config you can see the entries that include "popup". I found several, & according to the Moderator I need to make change(s) to the one that's blocking popups that should NOT be blocked, (like those I explained in my first post).

Thanks again, though. Please keep trying everyone! Nuts4Mutts :)

Hi FredMcD, I tried your suggestion, but it doesn't help...thanks anyway for trying! I guess I wasn't specific enough...a Moderator at WildEarth told me I needed to make changes in "about:config", because there is a built-in popup blocker in Firefox by default, that's different from the popup blocker we can control by checking/unchecking the little box in Tools>Options...it's also different from popup blockers we can add as addons/plugins/extensions. I went to about:config & there are several entries that include "popup(s)", it's just that I don't know which line I need to change so I can access websites that can't function without "necessary" popups, (please see my initial post explaining what's blocked by Firefox that prevents me from doing online shopping; viewing streaming nest-cams that rely on popup ads for their revenue). Thanks for your input, but adding the effected sites as exceptions doesn't work. I tried many different configurations adding/removing the 5 sites that "don't work", & I even UN-checked the box for "block popups", & none of these made these sites function correctly. If you go to about:config you can see the entries that include "popup". I found several, & according to the Moderator I need to make change(s) to the one that's blocking popups that should NOT be blocked, (like those I explained in my first post). Thanks again, though. Please keep trying everyone! Nuts4Mutts :)
FredMcD
  • Top 10 Contributor
4269 soluzioni 59855 risposte

On the about:config page, if you know what you are doing, or following directions of someone who does, be careful. If you are not sure about something, or don't know what you are doing . . . . . . . . STOP ! !


Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


I've called the big guys to help you. Good luck.

On the about:config page, if you know what you are doing, or following directions of someone who does, be careful. If you are not sure about something, or don't know what you are doing''' . . . . . . . . STOP ! !''' --------------- Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' --------------- '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? ------------------ I've called the big guys to help you. Good luck.

Utente che ha posto la domanda

FredMcD said

On the about:config page, if you know what you are doing, or following directions of someone who does, be careful. If you are not sure about something, or don't know what you are doing . . . . . . . . STOP ! !

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


I've called the big guys to help you. Good luck.

Hi FredMcD! A million blessings are coming your way!!!...this is exactly the info I need to get started! I have a question before I begin, though...after I make the changes in about:config, is closing & reopening Firefox enough, or should I reboot my PC to make sure the changes take effect? I want to make sure I do it right the first time! I also appreciate your warning about venturing into about:config-land...I used Firefox for 6 years before I even had the nerve to look there! That's why I came here for help, because I know Firefox-ers know their stuff & they like to help each other; it's hard to find that great combo sometimes, especially when dealing with tech issues. Thanks for reminding me about being careful. I'll go & disable all my addons then check back for your answer about restarting Firefox vs. rebooting my PC after making the changes. I hope I'll have good news to report! ;) Thanks SO much for getting the "big guys" involved...I KNOW that there's a light at the end of this dark tunnel after all! Thanks again! Nuts4Mutts  :)

''FredMcD [[#answer-672988|said]]'' <blockquote> On the about:config page, if you know what you are doing, or following directions of someone who does, be careful. If you are not sure about something, or don't know what you are doing''' . . . . . . . . STOP ! !''' --------------- Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' --------------- '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? ------------------ I've called the big guys to help you. Good luck. </blockquote> Hi FredMcD! A million blessings are coming your way!!!...this is exactly the info I need to get started! I have a question before I begin, though...after I make the changes in about:config, is closing & reopening Firefox enough, or should I reboot my PC to make sure the changes take effect? I want to make sure I do it right the first time! I also appreciate your warning about venturing into about:config-land...I used Firefox for 6 years before I even had the nerve to look there! That's why I came here for help, because I know Firefox-ers know their stuff & they like to help each other; it's hard to find that great combo sometimes, especially when dealing with tech issues. Thanks for reminding me about being careful. I'll go & disable all my addons then check back for your answer about restarting Firefox vs. rebooting my PC after making the changes. I hope I'll have good news to report! ;) Thanks SO much for getting the "big guys" involved...I KNOW that there's a light at the end of this dark tunnel after all! Thanks again! Nuts4Mutts :)
FredMcD
  • Top 10 Contributor
4269 soluzioni 59855 risposte

Nuts4Mutts said

after I make the changes in about:config, is closing & reopening Firefox enough, or should I reboot my PC to make sure the changes take effect?

Most about:config settings and Preference changes will take effect immanently. But some do require that Firefox be restarted.

''Nuts4Mutts [[#answer-673017|said]]'' <blockquote> after I make the changes in about:config, is closing & reopening Firefox enough, or should I reboot my PC to make sure the changes take effect? </blockquote> Most '''about:config''' settings and '''Preference''' changes will take effect immanently. But some do require that Firefox be restarted.

Utente che ha posto la domanda

Hi FredMcD! Well, as lots of stories go...I have some good news & some bad news. The really good news is that after lots of enabling, disabling, restarting & all that stuff, I was able to go to the online pet supply store & get the little dropdown menu for selecting the flavor of my dog's treats! Yipppee! I'm excited & my doggy's even more excited! The bad news is there must be more popup blocking being done that I can't control yet, because I still can't view those 5 'problem' sites I mentioned earlier. Did the "big guys" tell you about any other lines in about:config that are ad/popup blockers, & if so, what do I change them to? In the months that I've been unable to go to these sites I did lots of searching online, & it seems to be an issue that effects lots of people. It usually points to a popup blocker problem, especially when the plugin error message is involved, (as it is in my case). In reading my earlier posts in this thread, I noticed I didn't mention the error message...I thought I included it, but since I've been posting this problem on a few windows-related help forums I think I must've gotten forums messed up! After working on the same problem for months now, I think my brain's starting to turn to mush! Here's the error message I get on those 5 sites, (it's the same error that all the other people get, too)...the sites that rely on popup ads for revenue, the page opens, the Adobe Flash player starts to load, then a black screen appears with this message:

                                    Error loading plugin: 
                                    Plugin file not found

Adobe's forum told me it's not a Flash-related issue & the several instances I found on the Internet ALL get the above error message. In one case, it was a site where the person watched streaming media, & after they'd updated their popup blocker, the player would load, but they got the error message; when they entered the site as an exception, it blocked the popup ads AND the streaming media as well. Anyway, it seems that this is not an isolated incident with me, & it seems to take a while to figure out what's being blocked by what...just like your instructions led me to finding what was preventing me from placing an online order for dog treats. You've helped me immensely & I can finally stop checking/unchecking every item that was being blocked...how great! I order from that site monthly, (at least), & now I don't ever have to use IE again!! Tomorrow the quest to access the 5 'problem' sites continues, so I'm gonna get some sleep to recharge my battery. I'm hoping the "big guys" gave you more things I can try so I can access ALL sites I need to. Thank you SO much for your help today...especially for sticking with me all day, & please thank the "big guys" for me, too! Gratefully, Nuts4Mutts  :)

Hi FredMcD! Well, as lots of stories go...I have some good news & some bad news. The really good news is that after lots of enabling, disabling, restarting & all that stuff, I was able to go to the online pet supply store & get the little dropdown menu for selecting the flavor of my dog's treats! Yipppee! I'm excited & my doggy's even more excited! The bad news is there must be more popup blocking being done that I can't control yet, because I still can't view those 5 'problem' sites I mentioned earlier. Did the "big guys" tell you about any other lines in about:config that are ad/popup blockers, & if so, what do I change them to? In the months that I've been unable to go to these sites I did lots of searching online, & it seems to be an issue that effects lots of people. It usually points to a popup blocker problem, especially when the plugin error message is involved, (as it is in my case). In reading my earlier posts in this thread, I noticed I didn't mention the error message...I thought I included it, but since I've been posting this problem on a few windows-related help forums I think I must've gotten forums messed up! After working on the same problem for months now, I think my brain's starting to turn to mush! Here's the error message I get on those 5 sites, (it's the same error that all the other people get, too)...the sites that rely on popup ads for revenue, the page opens, the Adobe Flash player starts to load, then a black screen appears with this message: Error loading plugin: Plugin file not found Adobe's forum told me it's not a Flash-related issue & the several instances I found on the Internet ALL get the above error message. In one case, it was a site where the person watched streaming media, & after they'd updated their popup blocker, the player would load, but they got the error message; when they entered the site as an exception, it blocked the popup ads AND the streaming media as well. Anyway, it seems that this is not an isolated incident with me, & it seems to take a while to figure out what's being blocked by what...just like your instructions led me to finding what was preventing me from placing an online order for dog treats. You've helped me immensely & I can finally stop checking/unchecking every item that was being blocked...how great! I order from that site monthly, (at least), & now I don't ever have to use IE again!! Tomorrow the quest to access the 5 'problem' sites continues, so I'm gonna get some sleep to recharge my battery. I'm hoping the "big guys" gave you more things I can try so I can access ALL sites I need to. Thank you SO much for your help today...especially for sticking with me all day, & please thank the "big guys" for me, too! Gratefully, Nuts4Mutts :)
FredMcD
  • Top 10 Contributor
4269 soluzioni 59855 risposte

The Big Guys will respond on this post. Give them time.


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

The Big Guys will respond on this post. Give them time. ---------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
cor-el
  • Top 10 Contributor
  • Moderator
17573 soluzioni 158957 risposte

Try to uninstall and reinstall Flash.

You can uninstall the current Flash player version and (re)install the latest Flash version.

See this about uninstalling Flash players:

Note that this will remove all installed Flash players.

You can find the latest Flash player versions for Firefox on this page:


You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Try to uninstall and reinstall Flash. You can uninstall the current Flash player version and (re)install the latest Flash version. See this about uninstalling Flash players: *http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Note that this will remove all installed Flash players. You can find the latest Flash player versions for Firefox on this page: *http://www.adobe.com/special/products/flashplayer/fp_distribution3.html ---- You can inspect and manage permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.